summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Januszewski <spock@gentoo.org>2006-10-14 17:21:59 +0000
committerMichael Januszewski <spock@gentoo.org>2006-10-14 17:21:59 +0000
commitbb7d1a86eafc988605e36f0b5c3733ce78b9c12c (patch)
tree13cd11c679e6e4f0eeac7df6c0aa4d843e6c3fd5 /dev-util/oprofile/oprofile-0.9.1-r1.ebuild
parentFixed bug #151038. (diff)
downloadgentoo-2-bb7d1a86eafc988605e36f0b5c3733ce78b9c12c.tar.gz
gentoo-2-bb7d1a86eafc988605e36f0b5c3733ce78b9c12c.tar.bz2
gentoo-2-bb7d1a86eafc988605e36f0b5c3733ce78b9c12c.zip
Remove 'check_KV' calls (bug #150058).
(Portage version: 2.1.2_pre2-r9)
Diffstat (limited to 'dev-util/oprofile/oprofile-0.9.1-r1.ebuild')
-rw-r--r--dev-util/oprofile/oprofile-0.9.1-r1.ebuild14
1 files changed, 6 insertions, 8 deletions
diff --git a/dev-util/oprofile/oprofile-0.9.1-r1.ebuild b/dev-util/oprofile/oprofile-0.9.1-r1.ebuild
index 3d7927201b44..a04b079b5e80 100644
--- a/dev-util/oprofile/oprofile-0.9.1-r1.ebuild
+++ b/dev-util/oprofile/oprofile-0.9.1-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.1-r1.ebuild,v 1.9 2006/09/07 05:25:56 wormo Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.1-r1.ebuild,v 1.10 2006/10/14 17:21:59 spock Exp $
-inherit eutils qt3
+inherit eutils qt3 linux-info
DESCRIPTION="A transparent low-overhead system-wide profiler"
HOMEPAGE="http://oprofile.sourceforge.net"
@@ -28,8 +28,6 @@ src_unpack() {
}
src_compile() {
- check_KV
-
local myconf=""
if use qt3
@@ -48,10 +46,10 @@ src_compile() {
myconf="${myconf} --with-x"
- case $KV in
- 2.2.*|2.4.*) myconf="${myconf} --with-linux=/usr/src/linux";;
+ case ${KV_FULL} in
+ 2.2.*|2.4.*) myconf="${myconf} --with-linux=${KV_DIR}";;
2.5.*|2.6.*) myconf="${myconf} --with-kernel-support";;
- *) die "Kernel version '$KV' not supported";;
+ *) die "Kernel version '${KV_FULL}' not supported";;
esac
econf ${myconf} || die "econf failed"
@@ -64,7 +62,7 @@ src_compile() {
src_install() {
local myinst=""
- myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV}"
+ myinst="${myinst} MODINSTALLDIR=${D}/lib/modules/${KV_FULL}"
make DESTDIR=${D} ${myinst} install || die "make install failed"
dodoc ChangeLog* README TODO