summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-26 20:45:09 +0000
committerDiego Elio Pettenò <flameeyes@gentoo.org>2009-05-26 20:45:09 +0000
commitf18e3ecb7003475f6e7cadad589d6aed88efc3df (patch)
treeb2b098586c15fb7d8d04846dfa93ae3d7a35774f /dev-util/oprofile
parentAdd check for libgnomeui; bug #263367 (diff)
downloadgentoo-2-f18e3ecb7003475f6e7cadad589d6aed88efc3df.tar.gz
gentoo-2-f18e3ecb7003475f6e7cadad589d6aed88efc3df.tar.bz2
gentoo-2-f18e3ecb7003475f6e7cadad589d6aed88efc3df.zip
Add patch to fix building with glibc-2.10. Closes bug #270640.
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/oprofile')
-rw-r--r--dev-util/oprofile/ChangeLog8
-rw-r--r--dev-util/oprofile/files/oprofile-0.9.4+glibc-2.10.patch14
-rw-r--r--dev-util/oprofile/oprofile-0.9.4.ebuild7
3 files changed, 25 insertions, 4 deletions
diff --git a/dev-util/oprofile/ChangeLog b/dev-util/oprofile/ChangeLog
index 962a3541bed7..82d240f8afa3 100644
--- a/dev-util/oprofile/ChangeLog
+++ b/dev-util/oprofile/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/oprofile
-# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.56 2009/03/22 07:51:19 spock Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/ChangeLog,v 1.57 2009/05/26 20:45:09 flameeyes Exp $
+
+ 26 May 2009; Diego E. Pettenò <flameeyes@gentoo.org>
+ oprofile-0.9.4.ebuild, +files/oprofile-0.9.4+glibc-2.10.patch:
+ Add patch to fix building with glibc-2.10. Closes bug #270640.
21 Mar 2009; Michał Januszewski <spock@gentoo.org> oprofile-0.9.4.ebuild:
Fix the postinst messages so that they point to the correct location of
diff --git a/dev-util/oprofile/files/oprofile-0.9.4+glibc-2.10.patch b/dev-util/oprofile/files/oprofile-0.9.4+glibc-2.10.patch
new file mode 100644
index 000000000000..fa3d5bb53a56
--- /dev/null
+++ b/dev-util/oprofile/files/oprofile-0.9.4+glibc-2.10.patch
@@ -0,0 +1,14 @@
+Index: oprofile-0.9.4/configure.in
+===================================================================
+--- oprofile-0.9.4.orig/configure.in
++++ oprofile-0.9.4/configure.in
+@@ -96,6 +96,9 @@ ORIG_SAVE_LIBS="$LIBS"
+ dnl advanced glibc features which we need but may not be present
+ AC_CHECK_FUNCS(sched_setaffinity perfmonctl)
+
++AC_USE_SYSTEM_EXTENSIONS
++AC_CHECK_DECLS_ONCE([basename])
++
+ AC_CHECK_LIB(popt, poptGetContext,, AC_MSG_ERROR([popt library not found]))
+
+ AX_BINUTILS
diff --git a/dev-util/oprofile/oprofile-0.9.4.ebuild b/dev-util/oprofile/oprofile-0.9.4.ebuild
index 5c65a424cb54..766c09e788f8 100644
--- a/dev-util/oprofile/oprofile-0.9.4.ebuild
+++ b/dev-util/oprofile/oprofile-0.9.4.ebuild
@@ -1,10 +1,10 @@
# Copyright 1999-2009 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.4.ebuild,v 1.7 2009/03/22 07:51:19 spock Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/oprofile/oprofile-0.9.4.ebuild,v 1.8 2009/05/26 20:45:09 flameeyes Exp $
EAPI=1
-inherit eutils qt3 linux-info
+inherit eutils qt3 linux-info autotools
DESCRIPTION="A transparent low-overhead system-wide profiler"
HOMEPAGE="http://oprofile.sourceforge.net"
@@ -32,6 +32,9 @@ src_unpack() {
cd "${S}"
epatch "${FILESDIR}/${P}-gcc43.patch"
epatch "${FILESDIR}/${P}-open.patch"
+ epatch "${FILESDIR}/${P}+glibc-2.10.patch"
+
+ eautoreconf
}
src_compile() {