summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2013-03-08 17:02:30 +0000
committerJustin Lecher <jlec@gentoo.org>2013-03-08 17:02:30 +0000
commite18ae942bc2d0ab40e640ff1c7afc864ff118c5c (patch)
tree5ff6f796ec68366778b43c8f377a335d4547b654 /dev-util/patchelf
parentStable for HPPA (bug #457882). (diff)
downloadgentoo-2-e18ae942bc2d0ab40e640ff1c7afc864ff118c5c.tar.gz
gentoo-2-e18ae942bc2d0ab40e640ff1c7afc864ff118c5c.tar.bz2
gentoo-2-e18ae942bc2d0ab40e640ff1c7afc864ff118c5c.zip
dev-util/patchelf: Enhance the patch for as-needed problems
(Portage version: 2.2.0_alpha166/cvs/Linux x86_64, signed Manifest commit with key 70EB7916)
Diffstat (limited to 'dev-util/patchelf')
-rw-r--r--dev-util/patchelf/ChangeLog6
-rw-r--r--dev-util/patchelf/files/patchelf-0.6-test-build.patch15
2 files changed, 13 insertions, 8 deletions
diff --git a/dev-util/patchelf/ChangeLog b/dev-util/patchelf/ChangeLog
index 4dec40fbe616..1f220842eb4a 100644
--- a/dev-util/patchelf/ChangeLog
+++ b/dev-util/patchelf/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/patchelf
# Copyright 1999-2013 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/patchelf/ChangeLog,v 1.7 2013/03/08 13:38:10 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/patchelf/ChangeLog,v 1.8 2013/03/08 17:02:30 jlec Exp $
+
+ 08 Mar 2013; Justin Lecher <jlec@gentoo.org>
+ files/patchelf-0.6-test-build.patch:
+ Enhance the patch for as-needed problems
08 Mar 2013; Justin Lecher <jlec@gentoo.org>
files/patchelf-0.6-test-build.patch:
diff --git a/dev-util/patchelf/files/patchelf-0.6-test-build.patch b/dev-util/patchelf/files/patchelf-0.6-test-build.patch
index 4d741b525ca0..2f88b2af7cfc 100644
--- a/dev-util/patchelf/files/patchelf-0.6-test-build.patch
+++ b/dev-util/patchelf/files/patchelf-0.6-test-build.patch
@@ -1,8 +1,8 @@
- tests/Makefile.am | 22 +++++++++++-----------
- 1 file changed, 11 insertions(+), 11 deletions(-)
+ tests/Makefile.am | 24 ++++++++++++------------
+ 1 file changed, 12 insertions(+), 12 deletions(-)
diff --git a/tests/Makefile.am b/tests/Makefile.am
-index 9d9b6bc..f345f46 100644
+index 9d9b6bc..93677a3 100644
--- a/tests/Makefile.am
+++ b/tests/Makefile.am
@@ -11,38 +11,38 @@ simple_SOURCES = simple.c
@@ -14,9 +14,10 @@ index 9d9b6bc..f345f46 100644
+main: main.o libfoo.so libbar.so
+ $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -o main main.o -L . -lfoo -lbar
- main-scoped: main.o libfoo-scoped.so
+-main-scoped: main.o libfoo-scoped.so
- LD_LIBRARY_PATH=. gcc -Wl,--enable-new-dtags -o main-scoped main.o -L . -lfoo-scoped
-+ $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--enable-new-dtags -o main-scoped main.o -L . -lfoo-scoped
++main-scoped: main.o libfoo-scoped.so libbar-scoped.so
++ LD_LIBRARY_PATH=. $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--enable-new-dtags -o main-scoped main.o -L . -lfoo-scoped -lbar-scoped
main.o: main.c
- $(CC) -fpic -o main.o -c main.c
@@ -36,7 +37,7 @@ index 9d9b6bc..f345f46 100644
libbar.so: bar.o
- NIX_DONT_SET_RPATH=1 $(CC) -Wl,--disable-new-dtags -shared -o libbar.so bar.o -L . -Wl,-rpath,`pwd`/no-such-path
-+ NIX_DONT_SET_RPATH=1 $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -shared -o libbar.so bar.o -L . -Wl,-rpath,`pwd`/no-such-path
++ NIX_DONT_SET_RPATH=1 $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -shared -o libbar.so bar.o -L. -Wl,-rpath,`pwd`/no-such-path
libbar-scoped.so: bar.o
- NIX_DONT_SET_RPATH=1 $(CC) -Wl,--enable-new-dtags -shared -o libbar-scoped.so bar.o
@@ -51,7 +52,7 @@ index 9d9b6bc..f345f46 100644
big-dynstr: big-dynstr.o libfoo.so
- LD_LIBRARY_PATH=. gcc -Wl,--disable-new-dtags -o big-dynstr big-dynstr.o -L . -lfoo
-+ $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -o big-dynstr big-dynstr.o -L . -lfoo
++ LD_LIBRARY_PATH=. $(CC) $(LDFLAGS) $(CFLAGS) -Wl,--disable-new-dtags -o big-dynstr big-dynstr.o -L . -lfoo
big-dynstr.c: main.c
cat main.c > big-dynstr.c