summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-23 23:57:06 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2010-06-23 23:57:06 +0000
commite32fa1da0683831b0bd112ff65d8eb394b2c8de2 (patch)
treeda830201aace6bddc1d12e4aea8cea59f7d653ba /dev-util/pida
parentDelete older ebuilds. (diff)
downloadgentoo-2-e32fa1da0683831b0bd112ff65d8eb394b2c8de2.tar.gz
gentoo-2-e32fa1da0683831b0bd112ff65d8eb394b2c8de2.tar.bz2
gentoo-2-e32fa1da0683831b0bd112ff65d8eb394b2c8de2.zip
Version bump (bug #323863). Set SUPPORT_PYTHON_ABIS.
(Portage version: HEAD/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/pida')
-rw-r--r--dev-util/pida/ChangeLog9
-rw-r--r--dev-util/pida/files/pida-0.6.1-fix_implicit_declaration.patch10
-rw-r--r--dev-util/pida/pida-0.6.1.ebuild39
3 files changed, 57 insertions, 1 deletions
diff --git a/dev-util/pida/ChangeLog b/dev-util/pida/ChangeLog
index e2ae15299a2b..0389371a2313 100644
--- a/dev-util/pida/ChangeLog
+++ b/dev-util/pida/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/pida
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/ChangeLog,v 1.22 2010/01/15 21:49:24 fauli Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/ChangeLog,v 1.23 2010/06/23 23:57:05 arfrever Exp $
+
+*pida-0.6.1 (23 Jun 2010)
+
+ 23 Jun 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ -pida-0.5.1.ebuild, -pida-0.5.1-r1.ebuild, +pida-0.6.1.ebuild,
+ +files/pida-0.6.1-fix_implicit_declaration.patch:
+ Version bump (bug #323863). Set SUPPORT_PYTHON_ABIS.
15 Jan 2010; Christian Faulhammer <fauli@gentoo.org> pida-0.5.1-r1.ebuild:
Transfer Prefix keywords
diff --git a/dev-util/pida/files/pida-0.6.1-fix_implicit_declaration.patch b/dev-util/pida/files/pida-0.6.1-fix_implicit_declaration.patch
new file mode 100644
index 000000000000..0636a0dd7279
--- /dev/null
+++ b/dev-util/pida/files/pida-0.6.1-fix_implicit_declaration.patch
@@ -0,0 +1,10 @@
+--- contrib/moo/moo.override
++++ contrib/moo/moo.override
+@@ -6,6 +6,7 @@
+ #include <pygobject.h>
+ #include <pygtk/pygtk.h>
+ #include "moobigpaned.h"
++#include "moopython-utils.h"
+ %%
+ modulename moo_stub
+ %%
diff --git a/dev-util/pida/pida-0.6.1.ebuild b/dev-util/pida/pida-0.6.1.ebuild
new file mode 100644
index 000000000000..bb0d4a4bfe20
--- /dev/null
+++ b/dev-util/pida/pida-0.6.1.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pida/pida-0.6.1.ebuild,v 1.1 2010/06/23 23:57:05 arfrever Exp $
+
+EAPI="3"
+PYTHON_DEPEND="2"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.*"
+
+inherit distutils eutils
+
+DESCRIPTION="Gtk and/or Vim-based Python Integrated Development Application"
+HOMEPAGE="http://pida.co.uk/ http://pypi.python.org/pypi/pida"
+SRC_URI="http://pypi.python.org/packages/source/${PN:0:1}/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86 ~x86-interix ~amd64-linux ~x86-linux"
+IUSE="gnome"
+
+RDEPEND="|| ( >=dev-lang/python-2.6 dev-python/simplejson )
+ >=app-editors/gvim-6.3
+ >=dev-python/anyvc-0.3
+ >=dev-python/pygtk-2.8
+ dev-python/pygtkhelpers
+ gnome? ( >=x11-libs/vte-0.11.11-r2[python] )"
+DEPEND="${RDEPEND}
+ dev-python/setuptools
+ dev-util/pkgconfig"
+
+src_prepare() {
+ epatch "${FILESDIR}/${P}-fix_implicit_declaration.patch"
+ emake -C contrib/moo moo-pygtk.c
+}
+
+src_install() {
+ distutils_src_install
+ make_desktop_entry pida Pida pida/resources/pixmaps/pida-icon.png Development
+}