summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSantiago M. Mola <coldwind@gentoo.org>2008-03-11 13:03:53 +0000
committerSantiago M. Mola <coldwind@gentoo.org>2008-03-11 13:03:53 +0000
commit12ae860f27fd6985f49463153fd7162de1aab259 (patch)
treee49f577c0b8eca44bab1242c947dcf7117db8e84 /dev-util/plan9port
parentrevamp ebuild, proposed by jokey in bug 212984 (diff)
downloadgentoo-2-12ae860f27fd6985f49463153fd7162de1aab259.tar.gz
gentoo-2-12ae860f27fd6985f49463153fd7162de1aab259.tar.bz2
gentoo-2-12ae860f27fd6985f49463153fd7162de1aab259.zip
Version bump, added patch to fix shebangs (bug #201404), marked ~amd64 (bug #209553), use elog.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util/plan9port')
-rw-r--r--dev-util/plan9port/ChangeLog11
-rw-r--r--dev-util/plan9port/plan9port-20070522.ebuild6
-rw-r--r--dev-util/plan9port/plan9port-20080130.ebuild67
3 files changed, 79 insertions, 5 deletions
diff --git a/dev-util/plan9port/ChangeLog b/dev-util/plan9port/ChangeLog
index 9f29b9bb4be4..1a3d3d2da6d8 100644
--- a/dev-util/plan9port/ChangeLog
+++ b/dev-util/plan9port/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/plan9port
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/ChangeLog,v 1.1 2007/05/29 02:11:27 anant Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/ChangeLog,v 1.2 2008/03/11 13:03:53 coldwind Exp $
+
+*plan9port-20080130 (11 Mar 2008)
+
+ 11 Mar 2008; Santiago M. Mola <coldwind@gentoo.org>
+ plan9port-20070522.ebuild, +plan9port-20080130.ebuild:
+ Version bump, added patch to fix shebangs (bug #201404), marked ~amd64 (bug
+ #209553), use elog.
*plan9port-20070522 (29 May 2007)
diff --git a/dev-util/plan9port/plan9port-20070522.ebuild b/dev-util/plan9port/plan9port-20070522.ebuild
index fa2857d1f12d..0b7f46cd2819 100644
--- a/dev-util/plan9port/plan9port-20070522.ebuild
+++ b/dev-util/plan9port/plan9port-20070522.ebuild
@@ -1,6 +1,6 @@
-# Copyright 1999-2007 Gentoo Foundation
+# Copyright 1999-2008 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20070522.ebuild,v 1.1 2007/05/29 02:11:27 anant Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20070522.ebuild,v 1.2 2008/03/11 13:03:53 coldwind Exp $
DESCRIPTION="Plan 9 From User Space"
HOMEPAGE="http://swtch.com/plan9port/"
@@ -8,7 +8,7 @@ SRC_URI="http://www.kix.in/plan9/${PN}-repack-${PV}.tar.bz2"
LICENSE="MIT"
SLOT="0"
-KEYWORDS="~x86"
+KEYWORDS="~amd64 ~x86"
IUSE=""
DEPEND="x11-base/xorg-server"
diff --git a/dev-util/plan9port/plan9port-20080130.ebuild b/dev-util/plan9port/plan9port-20080130.ebuild
new file mode 100644
index 000000000000..20b961c2f05f
--- /dev/null
+++ b/dev-util/plan9port/plan9port-20080130.ebuild
@@ -0,0 +1,67 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/plan9port/plan9port-20080130.ebuild,v 1.1 2008/03/11 13:03:53 coldwind Exp $
+
+inherit eutils
+
+DESCRIPTION="Plan 9 From User Space"
+HOMEPAGE="http://swtch.com/plan9port/"
+SRC_URI="mirror://gentoo/${PN}-repack-${PV}.tar.bz2
+ mirror://gentoo/${P}-paths.patch.bz2"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="x11-base/xorg-server"
+RDEPEND=""
+
+S="${WORKDIR}/plan9"
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Fix shebangs (bug #209553) and all paths.
+ epatch "${WORKDIR}"/${P}-paths.patch
+}
+
+src_compile() {
+ einfo " "
+ einfo "Compiling Plan 9 from User Space can take a very long time "
+ einfo "depending on the speed of your computer. Please be patient! "
+ einfo " "
+ ./INSTALL -b
+}
+
+src_install() {
+ dodir /usr/lib/plan9
+ mv "${S}" "${D}"/usr/lib/
+ doenvd "${FILESDIR}/30plan9"
+}
+
+pkg_postinst() {
+ einfo " "
+ einfo "Recalibrating Plan 9 from User Space to its new environment. "
+ einfo "This could take a while... "
+ einfo " "
+
+ cd /usr/lib/plan9
+ export PATH="$PATH:/usr/lib/plan9"
+ ./INSTALL -c &> /dev/null
+
+ elog " "
+ elog "Plan 9 from User Space has been successfully installed into "
+ elog "/usr/lib/plan9. Your PLAN9 and PATH environment variables "
+ elog "have also been appropriately set, please use env-update and "
+ elog "source /etc/profile to bring that into immediate effect. "
+ elog " "
+ elog "Please note that \${PLAN9}/bin has been appended to the *end*"
+ elog "or your PATH to prevent conflicts. To use the Plan9 versions "
+ elog "of common UNIX tools, use the absolute path: "
+ elog "/usr/lib/plan9/bin or the 9 command (eg: 9 troff) "
+ elog " "
+ elog "Please report any bugs to bugs.gentoo.org, NOT Plan9Port. "
+ elog " "
+}