summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorOlivier Fisette <ribosome@gentoo.org>2006-02-19 01:39:02 +0000
committerOlivier Fisette <ribosome@gentoo.org>2006-02-19 01:39:02 +0000
commit6bc68334ebe7aeab30ca4d1c94a0a3eef337e092 (patch)
treedb617e009798fc3cd47a26b5dafc07e9a46f6fa4 /dev-util/pscan/pscan-20000721-r1.ebuild
parentVersion bump, reported by Donnie Berkholz <spyderous@gentoo.org> on bug #123081 (diff)
downloadgentoo-2-6bc68334ebe7aeab30ca4d1c94a0a3eef337e092.tar.gz
gentoo-2-6bc68334ebe7aeab30ca4d1c94a0a3eef337e092.tar.bz2
gentoo-2-6bc68334ebe7aeab30ca4d1c94a0a3eef337e092.zip
Rename pscan to printf-scan to avoid file collision (see bug #116236)
(Portage version: 2.0.54)
Diffstat (limited to 'dev-util/pscan/pscan-20000721-r1.ebuild')
-rw-r--r--dev-util/pscan/pscan-20000721-r1.ebuild30
1 files changed, 30 insertions, 0 deletions
diff --git a/dev-util/pscan/pscan-20000721-r1.ebuild b/dev-util/pscan/pscan-20000721-r1.ebuild
new file mode 100644
index 000000000000..4dc004a318d5
--- /dev/null
+++ b/dev-util/pscan/pscan-20000721-r1.ebuild
@@ -0,0 +1,30 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pscan/pscan-20000721-r1.ebuild,v 1.1 2006/02/19 01:39:02 ribosome Exp $
+
+inherit toolchain-funcs
+
+DESCRIPTION="A limited problem scanner for C source files"
+HOMEPAGE="http://www.striker.ottawa.on.ca/~aland/pscan/"
+# I wish upstream would version their files, even if it's only with a date
+SRC_URI="http://www.striker.ottawa.on.ca/~aland/pscan/pscan.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND="${RDEPEND}
+ sys-devel/flex"
+
+S="${WORKDIR}/${PN}"
+
+src_compile() {
+ emake CC="$(tc-getCC) ${CFLAGS}" || die
+}
+
+src_install() {
+ newbin pscan printf-scan || die
+ dodoc README find_formats.sh test.c wu-ftpd.pscan || die
+}