summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAaron Walker <ka0ttic@gentoo.org>2005-05-28 23:57:52 +0000
committerAaron Walker <ka0ttic@gentoo.org>2005-05-28 23:57:52 +0000
commitc8aaad4f79bcd5a67e3efb43988d7a6337e222ee (patch)
tree6246fd837dee9533062598fb00d030ade094c601 /dev-util/quilt/quilt-0.40.ebuild
parentdont install a versioned jar any longer. fixes #93529. (diff)
downloadgentoo-2-c8aaad4f79bcd5a67e3efb43988d7a6337e222ee.tar.gz
gentoo-2-c8aaad4f79bcd5a67e3efb43988d7a6337e222ee.tar.bz2
gentoo-2-c8aaad4f79bcd5a67e3efb43988d7a6337e222ee.zip
Version bump.
(Portage version: 2.0.51.22-r1)
Diffstat (limited to 'dev-util/quilt/quilt-0.40.ebuild')
-rw-r--r--dev-util/quilt/quilt-0.40.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/dev-util/quilt/quilt-0.40.ebuild b/dev-util/quilt/quilt-0.40.ebuild
new file mode 100644
index 000000000000..e51ad7dad64b
--- /dev/null
+++ b/dev-util/quilt/quilt-0.40.ebuild
@@ -0,0 +1,33 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/quilt-0.40.ebuild,v 1.1 2005/05/28 23:57:52 ka0ttic Exp $
+
+inherit bash-completion
+
+DESCRIPTION="quilt patch manager"
+HOMEPAGE="http://savannah.nongnu.org/projects/quilt"
+#SRC_URI="http://savannah.nongnu.org/download/quilt/${P}.tar.gz"
+# There are packages hosted at the savannah site, but the maintainers do not
+# update them. Which means we either have to hit the deb package or the suse
+# RPM for a current version.
+# yuck.
+SRC_URI="mirror://debian/pool/main/q/quilt/${P//-/_}.orig.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+RDEPEND="dev-util/diffstat
+ media-gfx/graphviz"
+
+src_install() {
+ make BUILD_ROOT="${D}" install || die "make install failed"
+
+ rm -rf ${D}/usr/share/doc/${P}
+ dodoc AUTHORS BUGS TODO quilt.changes doc/README doc/README.MAIL \
+ doc/quilt.pdf doc/sample.quiltrc
+
+ rm -rf ${D}/etc/bash_completion.d
+ dobashcompletion bash_completion
+}