summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Pagano <mpagano@gentoo.org>2009-02-24 18:56:45 +0000
committerMike Pagano <mpagano@gentoo.org>2009-02-24 18:56:45 +0000
commitc7b7943d1e7b14f6499aefb95a3aea08c8a9fc6f (patch)
treeb835597ed930d5712c1eeaf7ed167c022fe3329d /dev-util/quilt
parentstable amd64, bug 260012 (diff)
downloadgentoo-2-c7b7943d1e7b14f6499aefb95a3aea08c8a9fc6f.tar.gz
gentoo-2-c7b7943d1e7b14f6499aefb95a3aea08c8a9fc6f.tar.bz2
gentoo-2-c7b7943d1e7b14f6499aefb95a3aea08c8a9fc6f.zip
Version bump
(Portage version: 2.2_rc23/cvs/Linux i686)
Diffstat (limited to 'dev-util/quilt')
-rw-r--r--dev-util/quilt/ChangeLog8
-rw-r--r--dev-util/quilt/files/quilt-0.48-no-graphviz.patch34
-rw-r--r--dev-util/quilt/quilt-0.48.ebuild59
3 files changed, 100 insertions, 1 deletions
diff --git a/dev-util/quilt/ChangeLog b/dev-util/quilt/ChangeLog
index 707c87bbe092..2ad402300ab5 100644
--- a/dev-util/quilt/ChangeLog
+++ b/dev-util/quilt/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/quilt
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/ChangeLog,v 1.42 2009/01/12 14:02:52 fmccor Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/ChangeLog,v 1.43 2009/02/24 18:56:45 mpagano Exp $
+
+*quilt-0.48 (24 Feb 2009)
+
+ 24 Feb 2009; Mike Pagano <mpagano@gentoo.org>
+ +files/quilt-0.48-no-graphviz.patch, +quilt-0.48.ebuild:
+ Version bump
12 Jan 2009; Ferris McCormick <fmccor@gentoo.org> quilt-0.46.ebuild:
Sparc stable, part of Bug #254621.
diff --git a/dev-util/quilt/files/quilt-0.48-no-graphviz.patch b/dev-util/quilt/files/quilt-0.48-no-graphviz.patch
new file mode 100644
index 000000000000..4ae5ba09624e
--- /dev/null
+++ b/dev-util/quilt/files/quilt-0.48-no-graphviz.patch
@@ -0,0 +1,34 @@
+--- Makefile.in.orig 2009-02-24 13:49:47.000000000 -0500
++++ Makefile.in 2009-02-24 13:50:21.000000000 -0500
+@@ -82,8 +82,7 @@ QUILT := $(QUILT_IN)
+ SRC += $(QUILT_SRC:%=quilt/%)
+ DIRT += $(QUILT_IN:%=quilt/%)
+
+-SCRIPTS_IN := patchfns parse-patch inspect dependency-graph edmail \
+- remove-trailing-ws
++SCRIPTS_IN := patchfns parse-patch inspect edmail remove-trailing-ws
+
+ SCRIPTS_SRC := $(SCRIPTS_IN:%=%.in)
+ SCRIPTS := $(SCRIPTS_IN)
+--- bash_completion.orig 2009-02-24 13:49:52.000000000 -0500
++++ bash_completion 2009-02-24 13:50:46.000000000 -0500
+@@ -189,19 +189,6 @@ _quilt_completion()
+ ;;
+ esac
+ ;;
+- graph)
+- case $prev in
+- -T)
+- COMPREPLY=( $( compgen -W "ps" -- $cur ) )
+- ;;
+- --edge-labels)
+- COMPREPLY=( $( compgen -W "files" -- $cur ) )
+- ;;
+- *)
+- COMPREPLY=( $( compgen -W "-T -h --all --reduce --lines --edge-labels $(quilt applied)" -- $cur ) )
+- ;;
+- esac
+- ;;
+ grep)
+ _longopt grep
+ COMPREPLY=( ${COMPREPLY[@]:-} $( compgen -W "-h" -- $cur ) )
diff --git a/dev-util/quilt/quilt-0.48.ebuild b/dev-util/quilt/quilt-0.48.ebuild
new file mode 100644
index 000000000000..68bd0f7b9994
--- /dev/null
+++ b/dev-util/quilt/quilt-0.48.ebuild
@@ -0,0 +1,59 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/quilt/quilt-0.48.ebuild,v 1.1 2009/02/24 18:56:45 mpagano Exp $
+
+inherit bash-completion eutils
+
+DESCRIPTION="quilt patch manager"
+HOMEPAGE="http://savannah.nongnu.org/projects/quilt"
+SRC_URI="http://savannah.nongnu.org/download/quilt/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="emacs graphviz"
+
+RDEPEND="sys-apps/ed
+ dev-util/diffstat
+ graphviz? ( media-gfx/graphviz )
+ || ( >=sys-apps/coreutils-6.10-r1 sys-apps/mktemp )"
+
+PDEPEND="emacs? ( app-emacs/quilt-el )"
+
+pkg_setup() {
+ use graphviz && return 0
+ echo
+ elog "If you intend to use the folding functionality (graphical illustration of the"
+ elog "patch stack) then you'll need to remerge this package with USE=graphviz."
+ echo
+ epause 5
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Add support for USE=graphviz
+ use graphviz || epatch "${FILESDIR}/${P}-no-graphviz.patch"
+
+ # Some tests are somewhat broken while being run from within portage, work
+ # fine if you run them manually
+ rm "${S}"/test/delete.test "${S}"/test/mail.test
+}
+
+src_install() {
+ emake BUILD_ROOT="${D}" install || die "make install failed"
+
+ rm -rf "${D}"/usr/share/doc/${P}
+ dodoc AUTHORS TODO quilt.changes doc/README doc/README.MAIL \
+ doc/quilt.pdf
+
+ rm -rf "${D}"/etc/bash_completion.d
+ dobashcompletion bash_completion
+
+ # Remove the compat symlinks
+ rm -rf "${D}"/usr/share/quilt/compat
+
+ # Remove Emacs mode; newer version is in app-emacs/quilt-el, bug 247500
+ rm -rf "${D}"/usr/share/emacs
+}