summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorLisa M. Seelye <lisa@gentoo.org>2005-09-12 00:49:15 +0000
committerLisa M. Seelye <lisa@gentoo.org>2005-09-12 00:49:15 +0000
commit96eb9f02ec093c872b22d12f2710d97e1fa39d59 (patch)
tree7c0e27aa1c8e4318a6a436baec827d25d8b456aa /dev-util/re2c/re2c-0.9.10.ebuild
parentVersion bump, bug #105463. (diff)
downloadgentoo-2-96eb9f02ec093c872b22d12f2710d97e1fa39d59.tar.gz
gentoo-2-96eb9f02ec093c872b22d12f2710d97e1fa39d59.tar.bz2
gentoo-2-96eb9f02ec093c872b22d12f2710d97e1fa39d59.zip
Version bump and bump 0.9.9 to stable on x86. Other arches should test. Resolves bug #104991
(Portage version: 2.0.51.22-r2)
Diffstat (limited to 'dev-util/re2c/re2c-0.9.10.ebuild')
-rw-r--r--dev-util/re2c/re2c-0.9.10.ebuild37
1 files changed, 37 insertions, 0 deletions
diff --git a/dev-util/re2c/re2c-0.9.10.ebuild b/dev-util/re2c/re2c-0.9.10.ebuild
new file mode 100644
index 000000000000..b3704c3d2789
--- /dev/null
+++ b/dev-util/re2c/re2c-0.9.10.ebuild
@@ -0,0 +1,37 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/re2c/re2c-0.9.10.ebuild,v 1.1 2005/09/12 00:49:15 lisa Exp $
+
+inherit eutils
+
+DESCRIPTION="tool for generating C-based recognizers from regular expressions"
+HOMEPAGE="http://re2c.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="public-domain"
+SLOT="0"
+KEYWORDS="~ppc ~sparc ~x86"
+IUSE=""
+
+RDEPEND="virtual/libc"
+DEPEND="|| ( >=dev-util/byacc-1.9 >=sys-devel/bison-2.0 )
+ ${RDEPEND}"
+
+src_unpack() {
+ unpack ${A} || die
+ # Fix permissions
+ chmod -R u+rw ${S}
+}
+
+src_compile() {
+ econf || die
+ emake -e || die
+}
+
+src_install() {
+ dobin re2c || die "dobin failed"
+ doman re2c.1 || die "doman failed"
+ dodoc README CHANGELOG doc/* && \
+ docinto examples && \
+ dodoc examples/*.c examples/*.re || die "docs failed"
+}