summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <spyderous@gentoo.org>2004-04-03 21:26:45 +0000
committerDonnie Berkholz <spyderous@gentoo.org>2004-04-03 21:26:45 +0000
commit6aa333d7e57663011e3540d8cffe09f4fc6462d9 (patch)
treeed0ca7fa0344af1127d0d30cb3ae8e52870ae1b8 /dev-util/rhide
parentChange x11-base/xfree dependency to virtual/x11. (Manifest recommit) (diff)
downloadgentoo-2-6aa333d7e57663011e3540d8cffe09f4fc6462d9.tar.gz
gentoo-2-6aa333d7e57663011e3540d8cffe09f4fc6462d9.tar.bz2
gentoo-2-6aa333d7e57663011e3540d8cffe09f4fc6462d9.zip
Change XFree86 references to X11.
Diffstat (limited to 'dev-util/rhide')
-rw-r--r--dev-util/rhide/ChangeLog6
-rw-r--r--dev-util/rhide/rhide-1.5-r1.ebuild18
-rw-r--r--dev-util/rhide/rhide-1.5.ebuild18
3 files changed, 23 insertions, 19 deletions
diff --git a/dev-util/rhide/ChangeLog b/dev-util/rhide/ChangeLog
index 8f6afeebe5c5..84058b584b1b 100644
--- a/dev-util/rhide/ChangeLog
+++ b/dev-util/rhide/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/rhide
# Copyright 2002-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/ChangeLog,v 1.11 2004/01/31 02:50:16 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/ChangeLog,v 1.12 2004/04/03 21:22:42 spyderous Exp $
+
+ 03 Apr 2004; Donnie Berkholz <spyderous@gentoo.org>; rhide-1.5-r1.ebuild,
+ rhide-1.5.ebuild:
+ Change XFree86 references to X11.
31 Jan 2004; Marius Mauch <genone@gentoo.org> rhide-1.5-r1.ebuild:
added a patch for gcc-3.3 compatibility, thanks to Jochen Eisinger
diff --git a/dev-util/rhide/rhide-1.5-r1.ebuild b/dev-util/rhide/rhide-1.5-r1.ebuild
index 18b7173836c6..79a21a34b8e6 100644
--- a/dev-util/rhide/rhide-1.5-r1.ebuild
+++ b/dev-util/rhide/rhide-1.5-r1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/rhide-1.5-r1.ebuild,v 1.8 2004/01/31 02:50:16 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/rhide-1.5-r1.ebuild,v 1.9 2004/04/03 21:22:42 spyderous Exp $
#SNAPSHOT="20020825"
TVISIONVER="2.0.1"
@@ -156,30 +156,30 @@ src_compile() {
export GDB_SRC="${WORKDIR}/gdb-${GDBVER}"
#
- # *** DETECT XFREE86 with tvision-2.0 ***
+ # *** DETECT X11 with tvision-2.0 ***
#
- # None of these packages have any way to specify XFree86 support,
- # thus we check if tvision compiled with xfree support or not.
+ # None of these packages have any way to specify X11 support,
+ # thus we check if tvision compiled with X11 support or not.
#
- # If it did compile with xfree support, we need to get rhide to link
+ # If it did compile with X11 support, we need to get rhide to link
# against libX11 ...
#
- local have_xfree="$(gawk '/HAVE_X11/ { if (/yes/) print "Yes" }' \
+ local have_x11="$(gawk '/HAVE_X11/ { if (/yes/) print "Yes" }' \
${WORKDIR}/tvision/configure.cache)"
if [ ! -f "${WORKDIR}/.rhide-configured" ]
then
econf || die
- if [ "${have_xfree}" = "Yes" ]
+ if [ "${have_x11}" = "Yes" ]
then
- einfo "Compiling with XFree86 support..."
+ einfo "Compiling with X11 support..."
sed -i -e 's|LDFLAGS= |LDFLAGS= -L/usr/X11R6/lib -lXmu|' \
${S}/config.env
touch ${WORKDIR}/.tvision-with-X11
else
- einfo "Compiling without XFree86 support..."
+ einfo "Compiling without X11 support..."
fi
touch "${WORKDIR}/.rhide-configured"
diff --git a/dev-util/rhide/rhide-1.5.ebuild b/dev-util/rhide/rhide-1.5.ebuild
index dd329fecdb7d..854301e6acac 100644
--- a/dev-util/rhide/rhide-1.5.ebuild
+++ b/dev-util/rhide/rhide-1.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/rhide-1.5.ebuild,v 1.7 2004/03/13 01:49:46 mr_bones_ Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rhide/rhide-1.5.ebuild,v 1.8 2004/04/03 21:22:42 spyderous Exp $
#SNAPSHOT="20020825"
TVISIONVER="2.0.1"
@@ -145,30 +145,30 @@ src_compile() {
export GDB_SRC="${WORKDIR}/gdb-${GDBVER}"
#
- # *** DETECT XFREE86 with tvision-2.0 ***
+ # *** DETECT X11 with tvision-2.0 ***
#
- # None of these packages have any way to specify XFree86 support,
- # thus we check if tvision compiled with xfree support or not.
+ # None of these packages have any way to specify X11 support,
+ # thus we check if tvision compiled with X11 support or not.
#
- # If it did compile with xfree support, we need to get rhide to link
+ # If it did compile with X11 support, we need to get rhide to link
# against libX11 ...
#
- local have_xfree="$(gawk '/HAVE_X11/ { if (/yes/) print "Yes" }' \
+ local have_x11="$(gawk '/HAVE_X11/ { if (/yes/) print "Yes" }' \
${WORKDIR}/tvision/configure.cache)"
if [ ! -f "${WORKDIR}/.rhide-configured" ]
then
econf || die
- if [ "${have_xfree}" = "Yes" ]
+ if [ "${have_x11}" = "Yes" ]
then
- einfo "Compiling with XFree86 support..."
+ einfo "Compiling with X11 support..."
perl -pi -e 's|LDFLAGS= |LDFLAGS= -L/usr/X11R6/lib -lXmu|' \
${S}/config.env
touch ${WORKDIR}/.tvision-with-X11
else
- einfo "Compiling without XFree86 support..."
+ einfo "Compiling without X11 support..."
fi
touch "${WORKDIR}/.rhide-configured"