summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSergey Popov <pinkbyte@gentoo.org>2012-09-05 18:07:11 +0000
committerSergey Popov <pinkbyte@gentoo.org>2012-09-05 18:07:11 +0000
commit5a16f8853613f099a9934899ba0f95bafa83d1b1 (patch)
tree3dcb8c2e04eb6bcbd8a70ebfb1d2c09304df897f /dev-util/shc
parentDrop suggestion to manually downgrade package as explained in bug #421643, dr... (diff)
downloadgentoo-2-5a16f8853613f099a9934899ba0f95bafa83d1b1.tar.gz
gentoo-2-5a16f8853613f099a9934899ba0f95bafa83d1b1.tar.bz2
gentoo-2-5a16f8853613f099a9934899ba0f95bafa83d1b1.zip
Version bump wrt bug #433970, thanks to Jan Psota
(Portage version: 2.2.0_alpha124/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/shc')
-rw-r--r--dev-util/shc/ChangeLog7
-rw-r--r--dev-util/shc/shc-3.8.9.ebuild38
2 files changed, 44 insertions, 1 deletions
diff --git a/dev-util/shc/ChangeLog b/dev-util/shc/ChangeLog
index 0fb601fdb66d..244e490c0938 100644
--- a/dev-util/shc/ChangeLog
+++ b/dev-util/shc/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/shc
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/ChangeLog,v 1.22 2012/05/10 16:10:44 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/ChangeLog,v 1.23 2012/09/05 18:07:11 pinkbyte Exp $
+
+*shc-3.8.9 (05 Sep 2012)
+
+ 05 Sep 2012; Sergey Popov <pinkbyte@gentoo.org> +shc-3.8.9.ebuild:
+ Version bump wrt bug #433970, thanks to Jan Psota
10 May 2012; Agostino Sarubbo <ago@gentoo.org> -shc-3.6.ebuild,
-shc-3.7.ebuild, -shc-3.8.3.ebuild:
diff --git a/dev-util/shc/shc-3.8.9.ebuild b/dev-util/shc/shc-3.8.9.ebuild
new file mode 100644
index 000000000000..b467039ec7ff
--- /dev/null
+++ b/dev-util/shc/shc-3.8.9.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shc/shc-3.8.9.ebuild,v 1.1 2012/09/05 18:07:11 pinkbyte Exp $
+
+EAPI="4"
+
+inherit toolchain-funcs
+
+DESCRIPTION="A (shell-) script compiler/scrambler"
+HOMEPAGE="http://www.datsi.fi.upm.es/~frosal"
+SRC_URI="http://www.datsi.fi.upm.es/~frosal/sources/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~sparc ~x86"
+IUSE=""
+
+RESTRICT="test"
+
+src_prepare() {
+ # respect LDFLAGS
+ sed -i makefile -e 's:$(CC) $(CFLAGS):& $(LDFLAGS):' || die
+ # fix source file name wrt bug #433970
+ mv {${P},${PN}}.c || die
+}
+
+src_compile() {
+ ## the "test"-target leads to an access-violation -> so we skip it
+ ## as it's only for demonstration purposes anyway.
+ emake CC=$(tc-getCC) CFLAGS="${CFLAGS}" shc
+}
+
+src_install() {
+ dobin shc
+ doman shc.1
+ newdoc shc.README README
+ dodoc CHANGES
+}