summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDonnie Berkholz <dberkholz@gentoo.org>2011-08-01 05:24:51 +0000
committerDonnie Berkholz <dberkholz@gentoo.org>2011-08-01 05:24:51 +0000
commit1c3a0502ed3062e1dbde7fcd97e5f838716989d3 (patch)
tree91e23816b94251c88b3bf0ea5de85a1f0c2033ed /dev-util/shunit2
parentFix buffer overflow (bug #337415). (diff)
downloadgentoo-2-1c3a0502ed3062e1dbde7fcd97e5f838716989d3.tar.gz
gentoo-2-1c3a0502ed3062e1dbde7fcd97e5f838716989d3.tar.bz2
gentoo-2-1c3a0502ed3062e1dbde7fcd97e5f838716989d3.zip
(#374725, #360437) Version bump. Should fix docbook-related issues because docs aren't shipped as docbook anymore.
(Portage version: 2.2.0_alpha47/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/shunit2')
-rw-r--r--dev-util/shunit2/ChangeLog10
-rw-r--r--dev-util/shunit2/shunit2-2.1.6.ebuild32
2 files changed, 40 insertions, 2 deletions
diff --git a/dev-util/shunit2/ChangeLog b/dev-util/shunit2/ChangeLog
index 36a6967e14cc..1daf6a51caf0 100644
--- a/dev-util/shunit2/ChangeLog
+++ b/dev-util/shunit2/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/shunit2
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/ChangeLog,v 1.4 2010/06/26 11:02:00 jlec Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/ChangeLog,v 1.5 2011/08/01 05:24:51 dberkholz Exp $
+
+*shunit2-2.1.6 (01 Aug 2011)
+
+ 01 Aug 2011; Donnie Berkholz <dberkholz@gentoo.org>; +shunit2-2.1.6.ebuild:
+ (#374725, #360437) Version bump. Should fix docbook-related issues because
+ docs aren't shipped as docbook anymore.
26 Jun 2010; Justin Lecher <jlec@gentoo.org> shunit2-2.1.4.ebuild,
shunit2-2.1.5.ebuild, +files/test.patch:
diff --git a/dev-util/shunit2/shunit2-2.1.6.ebuild b/dev-util/shunit2/shunit2-2.1.6.ebuild
new file mode 100644
index 000000000000..a32b7e300eb0
--- /dev/null
+++ b/dev-util/shunit2/shunit2-2.1.6.ebuild
@@ -0,0 +1,32 @@
+# Copyright 1999-2011 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/shunit2/shunit2-2.1.6.ebuild,v 1.1 2011/08/01 05:24:51 dberkholz Exp $
+
+EAPI="4"
+
+inherit eutils
+
+DESCRIPTION="Unit-test framework for Bourne-based shell scripts."
+HOMEPAGE="http://code.google.com/p/shunit2/wiki/ProjectInfo"
+SRC_URI="http://shunit2.googlecode.com/files/${P}.tgz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="doc test"
+
+RDEPEND=""
+DEPEND="${RDEPEND}
+ dev-lang/perl
+ net-misc/curl"
+
+src_install() {
+ dobin src/shunit2 || die
+
+ # For backwards compat to <=2.1.5
+ dosym /usr/bin/shunit2 /usr/share/shunit2/shunit2 || die
+
+ dodoc -r examples || die
+ dodoc doc/*.txt || die
+ dohtml doc/*.{html,css} || die
+}