summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTiziano Müller <dev-zero@gentoo.org>2007-06-07 23:02:41 +0000
committerTiziano Müller <dev-zero@gentoo.org>2007-06-07 23:02:41 +0000
commit0aeecd82ad64dd6dc4829449454221db087520d0 (patch)
treefe9bd390b02cd050dfb1fddc2ad5cb3f1c0a98f5 /dev-util/source-highlight
parentStable on amd64 wrt bug 179862 (diff)
downloadgentoo-2-0aeecd82ad64dd6dc4829449454221db087520d0.tar.gz
gentoo-2-0aeecd82ad64dd6dc4829449454221db087520d0.tar.bz2
gentoo-2-0aeecd82ad64dd6dc4829449454221db087520d0.zip
Version bump, fixed bug #181220.
(Portage version: 2.1.2.9)
Diffstat (limited to 'dev-util/source-highlight')
-rw-r--r--dev-util/source-highlight/ChangeLog9
-rw-r--r--dev-util/source-highlight/files/digest-source-highlight-2.63
-rw-r--r--dev-util/source-highlight/files/source-highlight-2.6-exuberant-ctags.diff202
-rw-r--r--dev-util/source-highlight/source-highlight-2.5.ebuild5
-rw-r--r--dev-util/source-highlight/source-highlight-2.6.ebuild51
5 files changed, 267 insertions, 3 deletions
diff --git a/dev-util/source-highlight/ChangeLog b/dev-util/source-highlight/ChangeLog
index 7b0d156e6bff..0e7dfcde3abd 100644
--- a/dev-util/source-highlight/ChangeLog
+++ b/dev-util/source-highlight/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/source-highlight
# Copyright 2000-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.24 2007/02/04 19:27:06 dev-zero Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/ChangeLog,v 1.25 2007/06/07 23:02:41 dev-zero Exp $
+
+*source-highlight-2.6 (07 Jun 2007)
+
+ 07 Jun 2007; Tiziano Müller <dev-zero@gentoo.org>
+ +files/source-highlight-2.6-exuberant-ctags.diff,
+ source-highlight-2.5.ebuild, +source-highlight-2.6.ebuild:
+ Version bump, fixed bug #181220.
04 Feb 2007; Tiziano Müller <dev-zero@gentoo.org>
-files/source-highlight.bash-completion, -source-highlight-1.11-r2.ebuild:
diff --git a/dev-util/source-highlight/files/digest-source-highlight-2.6 b/dev-util/source-highlight/files/digest-source-highlight-2.6
new file mode 100644
index 000000000000..2bfaf892c74d
--- /dev/null
+++ b/dev-util/source-highlight/files/digest-source-highlight-2.6
@@ -0,0 +1,3 @@
+MD5 f36f813a0e5e2a55e9f8050a65dbc594 source-highlight-2.6.tar.gz 986369
+RMD160 cca6bc31921d544053a59f67c02dd8eb67e6c777 source-highlight-2.6.tar.gz 986369
+SHA256 71a3504fcdee1f5fb3884e20ea33bd954aed43e3c59d2d6234653b435547c61d source-highlight-2.6.tar.gz 986369
diff --git a/dev-util/source-highlight/files/source-highlight-2.6-exuberant-ctags.diff b/dev-util/source-highlight/files/source-highlight-2.6-exuberant-ctags.diff
new file mode 100644
index 000000000000..e1376f60c99e
--- /dev/null
+++ b/dev-util/source-highlight/files/source-highlight-2.6-exuberant-ctags.diff
@@ -0,0 +1,202 @@
+diff -Naur source-highlight-2.6.orig/configure.ac source-highlight-2.6/configure.ac
+--- source-highlight-2.6.orig/configure.ac 2007-06-08 00:28:50.000000000 +0200
++++ source-highlight-2.6/configure.ac 2007-06-08 00:31:09.000000000 +0200
+@@ -125,7 +125,8 @@
+ AM_CONDITIONAL(NO_HELP2MAN, test -z "$ac_cv_path_HELP2MAN" )
+
+ dnl this is for generating references
+-AC_PATH_PROGS(CTAGS, ctags)
++AC_PATH_PROGS(CTAGS, exuberant-ctags)
++AC_SUBST([$CTAGS])
+ AM_CONDITIONAL(NO_CTAGS, test -z "$ac_cv_path_CTAGS" )
+
+ dnl *******************
+@@ -229,4 +230,4 @@
+ generate references (--gen-references).
+ Furthermore, if you run make check, then some
+ tests are going to fail.])
+-fi
+\ Kein Zeilenumbruch am Dateiende.
++fi
+diff -Naur source-highlight-2.6.orig/doc/Makefile.am source-highlight-2.6/doc/Makefile.am
+--- source-highlight-2.6.orig/doc/Makefile.am 2007-06-08 00:28:50.000000000 +0200
++++ source-highlight-2.6/doc/Makefile.am 2007-06-08 00:35:55.000000000 +0200
+@@ -20,7 +20,7 @@
+
+ CPP2HTML = $(SRCHILITEPROG) -s cpp -f html $(STD_STYLE)
+
+-CPP2HTML_WREFS = $(CPP2HTML) --title="Contains references to tags" --gen-references=inline --ctags="ctags --excmd=n --tag-relative=yes -o my_test_ref.tags"
++CPP2HTML_WREFS = $(CPP2HTML) --title="Contains references to tags" --gen-references=inline --ctags="@CTAGS@ --excmd=n --tag-relative=yes -o my_test_ref.tags"
+
+ CHANGELOG2HTML = $(SRCHILITEPROG) -s changelog -f html $(STD_STYLE)
+
+@@ -47,80 +47,80 @@
+ endif
+
+ lang-list.texinfo: $(top_srcdir)/src/lang.map
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ --lang-list | sed -e 's/@/@@/' > $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ --lang-list | sed -e 's/@/@@/' > $@
+
+ outlang-list.texinfo: $(top_srcdir)/src/outlang.map
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ --outlang-list | sed -e 's/@/@@/' > $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ --outlang-list | sed -e 's/@/@@/' > $@
+
+ test.java.texinfo: $(top_srcdir)/tests/test.java
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test.java --style-file=$(top_srcdir)/src/texinfo.style -n > $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test.java --style-file=$(top_srcdir)/src/texinfo.style -n > $@
+
+ debug.java.texinfo: $(top_srcdir)/tests/debug.java
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/debug.java --style-file=$(top_srcdir)/src/texinfo.style -n > $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/debug.java --style-file=$(top_srcdir)/src/texinfo.style -n > $@
+
+ %.lang.texinfo: $(top_srcdir)/src/%.lang
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.langelems.texinfo: $(top_srcdir)/src/%.lang
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ --show-lang-elements=$< > $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ --show-lang-elements=$< > $@
+
+ %.txt.texinfo: $(srcdir)/%.txt
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.txt.texinfo.texinfo: $(srcdir)/%.txt.texinfo
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=nohilite.lang
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=nohilite.lang
+
+ %.outlang.texinfo: $(top_srcdir)/src/%.outlang
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.lang.texinfo: $(top_srcdir)/tests/%.lang
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.lang.texinfo: $(srcdir)/%.lang
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.lang.texinfo: $(top_srcdir)/src/%.lang
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.style.texinfo: $(top_srcdir)/src/%.style
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.style.texinfo: $(top_srcdir)/tests/%.style
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.diff.texinfo: %.diff
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.css.texinfo: %.css
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.css.texinfo: $(top_srcdir)/src/%.css
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ %.cpp.texinfo: $(top_srcdir)/tests/%.cpp
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $< --style-file=$(top_srcdir)/src/texinfo.style -o $@
+
+ test_extreme_comment_wrong.texinfo: $(top_srcdir)/tests/test_extreme_comment.cpp
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment.lang
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment.lang
+
+ test_extreme_comment_1.texinfo: $(top_srcdir)/tests/test_extreme_comment.cpp
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment2.lang
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment2.lang
+
+ test_extreme_comment_wrong2.texinfo: $(top_srcdir)/tests/test_extreme_comment2.cpp
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment2.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment2.lang
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment2.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment2.lang
+
+ test_extreme_comment_2.texinfo: $(top_srcdir)/tests/test_extreme_comment2.cpp
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment2.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment3.lang
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment2.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment3.lang
+
+ test_extreme_comment_3.texinfo: $(top_srcdir)/tests/test_extreme_comment3.cpp
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment3.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment3.lang
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test_extreme_comment3.cpp --style-file=$(top_srcdir)/src/texinfo.style -o $@ --lang-def=extreme_comment3.lang
+
+ %.show.texinfo: %.lang
+ $(SRCHILITEEXE) --show-regex=$< > $@
+ sed -i -e 's/@/@@/g' $@
+
+ test_ref.h.texinfo: $(top_srcdir)/tests/test.h
+- $(SRCHILITEEXE) --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test.h --style-file=$(top_srcdir)/src/texinfo.style -n --gen-references=postline > $@
++ $(SRCHILITEEXE) --ctags=@CTAGS@ --data-dir=$(top_srcdir)/src/ -f texinfo -i $(top_srcdir)/tests/test.h --style-file=$(top_srcdir)/src/texinfo.style -n --gen-references=postline > $@
+
+ # the dependence on config.h is to ensure the correct version number
+ # in the generated man file
+@@ -189,7 +189,7 @@
+ # note that $(srcdir) actually points to doc dir
+
+ langdef.lang.html: $(top_srcdir)/src/langdef.lang
+- $(SRCHILITEPROG) $(STD_STYLE) -i $(top_srcdir)/src/langdef.lang -o langdef.lang.html
++ $(SRCHILITEPROG) --ctags=@CTAGS@ $(STD_STYLE) -i $(top_srcdir)/src/langdef.lang -o langdef.lang.html
+
+ startapp.cc.html: $(top_srcdir)/src/startapp.cc
+ $(CPP2HTML) --doc $(OUTPUT_HERE) $(top_srcdir)/src/startapp.cc
+@@ -310,4 +310,4 @@
+ texinfo-clean:
+ rm -f $(GENERATEDINFOS)
+
+-DISTCLEANFILES = $(HTML_GENERATED_FILES) source-highlight.1 $(GENERATEDINFOS) tags langdef.lang.html
+\ Kein Zeilenumbruch am Dateiende.
++DISTCLEANFILES = $(HTML_GENERATED_FILES) source-highlight.1 $(GENERATEDINFOS) tags langdef.lang.html
+diff -Naur source-highlight-2.6.orig/src/lib/Makefile.am source-highlight-2.6/src/lib/Makefile.am
+--- source-highlight-2.6.orig/src/lib/Makefile.am 2007-06-08 00:28:50.000000000 +0200
++++ source-highlight-2.6/src/lib/Makefile.am 2007-06-08 00:38:29.000000000 +0200
+@@ -127,7 +127,7 @@
+ test_langinfer_LDADD = libcommon.la
+
+ mytags: $(srcdir)/test_readtags_main.cpp
+- $(CTAGS) --excmd=n --fields=+n -o mytags $(srcdir)/test_readtags_main.cpp $(srcdir)/readtags.h
++ @CTAGS@ --excmd=n --fields=+n -o mytags $(srcdir)/test_readtags_main.cpp $(srcdir)/readtags.h
+
+ outlangtest.outlang: $(srcdir)/outlangtest.outlang.tmpl
+ rm -f outlangtest.outlang
+diff -Naur source-highlight-2.6.orig/tests/Makefile.am source-highlight-2.6/tests/Makefile.am
+--- source-highlight-2.6.orig/tests/Makefile.am 2007-06-08 00:28:50.000000000 +0200
++++ source-highlight-2.6/tests/Makefile.am 2007-06-08 00:38:10.000000000 +0200
+@@ -50,7 +50,7 @@
+
+ JAVA2TEXINFO = $(PROGNAME) -s java -f texinfo --style-file $(top_srcdir)/src/texinfo.style
+
+-CPP2TEXINFO_WREFS = $(PROGNAME) -s cpp -f texinfo --style-file $(top_srcdir)/src/texinfo.style --gen-references=postline --line-number --ctags=""
++CPP2TEXINFO_WREFS = $(PROGNAME) -s cpp -f texinfo --style-file $(top_srcdir)/src/texinfo.style --gen-references=postline --line-number --ctags="@CTAGS@"
+
+ # this refers to an "absolute" path (../doc/) without using the automake
+ # variables. However this way the generated files will always be the
+@@ -360,13 +360,13 @@
+
+ CPP2HTML_WHEADERS = $(CPP2HTML) --header=$(srcdir)/header.html --footer=$(srcdir)/footer.html
+
+-CPP2HTML_WREFS = $(CPP2HTML) --title="Contains references to tags" --gen-references=inline --ctags="$(CTAGS) --excmd=number --tag-relative=yes -o my_test_ref.tags"
++CPP2HTML_WREFS = $(CPP2HTML) --title="Contains references to tags" --gen-references=inline --ctags="@CTAGS@ --excmd=number --tag-relative=yes -o my_test_ref.tags"
+
+-CPP2LATEX_WREFS = $(CPP2TEX) --title="Contains references to tags" --gen-references=postline --line-number --ctags=""
++CPP2LATEX_WREFS = $(CPP2TEX) --title="Contains references to tags" --gen-references=postline --line-number --ctags="@CTAGS@"
+
+-CPP2LATEX_WREFSPOST = $(CPP2TEX) --title="Contains references to tags" --gen-references=postdoc --line-number --ctags=""
++CPP2LATEX_WREFSPOST = $(CPP2TEX) --title="Contains references to tags" --gen-references=postdoc --line-number --ctags="@CTAGS@"
+
+-CTAGS_CMD=$(CTAGS) --excmd=number --tag-relative=yes
++CTAGS_CMD=@CTAGS@ --excmd=number --tag-relative=yes
+
+ test_header.html: test.h
+ $(CPP2HTML_WHEADERS) -i test.h -o $@
+@@ -847,4 +847,4 @@
+ clean_html:
+ rm -f *.h.html *.java.html *.cc.html *.pas.html *.pl.html *.pm.html *.php3.html *.py.html *.chlog.html *.chlog_css.html *.l.html test_xhtml*.html test_notfixed.html test_css.html test_css_nodoc.html test_header.html *.rb.html *.js.html *.java.txt *.java.tex *.java.texinfo *.lua.html *.ml.html *.sml.html test_*_lines.html *.log.html *.y.html *.simple.html *.tex.html *.lgt.html *.diff.html *.lang.html *.htm.html *.style.html *.cs.html *.xml.html *.sh.html *.url.html *.txt.html *.unknown.html *.tcl.html *.bib.html *.makefile.html *.css.html
+
+-DISTCLEANFILES=test_ref.html test_ref.tags my_test_ref.tags tags test_ref.tex test_ref_post.tex test_ref.texinfo syslog.style.html
+\ Kein Zeilenumbruch am Dateiende.
++DISTCLEANFILES=test_ref.html test_ref.tags my_test_ref.tags tags test_ref.tex test_ref_post.tex test_ref.texinfo syslog.style.html
diff --git a/dev-util/source-highlight/source-highlight-2.5.ebuild b/dev-util/source-highlight/source-highlight-2.5.ebuild
index 0348ebfbb3d6..bce011f7889b 100644
--- a/dev-util/source-highlight/source-highlight-2.5.ebuild
+++ b/dev-util/source-highlight/source-highlight-2.5.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2007 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-2.5.ebuild,v 1.4 2007/02/04 18:36:18 beandog Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-2.5.ebuild,v 1.5 2007/06/07 23:02:41 dev-zero Exp $
inherit autotools eutils bash-completion
@@ -26,8 +26,9 @@ src_unpack() {
src_compile() {
local myconf
- built_with_use dev-libs/boost threadsonly && \
+ if has_version "<dev-libs/boost-1.34.0" && built_with_use dev-libs/boost threadsonly ; then
myconf="--with-boost-regex=boost_regex-gcc-mt"
+ fi
econf ${myconf} || die "econf failed"
emake || die "emake failed"
diff --git a/dev-util/source-highlight/source-highlight-2.6.ebuild b/dev-util/source-highlight/source-highlight-2.6.ebuild
new file mode 100644
index 000000000000..927cefe7f400
--- /dev/null
+++ b/dev-util/source-highlight/source-highlight-2.6.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/source-highlight/source-highlight-2.6.ebuild,v 1.1 2007/06/07 23:02:41 dev-zero Exp $
+
+inherit autotools eutils bash-completion
+
+DESCRIPTION="Generate highlighted source code as an (x)html document"
+HOMEPAGE="http://www.gnu.org/software/src-highlite/source-highlight.html"
+SRC_URI="mirror://gnu/src-highlite/${P}.tar.gz"
+
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~mips ~ppc ~x86"
+SLOT="0"
+IUSE="doc"
+
+DEPEND=">=dev-libs/boost-1.33.1-r1
+ dev-util/ctags"
+RDEPEND="${DEPEND}"
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ epatch "${FILESDIR}/${P}-exuberant-ctags.diff"
+ eautoreconf
+}
+
+src_compile() {
+ local myconf
+
+ if has_version "<dev-libs/boost-1.34.0" && built_with_use dev-libs/boost threadsonly ; then
+ myconf="--with-boost-regex=boost_regex-gcc-mt"
+ fi
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install () {
+ emake DESTDIR="${D}" install || die "make install failed"
+
+ dobashcompletion "${FILESDIR}/${PN}-2.5.bash-completion"
+
+ # That's not how we want it
+ rm -fr "${D}/usr/share/doc"
+ dodoc AUTHORS ChangeLog CREDITS NEWS README THANKS TODO.txt
+
+ if use doc ; then
+ cd "${S}/doc"
+ dohtml *.{html,css,java}
+ fi
+}