summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2007-04-10 18:07:41 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2007-04-10 18:07:41 +0000
commitaa3a4dbfb116d9aea911deb048b43d4f531bcb6c (patch)
tree19263cae2b81c5d45230ab3f69d51f694c89aac7 /dev-util/stgit/stgit-0.12.1-r1.ebuild
parentFix deps. Just as bug 161424. (diff)
downloadgentoo-2-aa3a4dbfb116d9aea911deb048b43d4f531bcb6c.tar.gz
gentoo-2-aa3a4dbfb116d9aea911deb048b43d4f531bcb6c.tar.bz2
gentoo-2-aa3a4dbfb116d9aea911deb048b43d4f531bcb6c.zip
Add a bash-completion script. Thanks to Nicolas Boichat <nicolas@boichat.ch>. Fixes bug #174014
(Portage version: 2.1.2.2)
Diffstat (limited to 'dev-util/stgit/stgit-0.12.1-r1.ebuild')
-rw-r--r--dev-util/stgit/stgit-0.12.1-r1.ebuild26
1 files changed, 26 insertions, 0 deletions
diff --git a/dev-util/stgit/stgit-0.12.1-r1.ebuild b/dev-util/stgit/stgit-0.12.1-r1.ebuild
new file mode 100644
index 000000000000..20a00d280c55
--- /dev/null
+++ b/dev-util/stgit/stgit-0.12.1-r1.ebuild
@@ -0,0 +1,26 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/stgit/stgit-0.12.1-r1.ebuild,v 1.1 2007/04/10 18:07:41 ferdy Exp $
+
+inherit distutils bash-completion
+
+DESCRIPTION="Manage a stack of patches using GIT as a backend"
+HOMEPAGE="http://www.procode.org/stgit/"
+SRC_URI="http://homepage.ntlworld.com/cmarinas/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~x86"
+IUSE=""
+
+DEPEND=""
+RDEPEND=">=dev-util/git-1.5"
+
+src_install() {
+ sed -i -e 's-\(prefix:\) ~-\1 /usr-' setup.cfg
+ distutils_src_install
+ dodir /usr/share/doc/${PF}
+ mv ${D}/usr/share/${PN}/examples ${D}/usr/share/doc/${PF}
+ rmdir ${D}/usr/share/doc/${PN}
+ dobashcompletion contrib/stgit-completion.bash ${PN}
+}