summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHanno Böck <hanno@gentoo.org>2008-04-06 13:41:21 +0000
committerHanno Böck <hanno@gentoo.org>2008-04-06 13:41:21 +0000
commit87a23abb1e3494b7e9e48779283ac2c76c0c6385 (patch)
treeb20ccbb9003ba31947927a9c24a1ec3a85e80605 /dev-util/svnmailer
parentversion bump for bug #214627, bug #161930 and bug #214550 (diff)
downloadgentoo-2-87a23abb1e3494b7e9e48779283ac2c76c0c6385.tar.gz
gentoo-2-87a23abb1e3494b7e9e48779283ac2c76c0c6385.tar.bz2
gentoo-2-87a23abb1e3494b7e9e48779283ac2c76c0c6385.zip
svnmailer python 2.5 support
(Portage version: 2.1.5_rc2)
Diffstat (limited to 'dev-util/svnmailer')
-rw-r--r--dev-util/svnmailer/ChangeLog10
-rw-r--r--dev-util/svnmailer/files/svnmailer-1.0.8-python2.5.diff47
-rw-r--r--dev-util/svnmailer/svnmailer-1.0.8-r2.ebuild43
3 files changed, 98 insertions, 2 deletions
diff --git a/dev-util/svnmailer/ChangeLog b/dev-util/svnmailer/ChangeLog
index e0acc4934cc8..2fc92d5f10ad 100644
--- a/dev-util/svnmailer/ChangeLog
+++ b/dev-util/svnmailer/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/svnmailer
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/svnmailer/ChangeLog,v 1.4 2007/01/27 00:00:29 aross Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/svnmailer/ChangeLog,v 1.5 2008/04/06 13:41:20 hanno Exp $
+
+*svnmailer-1.0.8-r2 (06 Apr 2008)
+
+ 06 Apr 2008; Hanno Boeck <hanno@gentoo.org>
+ +files/svnmailer-1.0.8-python2.5.diff, +svnmailer-1.0.8-r2.ebuild:
+ Patch for Python 2.5.
*svnmailer-1.0.8-r1 (26 Jan 2007)
diff --git a/dev-util/svnmailer/files/svnmailer-1.0.8-python2.5.diff b/dev-util/svnmailer/files/svnmailer-1.0.8-python2.5.diff
new file mode 100644
index 000000000000..348f26f36a0a
--- /dev/null
+++ b/dev-util/svnmailer/files/svnmailer-1.0.8-python2.5.diff
@@ -0,0 +1,47 @@
+Index: src/lib/svnmailer/notifier/_base.py
+===================================================================
+--- src/lib/svnmailer/notifier/_base.py
++++ src/lib/svnmailer/notifier/_base.py 2007-05-01 00:54:23.000000000 +0200
+@@ -345,7 +345,6 @@
+ @return: The two encodings
+ @rtype: C{tuple} of C{str}
+ """
+- from encodings import exceptions
+
+ enc1 = enc2 = default
+ if not change.wasAdded() or change.wasCopied():
+@@ -353,7 +352,7 @@
+ enc1 = self._getContentEncoding(
+ change.getBasePath(), change.getBaseRevision()
+ )
+- except exceptions.LookupError:
++ except LookupError:
+ # fall back
+ pass
+
+@@ -364,7 +363,7 @@
+ enc2 = self._getContentEncoding(
+ change.path, change.revision
+ )
+- except exceptions.LookupError:
++ except LookupError:
+ # fall back
+ pass
+
+@@ -389,7 +388,6 @@
+ @exception encodings.exception.LookupError: The specified encoding
+ is not implemented or no encoding was specified
+ """
+- from encodings import exceptions
+
+ # first try the svn:mime-type
+ enc = self.getEncodingFromMimeType(path, revision)
+@@ -427,7 +425,7 @@
+ codecs.lookup(enc)
+ return enc
+
+- raise exceptions.LookupError("No Encoding configured")
++ raise LookupError("No Encoding configured")
+
+
+ def getEncodingFromMimeType(self, path, revision):
diff --git a/dev-util/svnmailer/svnmailer-1.0.8-r2.ebuild b/dev-util/svnmailer/svnmailer-1.0.8-r2.ebuild
new file mode 100644
index 000000000000..f6b6cc9d9cb2
--- /dev/null
+++ b/dev-util/svnmailer/svnmailer-1.0.8-r2.ebuild
@@ -0,0 +1,43 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/svnmailer/svnmailer-1.0.8-r2.ebuild,v 1.1 2008/04/06 13:41:20 hanno Exp $
+
+inherit distutils eutils
+
+DESCRIPTION="A subversion commit notifier written in Python"
+SRC_URI="http://storage.perlig.de/svnmailer/${P}.tar.bz2"
+HOMEPAGE="http://opensource.perlig.de/svnmailer/"
+
+IUSE=""
+SLOT="0"
+KEYWORDS="~x86 ~amd64"
+LICENSE="Apache-2.0"
+
+DEPEND=">=dev-lang/python-2.3"
+RDEPEND="${DEPEND}
+ dev-util/subversion
+ virtual/mta"
+
+DOCS="CHANGES NOTICE CREDITS"
+
+pkg_setup() {
+ if ! built_with_use dev-util/subversion python ; then
+ eerror "This package requires dev-util/subversion to be built with python support."
+ eerror "Please enable the python USE flag and remerge subversion."
+ elog "USE flags can be enabled globally in /etc/make.conf,"
+ elog "or for specific packages in /etc/portage/package.use."
+ die "dev-utils/subversion was built without python support"
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-python2.5.diff"
+}
+
+src_install() {
+ distutils_src_install
+
+ dohtml -r docs/* || die "failed to install HTML documentation"
+}