summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMichael Palimaka <kensington@gentoo.org>2012-11-05 17:53:44 +0000
committerMichael Palimaka <kensington@gentoo.org>2012-11-05 17:53:44 +0000
commit712a0458b02f4e96c051e802fd7002b7d730e12b (patch)
treea39932c8403b0db8bdd627e3c7690eb0172cc8fc /dev-util/synopsis/synopsis-0.13.ebuild
parentrev bumped, doc use flag added, tests restricted for python3 due to known fai... (diff)
downloadgentoo-2-712a0458b02f4e96c051e802fd7002b7d730e12b.tar.gz
gentoo-2-712a0458b02f4e96c051e802fd7002b7d730e12b.tar.bz2
gentoo-2-712a0458b02f4e96c051e802fd7002b7d730e12b.zip
Version bump.
(Portage version: 2.1.11.31/cvs/Linux x86_64, signed Manifest commit with key 675D0D2C)
Diffstat (limited to 'dev-util/synopsis/synopsis-0.13.ebuild')
-rw-r--r--dev-util/synopsis/synopsis-0.13.ebuild52
1 files changed, 52 insertions, 0 deletions
diff --git a/dev-util/synopsis/synopsis-0.13.ebuild b/dev-util/synopsis/synopsis-0.13.ebuild
new file mode 100644
index 000000000000..423a7bfdbc99
--- /dev/null
+++ b/dev-util/synopsis/synopsis-0.13.ebuild
@@ -0,0 +1,52 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/synopsis/synopsis-0.13.ebuild,v 1.1 2012/11/05 17:53:44 kensington Exp $
+
+EAPI=4
+DISTUTILS_IN_SOURCE_BUILD=1
+PYTHON_COMPAT=( python2_5 python2_6 python2_7 )
+
+inherit distutils-r1 multilib toolchain-funcs
+
+DESCRIPTION="General source code documentation tool"
+HOMEPAGE="http://synopsis.fresco.org/index.html"
+SRC_URI="http://synopsis.fresco.org/download/${P}.tar.gz"
+
+LICENSE="GPL-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE=""
+
+COMMON_DEPEND="dev-libs/boehm-gc"
+RDEPEND="${COMMON_DEPEND}
+ media-gfx/graphviz"
+DEPEND="${COMMON_DEPEND}
+ ${RDEPEND}
+ sys-devel/bison
+ sys-devel/flex
+ virtual/pkgconfig"
+
+PATCHES=( "${FILESDIR}"/${PN}-0.12-gcc45.patch )
+
+pkg_setup() {
+ tc-export CC CXX
+}
+
+python_prepare() {
+ rm -r src/Synopsis/gc || die "failed to remove bundled lib"
+
+ # the distutils script passes its options to a number of
+ # autoconf scripts, to not all of which these options are
+ # relevant. adding this option disables these useless warnings.
+ sed -e "/self.announce(command)/i\ command += ' --disable-option-checking'" \
+ -i Synopsis/dist/command/config.py || die
+}
+
+python_configure() {
+ local mydistutilsargs=(
+ config
+ --libdir=/usr/$(get_libdir)
+ --with-gc-prefix=/usr
+ )
+ esetup.py
+}