summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeremy Olexa <darkside@gentoo.org>2008-07-17 03:48:55 +0000
committerJeremy Olexa <darkside@gentoo.org>2008-07-17 03:48:55 +0000
commit58cd7befda7ae958348533b2c12bdad245894ad0 (patch)
tree0dfb50c33d1c40dad06a03bef11f329b3da8965d /dev-util/valkyrie
parentp.mask app-emulation/basiliskII-jit-1.0.0-r1 for removal. bug #232039 (diff)
downloadgentoo-2-58cd7befda7ae958348533b2c12bdad245894ad0.tar.gz
gentoo-2-58cd7befda7ae958348533b2c12bdad245894ad0.tar.bz2
gentoo-2-58cd7befda7ae958348533b2c12bdad245894ad0.zip
trivial version bump. bug #230557. Thanks to David Hallas for reporting and initial testing
(Portage version: 2.2_rc1/cvs/Linux 2.6.22-gentoo-r2 i686)
Diffstat (limited to 'dev-util/valkyrie')
-rw-r--r--dev-util/valkyrie/ChangeLog8
-rw-r--r--dev-util/valkyrie/valkyrie-1.3.0.ebuild39
2 files changed, 46 insertions, 1 deletions
diff --git a/dev-util/valkyrie/ChangeLog b/dev-util/valkyrie/ChangeLog
index 9f0554826652..d993fed87a0d 100644
--- a/dev-util/valkyrie/ChangeLog
+++ b/dev-util/valkyrie/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/valkyrie
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/ChangeLog,v 1.7 2008/04/21 17:26:05 phreak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/ChangeLog,v 1.8 2008/07/17 03:48:55 darkside Exp $
+
+*valkyrie-1.3.0 (17 Jul 2008)
+
+ 17 Jul 2008; Jeremy Olexa <darkside@gentoo.org> +valkyrie-1.3.0.ebuild:
+ trivial version bump. bug #230557. Thanks to David Hallas for reporting and
+ initial testing
21 Apr 2008; Christian Heim <phreak@gentoo.org> metadata.xml:
Fix up metadata.xml. If there's no maintainer for the package, the metadata
diff --git a/dev-util/valkyrie/valkyrie-1.3.0.ebuild b/dev-util/valkyrie/valkyrie-1.3.0.ebuild
new file mode 100644
index 000000000000..116f3ee705aa
--- /dev/null
+++ b/dev-util/valkyrie/valkyrie-1.3.0.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/valkyrie/valkyrie-1.3.0.ebuild,v 1.1 2008/07/17 03:48:55 darkside Exp $
+
+inherit eutils qt3
+
+DESCRIPTION="Graphical front-end to the Valgrind suite of tools"
+HOMEPAGE="http://www.open-works.co.uk/projects/valkyrie.html"
+SRC_URI="http://www.valgrind.org/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~x86"
+IUSE="debug"
+
+DEPEND="$(qt_min_version 3)"
+RDEPEND="${DEPEND}
+ =dev-util/valgrind-3.3*"
+
+src_compile() {
+ use debug || sed -i -e '/#define DEBUG_ON/ s:1:0:' \
+ "${S}/valkyrie/vk_utils.h"
+
+ econf \
+ --disable-dependency-tracking \
+ --with-Qt-dir="${QTDIR}" || die "econf failed"
+
+ # Use the right path for the documentation
+ sed -i -e '/VK_DOC_PATH/ s:/doc/:/share/doc/'${PF}'/html/:g' \
+ "${S}/config.h"
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" docdir="/usr/share/doc/${PF}/html" install
+
+ dodoc README README_DEVELOPERS AUTHORS
+}