summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorHans de Graaff <graaff@gentoo.org>2012-01-15 18:05:46 +0000
committerHans de Graaff <graaff@gentoo.org>2012-01-15 18:05:46 +0000
commitbaddf18baca5c6e27813ddfe72b5bb9f57d15c2c (patch)
tree36574e30b6dd8e5b29b432e2823d29e10ed959d3 /dev-util/watchr/watchr-0.7.ebuild
parentsh stable (diff)
downloadgentoo-2-baddf18baca5c6e27813ddfe72b5bb9f57d15c2c.tar.gz
gentoo-2-baddf18baca5c6e27813ddfe72b5bb9f57d15c2c.tar.bz2
gentoo-2-baddf18baca5c6e27813ddfe72b5bb9f57d15c2c.zip
Initial import from overlay 'graaff'.
(Portage version: 2.1.10.41/cvs/Linux x86_64)
Diffstat (limited to 'dev-util/watchr/watchr-0.7.ebuild')
-rw-r--r--dev-util/watchr/watchr-0.7.ebuild24
1 files changed, 24 insertions, 0 deletions
diff --git a/dev-util/watchr/watchr-0.7.ebuild b/dev-util/watchr/watchr-0.7.ebuild
new file mode 100644
index 000000000000..27cac264efe9
--- /dev/null
+++ b/dev-util/watchr/watchr-0.7.ebuild
@@ -0,0 +1,24 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/watchr/watchr-0.7.ebuild,v 1.1 2012/01/15 18:05:46 graaff Exp $
+
+EAPI=2
+USE_RUBY="ruby18 ruby19"
+
+RUBY_FAKEGEM_TASK_DOC=""
+
+# Requires every which we don't have packaged.
+RUBY_FAKEGEM_TASK_TEST=""
+
+inherit ruby-fakegem
+
+DESCRIPTION="Modern continuous testing (flexible alternative to Autotest)"
+HOMEPAGE="http://mynyml.com/ruby/flexible-continuous-testing"
+LICENSE="MIT"
+
+KEYWORDS="~amd64 ~x86 ~x86-macos"
+SLOT="0"
+IUSE=""
+
+# This is an optional dependency, but highly recommended on unix systems
+ruby_add_rdepend "dev-ruby/rev"