summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJeroen Roovers <jer@gentoo.org>2010-05-07 00:38:42 +0000
committerJeroen Roovers <jer@gentoo.org>2010-05-07 00:38:42 +0000
commitb9ebda7bb8322966aee82cfc8fea1d0392b605ba (patch)
treee1f5c295206bce96941944e7acf1ce557957c2b0 /dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild
parentVersion bump. (diff)
downloadgentoo-2-b9ebda7bb8322966aee82cfc8fea1d0392b605ba.tar.gz
gentoo-2-b9ebda7bb8322966aee82cfc8fea1d0392b605ba.tar.bz2
gentoo-2-b9ebda7bb8322966aee82cfc8fea1d0392b605ba.zip
Set RDEPEND so it is not set implicitly (bug #221331). Respect CC (bug #244048), CFLAGS and LDFLAGS.
(Portage version: 2.2_rc67/cvs/Linux i686)
Diffstat (limited to 'dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild')
-rw-r--r--dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild35
1 files changed, 35 insertions, 0 deletions
diff --git a/dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild b/dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild
new file mode 100644
index 000000000000..7bada54bebdd
--- /dev/null
+++ b/dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild
@@ -0,0 +1,35 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/xmlindent/xmlindent-0.2.17-r1.ebuild,v 1.1 2010/05/07 00:38:42 jer Exp $
+
+EAPI="2"
+
+inherit toolchain-funcs
+
+DESCRIPTION="XML Indent is an XML stream reformatter written in ANSI C, analogous to GNU indent."
+HOMEPAGE="http://xmlindent.sourceforge.net/"
+SRC_URI="mirror://sourceforge/xmlindent/${P}.tar.gz"
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~sparc ~x86"
+
+IUSE=""
+DEPEND="sys-devel/flex"
+RDEPEND=""
+
+src_prepare() {
+ sed -i Makefile \
+ -e 's|gcc|$(CC)|g' \
+ -e 's|-g|$(CFLAGS) $(LDFLAGS) |g' \
+ || die "sed failed"
+}
+
+src_compile() {
+ tc-export CC
+ emake || die "emake failed"
+}
+
+src_install() {
+ dobin xmlindent || die "dobin failed"
+ doman *.1
+}