summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFernando J. Pereda <ferdy@gentoo.org>2005-12-21 09:48:47 +0000
committerFernando J. Pereda <ferdy@gentoo.org>2005-12-21 09:48:47 +0000
commit1841cd40ba8ffe997d459e813ab6fe73da61e97a (patch)
treeb9ef2690447493a720901f1e98e32052901c612b /dev-util
parentadding ~ppc (diff)
downloadgentoo-2-1841cd40ba8ffe997d459e813ab6fe73da61e97a.tar.gz
gentoo-2-1841cd40ba8ffe997d459e813ab6fe73da61e97a.tar.bz2
gentoo-2-1841cd40ba8ffe997d459e813ab6fe73da61e97a.zip
New upstream version
(Portage version: 2.0.51.22-r3)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/Manifest12
-rw-r--r--dev-util/git/files/digest-git-1.0.01
-rw-r--r--dev-util/git/git-1.0.0.ebuild113
4 files changed, 122 insertions, 11 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index 2feef184c4d9..2b112d2f6045 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2005 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.52 2005/12/15 09:47:35 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.53 2005/12/21 09:48:47 ferdy Exp $
+
+*git-1.0.0 (21 Dec 2005)
+
+ 21 Dec 2005; Fernando J. Pereda <ferdy@gentoo.org> +git-1.0.0.ebuild:
+ New upstream version
*git-0.99.9n (15 Dec 2005)
diff --git a/dev-util/git/Manifest b/dev-util/git/Manifest
index 7201b62bdbcf..0684da1bbaa8 100644
--- a/dev-util/git/Manifest
+++ b/dev-util/git/Manifest
@@ -1,6 +1,4 @@
------BEGIN PGP SIGNED MESSAGE-----
-Hash: SHA1
-
+MD5 ec1ae1059acacb4fa48cd8f4a10dc7ff git-1.0.0.ebuild 3248
MD5 d35a0c0793dbfc65191588d2eca405d1 git-0.99.8a.ebuild 2835
MD5 836fd3f0a31e670e7cdb6350d38f5323 git-0.99.9n.ebuild 3342
MD5 edebd592261315b29a6b903b414573d2 git-0.7.ebuild 1312
@@ -10,11 +8,5 @@ MD5 5c96e23fef078682e648254d9197f618 files/git-daemon.confd 376
MD5 ad6b9193f41375013fad4455bf1acda7 files/git-daemon.initd 526
MD5 62316f61a79143fdaf1e9f747d1ddf03 files/digest-git-0.99.8a 69
MD5 ede5785dc3531d89fe224f16c233e8d2 files/digest-git-0.99.9n 64
+MD5 d595491de4b7b5821570152627ef35c6 files/digest-git-1.0.0 62
MD5 8ebc37d29c321b95a3c0ae51ebee4d4d files/digest-git-0.7 59
------BEGIN PGP SIGNATURE-----
-Version: GnuPG v1.4.2 (GNU/Linux)
-
-iD8DBQFDoTvJViELBEf1JB0RAsOzAJ9XuPA+FoD/Bz+Ktc0uLZ1TF+1+ZgCfZMUl
-bR9LBXlF+m4iDVswGYlVBg0=
-=r0eF
------END PGP SIGNATURE-----
diff --git a/dev-util/git/files/digest-git-1.0.0 b/dev-util/git/files/digest-git-1.0.0
new file mode 100644
index 000000000000..b5c07fcc0b88
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.0.0
@@ -0,0 +1 @@
+MD5 fd0a57fb1a9099752ab93412d394ccc5 git-1.0.0.tar.bz2 475364
diff --git a/dev-util/git/git-1.0.0.ebuild b/dev-util/git/git-1.0.0.ebuild
new file mode 100644
index 000000000000..a8e617844017
--- /dev/null
+++ b/dev-util/git/git-1.0.0.ebuild
@@ -0,0 +1,113 @@
+# Copyright 1999-2005 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.0.0.ebuild,v 1.1 2005/12/21 09:48:47 ferdy Exp $
+
+inherit python toolchain-funcs eutils
+
+DESCRIPTION="GIT - the stupid content tracker"
+HOMEPAGE="http://kernel.org/pub/software/scm/git/"
+SRC_URI="http://kernel.org/pub/software/scm/git/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="mozsha1 ppcsha1 doc curl tcltk gitsendemail webdav"
+
+DEPEND="dev-libs/openssl
+ sys-libs/zlib
+ !app-misc/git
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ doc? ( >=app-text/asciidoc-7.0.1 app-text/xmlto )"
+RDEPEND="${DEPEND}
+ dev-lang/perl
+ >=dev-lang/python-2.3
+ app-text/rcs
+ tcltk? ( dev-lang/tk )
+ dev-perl/String-ShellQuote
+ gitsendemail? ( dev-perl/Mail-Sendmail dev-perl/Email-Valid )"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ use gitsendemail && myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ # Older python versions need own subproccess.py
+ python_version
+ [[ ${PYVER} < 2.4 ]] && myopts="${myopts} WITH_OWN_SUBPROCESS_PY=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+src_unpack() {
+ unpack ${A}
+ cd ${S}
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} prefix=/usr || die "make failed"
+
+ if use doc ; then
+ sed -i \
+ -e "s:^\(WEBDOC_DEST = \).*$:\1${D}/usr/share/doc/${PF}/html/:g" \
+ ${S}/Documentation/Makefile || die "sed failed (Documentation)"
+ emake -C Documentation/ || die "make documentation failed"
+ fi
+}
+
+src_install() {
+ make ${MY_MAKEOPTS} DESTDIR=${D} prefix=/usr install || die "make install failed"
+
+ use tcltk || rm ${D}/usr/bin/gitk
+
+ dodoc README COPYING Documentation/SubmittingPatches
+ if use doc ; then
+ doman Documentation/*.1 Documentation/*.7
+ make install-webdoc -C Documentation/
+ dodoc Documentation/technical/*
+ fi
+
+ newinitd "${FILESDIR}/git-daemon.initd" git-daemon
+ newconfd "${FILESDIR}/git-daemon.confd" git-daemon
+}
+
+src_test() {
+ cd ${S}
+ make ${MY_MAKEOPTS} test || die "tests failed"
+}
+
+pkg_postinst() {
+ einfo
+ einfo "If you want to import arch repositories into git, consider using the"
+ einfo "git-archimport command. You should install dev-util/tla before"
+ einfo
+ einfo "If you want to import cvs repositories into git, consider using the"
+ einfo "git-cvsimport command. You should install >=dev-util/cvsps-2.1 before"
+ einfo
+ einfo "If you want to import svn repositories into git, consider using the"
+ einfo "git-svnimport command. You should install dev-util/subversion before"
+ einfo
+}