summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 21:05:17 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2009-12-19 21:05:17 +0000
commit2b874d2643d496362fa1d2dc119aa1a1f0fdd52b (patch)
tree68eaac4f3e3aab8b677ccd114b191d140dd5f98a /dev-util
parentDelete older ebuild. (diff)
downloadgentoo-2-2b874d2643d496362fa1d2dc119aa1a1f0fdd52b.tar.gz
gentoo-2-2b874d2643d496362fa1d2dc119aa1a1f0fdd52b.tar.bz2
gentoo-2-2b874d2643d496362fa1d2dc119aa1a1f0fdd52b.zip
Version bump.
(Portage version: 15121-svn/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/global/ChangeLog8
-rw-r--r--dev-util/global/global-5.7.7.ebuild68
2 files changed, 75 insertions, 1 deletions
diff --git a/dev-util/global/ChangeLog b/dev-util/global/ChangeLog
index afce41f076b2..f522e4b0ea5b 100644
--- a/dev-util/global/ChangeLog
+++ b/dev-util/global/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/global
# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.42 2009/11/22 20:21:25 tcunha Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/ChangeLog,v 1.43 2009/12/19 21:05:17 arfrever Exp $
+
+*global-5.7.7 (19 Dec 2009)
+
+ 19 Dec 2009; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ +global-5.7.7.ebuild:
+ Version bump.
22 Nov 2009; Tiago Cunha <tcunha@gentoo.org> global-5.7.6.ebuild:
stable sparc, bug 292307
diff --git a/dev-util/global/global-5.7.7.ebuild b/dev-util/global/global-5.7.7.ebuild
new file mode 100644
index 000000000000..49eb8402ff4c
--- /dev/null
+++ b/dev-util/global/global-5.7.7.ebuild
@@ -0,0 +1,68 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/global/global-5.7.7.ebuild,v 1.1 2009/12/19 21:05:17 arfrever Exp $
+
+EAPI="2"
+
+inherit elisp-common
+
+DESCRIPTION="GNU Global is a tag system to find the locations of a specified object in various sources."
+HOMEPAGE="http://www.gnu.org/software/global/global.html"
+SRC_URI="ftp://ftp.gnu.org/pub/gnu/${PN}/${P}.tar.gz"
+LICENSE="GPL-3"
+
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~sparc ~x86"
+IUSE="doc vim emacs"
+
+RDEPEND="vim? ( || ( app-editors/vim app-editors/gvim ) )
+ emacs? ( virtual/emacs )"
+DEPEND="${DEPEND}
+ doc? ( app-text/texi2html sys-apps/texinfo )"
+
+SITEFILE=50gtags-gentoo.el
+
+src_compile() {
+ if use doc; then
+ texi2pdf -q -o doc/global.pdf doc/global.texi
+ texi2html -o doc/global.html doc/global.texi
+ fi
+
+ if use emacs; then
+ elisp-compile *.el || die "elisp-compile failed"
+ fi
+
+ emake || die "emake failed"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die "emake install failed"
+ if use doc; then
+ dohtml doc/global.html
+ [[ -f doc/global.pdf ]] && dodoc doc/global.pdf
+ fi
+ dodoc AUTHORS FAQ NEWS README THANKS
+
+ insinto /etc
+ doins gtags.conf
+ insinto /usr/share/${PN}
+ doins gtags.pl globash.rc
+
+ if use vim; then
+ insinto /usr/share/vim/vimfiles/plugin
+ doins gtags.vim
+ fi
+
+ if use emacs; then
+ elisp-install gtags *.{el,elc}
+ elisp-site-file-install "${FILESDIR}/${SITEFILE}"
+ fi
+}
+
+pkg_postinst() {
+ use emacs && elisp-site-regen
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}