summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorPaul de Vrieze <pauldv@gentoo.org>2003-05-17 13:16:39 +0000
committerPaul de Vrieze <pauldv@gentoo.org>2003-05-17 13:16:39 +0000
commit32c63cc316e45982cd3eaefa8cd6923340084de8 (patch)
tree22d596a5b93c6793ce65fb02eec24ff6347d1aa4 /dev-util
parentNew version of the subversion ebuild. Please test. (diff)
downloadgentoo-2-32c63cc316e45982cd3eaefa8cd6923340084de8.tar.gz
gentoo-2-32c63cc316e45982cd3eaefa8cd6923340084de8.tar.bz2
gentoo-2-32c63cc316e45982cd3eaefa8cd6923340084de8.zip
New version of the subversion ebuild. Please test.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/subversion/ChangeLog9
-rw-r--r--dev-util/subversion/Manifest4
-rw-r--r--dev-util/subversion/files/digest-subversion-0.22.22
-rw-r--r--dev-util/subversion/subversion-0.22.2.ebuild224
4 files changed, 236 insertions, 3 deletions
diff --git a/dev-util/subversion/ChangeLog b/dev-util/subversion/ChangeLog
index f1116e4d3498..53cc24da9529 100644
--- a/dev-util/subversion/ChangeLog
+++ b/dev-util/subversion/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/subversion
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.17 2003/05/12 20:52:38 mholzer Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/ChangeLog,v 1.18 2003/05/17 13:16:31 pauldv Exp $
+
+*subversion-0.22.2 (17 May 2003)
+
+ 17 May 2003; Paul de Vrieze <pauldv@gentoo.org> subversion-0.22.2.ebuild:
+ New upstream version, and inclusion of berkdb and python useflags. For now
+ python bindings are never build if berkdb is not set as the bindings
+ unconditionally depend on python. Closes #20840 and #20842
*subversion-0.21.0-r1 (30 Apr 2003)
diff --git a/dev-util/subversion/Manifest b/dev-util/subversion/Manifest
index 7ffb07deddee..be1eeb391846 100644
--- a/dev-util/subversion/Manifest
+++ b/dev-util/subversion/Manifest
@@ -1,9 +1,9 @@
MD5 a343df53435bdcfc3a4c85f3e9912102 subversion-0.10_pre1.ebuild 8054
-MD5 77b7ff6277e0371cb59f127e2bda2f9d ChangeLog 2482
+MD5 0c048a923bcd4950809fd32ee0a53b3d ChangeLog 2801
MD5 ca1f55a8afc4e3f889452aca89d9ebac subversion-0.20.1.ebuild 5566
MD5 fd3ac2ef875451503c8829716f9dc2e2 subversion-0.21.0-r1.ebuild 5721
MD5 7a45c9dae1829ed6fa2b22ead64c4eab subversion-0.21.0.ebuild 6494
-MD5 ad28c7d83c203a7dd0a39f125768457a subversion-0.22.2.ebuild 5721
+MD5 85a83ed1c428964a9c891992f01e957f subversion-0.22.2.ebuild 6756
MD5 8208be10eefcdc258afb4ca8d410a06c files/digest-subversion-0.10_pre1 446
MD5 8761867d2d9c80254eb9945021b552fa files/digest-subversion-0.20.1 132
MD5 d3250565b5dca16ba84df4bb5075992b files/digest-subversion-0.21.0 132
diff --git a/dev-util/subversion/files/digest-subversion-0.22.2 b/dev-util/subversion/files/digest-subversion-0.22.2
new file mode 100644
index 000000000000..1dd5957af994
--- /dev/null
+++ b/dev-util/subversion/files/digest-subversion-0.22.2
@@ -0,0 +1,2 @@
+MD5 12262c64fcd64b772e7cffad8e4d0ebc db-4.0.14.tar.gz 2701799
+MD5 68213306ec24b0d2189aea0f68a7c223 subversion-0.22.2.tar.gz 7713105
diff --git a/dev-util/subversion/subversion-0.22.2.ebuild b/dev-util/subversion/subversion-0.22.2.ebuild
new file mode 100644
index 000000000000..d1ee6c8c1f86
--- /dev/null
+++ b/dev-util/subversion/subversion-0.22.2.ebuild
@@ -0,0 +1,224 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/subversion/subversion-0.22.2.ebuild,v 1.1 2003/05/17 13:16:31 pauldv Exp $
+
+inherit libtool
+
+DESCRIPTION="A compelling replacement for CVS"
+SRC_URI="http://www.sleepycat.com/update/snapshot/db-4.0.14.tar.gz
+ http://subversion.tigris.org/files/documents/15/4097/${P}.tar.gz"
+HOMEPAGE="http://subversion.tigris.org/"
+
+SLOT="0"
+LICENSE="Apache-1.1"
+KEYWORDS="~x86"
+IUSE="ssl apache2 berkdb python"
+
+S_DB="${WORKDIR}/db-4.0.14/build_unix"
+
+DEPEND="python? ( >=dev-lang/python-2.0 )
+ >=sys-apps/diffutils-2.7.7
+ >=sys-devel/libtool-1.4.1-r1
+ >=sys-devel/bison-1.28-r3
+ apache2? ( >=net-www/apache-2.0.45 )
+ !apache2? ( !>=apache-2* )
+ !dev-libs/apr
+ ~sys-devel/m4-1.4
+ python? ( >=dev-lang/swig-1.3.16 )
+ >=net-misc/neon-0.23.8"
+
+RDEPEND="python? ( >=dev-lang/python-2.0 )
+ >=sys-apps/diffutils-2.7.7
+ ~sys-devel/m4-1.4"
+
+pkg_setup() {
+ if use apache2; then
+ einfo "The apache2 subversion module will be built, and libapr from the"
+ einfo "apache package will be used instead of the included"
+ else
+ einfo "Please note that subversion and apache2 cannot be installed"
+ einfo "simultaneously without specifying the apache2 use flag. This is"
+ einfo "because subversion installs its own libapr and libapr-util in that"
+ einfo "case."
+ fi
+}
+
+src_unpack() {
+ cd ${WORKDIR}
+ unpack ${P}.tar.gz
+ use berkdb && ( has_version =db-4* || (
+ unpack db-4.0.14.tar.gz
+ ) )
+ cd ${S}
+}
+
+src_compile() {
+ local myconf
+ elibtoolize
+ use berkdb && ( has_version =db-4* || (
+ cd ${S_DB}
+ ../dist/configure \
+ --prefix=/usr \
+ --mandir=/usr/share/man \
+ --infodir=/usr/share/info \
+ --datadir=/usr/share \
+ --sysconfdir=/etc \
+ --localstatedir=/var/lib \
+ --disable-compat185 \
+ --disable-cxx \
+ --disable-tcl \
+ --disable-java \
+ --disable-shared \
+ --with-uniquename
+ emake || make || die "db make failed"
+ [ -e ${WORKDIR}/dbinst ] && rm -rf ${WORKDIR}/dbinst
+ mkdir -p ${WORKDIR}/dbinst/lib
+ make prefix=${WORKDIR}/dbinst install ||die
+ mkdir ${WORKDIR}/dbinst/include/db4
+ cp ${WORKDIR}/dbinst/include/*.h ${WORKDIR}/dbinst/include/db4
+ mv ${WORKDIR}/dbinst/lib/libdb.a ${WORKDIR}/dbinst/lib/libdb4.a
+ cat <<EOF >${WORKDIR}/dbinst/lib/libdb4.so
+GROUP( ${WORKDIR}/dbinst/lib/libdb4.a /usr/lib/libdb.so)
+EOF
+ ) ) #no db4
+
+ cd ${S}
+ use ssl && myconf="${myconf} --with-ssl"
+ use ssl || myconf="${myconf} --without-ssl"
+
+ use apache2 && myconf="${myconf} --with-apxs=/usr/sbin/apxs2 \
+ --with-apr=/usr --with-apr-util=/usr"
+ use apache2 || myconf="${myconf} --without-apxs"
+
+ if use berkdb; then
+ has_version =db-4* && myconf="${myconf} --with-berkeley-db"
+ has_version =db-4* || myconf="${myconf} --with-berkeley-db=${WORKDIR}/dbinst"
+ else
+ myconf="${myconf} --without-berkeley-db"
+ fi
+
+ use python && myconf="${myconf} --with-python=/usr/bin/python --with-swig"
+ use python || myconf="${myconf} --without-python --without-swig"
+
+ echo "myconf=${myconf}"
+ LDFLAGS=${LDFLAGS} econf ${myconf} \
+ --with-neon=/usr \
+ --disable-mod-activation ||die "configuration failed"
+ # build subversion, but do it in a way that is safe for paralel builds
+ ( emake external-all && emake local-all ) || die "make of subversion failed"
+
+ #building fails without the apache apr-util as includes are wrong.
+ #Also the python bindings do not work without db installed
+ if use python; then
+ if use berkdb; then
+ if use apache2; then
+ emake swig-py || die "subversion python bindings failed"
+ else
+ emake SVN_APR_INCLUDES="-I${S}/apr/include -I${S}/apr-util/include" swig-py || die "subversion python bindings failed"
+ fi
+ fi
+ fi
+}
+
+
+src_install () {
+ mkdir -p ${D}/etc/apache2/conf
+ mkdir -p ${D}/etc/share
+
+ use berkdb && ( has_version =db-4* || (
+ mkdir -p ${D}/usr/share/subversion/bin
+ cp ${WORKDIR}/dbinst/bin/* ${D}/usr/share/subversion/bin/
+ ) )
+
+ make DESTDIR=${D} install || die "Installation of subversion failed"
+ if [ -e ${D}/usr/lib/apache2 ]; then
+ mv ${D}/usr/lib/apache2 ${D}/usr/lib/apache2-extramodules
+ fi
+
+ if use python; then
+ if use berkdb; then
+ make install-swig-py DESTDIR=${D} DISTUTIL_PARAM=--prefix=${D} || die "Installation of subversion python bindings failed"
+ # install cvs2svn
+ dobin tools/cvs2svn/cvs2svn.py
+ mv ${D}/usr/bin/cvs2svn.py ${D}/usr/bin/cvs2svn
+ doman tools/cvs2svn/cvs2svn.1
+
+ # move python bindings
+ mkdir -p ${D}/usr/lib/python2.2/site-packages
+ cp -r tools/cvs2svn/rcsparse ${D}/usr/lib/python2.2/site-packages
+ mv ${D}/usr/lib/svn-python/svn ${D}/usr/lib/python2.2/site-packages
+ rmdir ${D}/usr/lib/svn-python
+ fi
+ fi
+
+ dodoc BUGS COMMITTERS COPYING HACKING IDEAS INSTALL PORTING README
+ dodoc tools/xslt/svnindex.css tools/xslt/svnindex.xsl
+
+ # install documentation
+ cd notes
+ for f in *.txt
+ do
+ dodoc ${f}
+ done
+ cd ${S}
+ echo "installing html book"
+ dohtml -r doc/book/book/book.html doc/book/book/styles.css doc/book/book/images
+ if use apache; then
+ mkdir -p ${D}/etc/apache2/conf/modules.d
+ cat <<EOF >${D}/etc/apache2/conf/modules.d/47_mod_dav_svn.conf
+<IfDefine SVN>
+ <IfModule !mod_dav_svn.c>
+ LoadModule dav_svn_module extramodules/mod_dav_svn.so
+ </IfModule>
+ <Location /svn/repos>
+ DAV svn
+ SVNPath /home/svn/repos
+ AuthType Basic
+ AuthName "Subversion repository"
+ AuthUserFile /home/svn/conf/svnusers
+ Require valid-user
+ </Location>
+</IfDefine>
+EOF
+ fi
+}
+
+pkg_postinst() {
+ if use berkdb; then
+ if use apache; then
+ einfo "Subversion has multiple server types. To enable the http based version"
+ einfo "you must edit /etc/conf.d/apache2 to include both \"-D DAV\" and \"-D SVN\""
+ einfo ""
+ fi
+ einfo "A repository needs to be created using the ebuild ${PN} config command"
+ if use apache; then
+ einfo "To allow web access a htpasswd file needs to be created using the"
+ einfo "following command:"
+ einfo " htpasswd2 -m -c /home/svn/conf/svnusers USERNAME"
+ fi
+ else
+ einfo "Your subversion is client only as the server is only build when"
+ einfo "the berkdb flag is set"
+ fi
+}
+
+pkg_config() {
+ if [ ! -x /usr/bin/svnadmin ]; then
+ die "You seem to only have build the subversion client"
+ fi
+ einfo ">>> Initializing the database ..."
+ if [ -f /home/svn/repos ] ; then
+ echo "A subversion repository already exists and I will not overwrite it."
+ echo "Delete /home/svn/repos first if you're sure you want to have a clean version."
+ else
+ mkdir -p /home/svn
+ einfo ">>> Populating repository directory ..."
+ # create initial repository
+ /usr/bin/svnadmin create /home/svn/repos
+
+ einfo ">>> Setting repository permissions ..."
+ chown -Rf apache.apache /home/svn/repos
+ chmod -Rf 755 /home/svn/repos
+ fi
+}
+