summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2008-03-29 07:59:42 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2008-03-29 07:59:42 +0000
commit47216dc61018dfd30930076f58c769e9d1a8d3e2 (patch)
tree58339e9ca958a6313a8e2debf01a2527051cec07 /dev-util
parentFix seamonkey support in 0.16.0 (diff)
downloadgentoo-2-47216dc61018dfd30930076f58c769e9d1a8d3e2.tar.gz
gentoo-2-47216dc61018dfd30930076f58c769e9d1a8d3e2.tar.bz2
gentoo-2-47216dc61018dfd30930076f58c769e9d1a8d3e2.zip
Version bump.
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog7
-rw-r--r--dev-util/git/git-1.5.4.5.ebuild270
2 files changed, 276 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index eee81a02467d..679456fb6657 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/git
# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.264 2008/03/24 15:48:19 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.265 2008/03/29 07:59:42 robbat2 Exp $
+
+*git-1.5.4.5 (29 Mar 2008)
+
+ 29 Mar 2008; Robin H. Johnson <robbat2@gentoo.org> +git-1.5.4.5.ebuild:
+ Version bump.
24 Mar 2008; Raúl Porcel <armin76@gentoo.org> git-1.5.4.4-r1.ebuild:
Re-add ~ia64 wrt #214464
diff --git a/dev-util/git/git-1.5.4.5.ebuild b/dev-util/git/git-1.5.4.5.ebuild
new file mode 100644
index 000000000000..9eb621d98eec
--- /dev/null
+++ b/dev-util/git/git-1.5.4.5.ebuild
@@ -0,0 +1,270 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.5.4.5.ebuild,v 1.1 2008/03/29 07:59:42 robbat2 Exp $
+
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion
+
+MY_PV="${PV/_rc/.rc}"
+MY_P="${PN}-${MY_PV}"
+
+DOC_VER=${MY_PV}
+
+DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="curl cgi doc emacs gtk iconv mozsha1 perl ppcsha1 tk threads webdav xinetd cvs subversion"
+
+DEPEND="
+ !app-misc/git
+ dev-libs/openssl
+ sys-libs/zlib
+ app-arch/cpio
+ perl? ( dev-lang/perl )
+ tk? ( dev-lang/tk )
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+# dev-perl/{Authen-SASL,Net-SMTP-SSL} are used by git-send-email
+
+RDEPEND="${DEPEND}
+ perl? ( dev-perl/Error
+ dev-perl/Net-SMTP-SSL
+ dev-perl/Authen-SASL
+ cgi? ( virtual/perl-CGI )
+ cvs? ( >=dev-util/cvsps-2.1 dev-perl/DBI dev-perl/DBD-SQLite )
+ subversion? ( dev-util/subversion dev-perl/libwww-perl dev-perl/TermReadKey )
+ )
+ gtk? ( >=dev-python/pygtk-2.8 )"
+
+SITEFILE=72${PN}-gentoo.el
+S="${WORKDIR}/${MY_P}"
+
+pkg_setup() {
+ if ! use perl ; then
+ if use cgi || use cvs || use subversion ; then
+ eerror "You must built dev-util/git with USE=perl and the"
+ eerror "applicable USE flag to use any of the following:"
+ eerror "gitweb, git-cvs*, git-svn, git-archimport, git-quiltimport"
+ die "You need USE=perl to satisfy your other USE= requests!"
+ fi
+ fi
+}
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ use iconv || myopts="${myopts} NO_ICONV=YesPlease"
+ use tk || myopts="${myopts} NO_TCLTK=YesPlease"
+ use perl || myopts="${myopts} NO_PERL=YesPlease"
+ use threads && myopts="${myopts} THREADED_DELTA_SEARCH=YesPlease"
+ use subversion || myopts="${myopts} NO_SVN_TESTS=YesPlease"
+
+ export MY_MAKEOPTS="${myopts}"
+}
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ unpack ${PN}-manpages-${DOC_VER}.tar.bz2
+ use doc && cd "${S}"/Documentation && unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.5.3-symlinks.patch
+ epatch "${FILESDIR}"/20080322-${PN}-1.5.5.4-noperl.patch
+
+ sed -i \
+ -e "s:^\(CFLAGS =\).*$:\1 ${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS =\).*$:\1 ${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ -e 's:ln :ln -s :g' \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+ if use perl && use cgi ; then
+ emake ${MY_MAKEOPTS} \
+ DESTDIR="${D}" \
+ prefix=/usr \
+ gitweb/gitweb.cgi || die "make gitweb/gitweb.cgi failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || \
+ die "make install failed"
+
+ doman man?/*
+
+ dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
+ use doc && dodir /usr/share/doc/${PF}/html
+ for d in / /howto/ /technical/ ; do
+ docinto ${d}
+ dodoc Documentation${d}*.txt
+ use doc && dohtml -p ${d} Documentation${d}*.html
+ done
+ docinto /
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ elisp-install ${PN} contrib/emacs/{,vc-}git.el* || \
+ die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${D}"/"${SITELISP}"/${PN}/.nosearch
+ fi
+
+ if use gtk ; then
+ dobin "${S}"/contrib/gitview/gitview
+ dodoc "${S}"/contrib/gitview/gitview.txt
+ fi
+
+ dobin contrib/fast-import/git-p4
+ dodoc contrib/fast-import/git-p4.txt
+ newbin contrib/fast-import/import-tars.perl import-tars
+
+ dodir /usr/share/${PN}/contrib
+ # The following are excluded:
+ # svnimport - use git-svn
+ # p4import - excluded because fast-import has a better one
+ # examples - these are stuff that is not used in Git anymore actually
+ # patches - stuff the Git guys made to go upstream to other places
+ for i in continuous fast-import hg-to-git \
+ hooks remotes2config.sh vim stats \
+ workdir convert-objects blameview ; do
+ cp -rf \
+ "${S}"/contrib/${i} \
+ "${D}"/usr/share/${PN}/contrib \
+ || die "Failed contrib ${i}"
+ done
+
+ if use perl && use cgi ; then
+ dodir /usr/share/${PN}/gitweb
+ insinto /usr/share/${PN}/gitweb
+ doins "${S}"/gitweb/gitweb.{cgi,css}
+ doins "${S}"/gitweb/git-{favicon,logo}.png
+ docinto /
+ # INSTALL discusses configuration issues, not just installation
+ newdoc "${S}"/gitweb/INSTALL INSTALL.gitweb
+ newdoc "${S}"/gitweb/README README.gitweb
+ fi
+
+ if use xinetd ; then
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+ fi
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ local disabled=""
+ local tests_cvs="t9200-git-cvsexportcommit.sh \
+ t9400-git-cvsserver-server.sh \
+ t9600-cvsimport.sh"
+ local tests_perl="t5502-quickfetch.sh \
+ t5512-ls-remote.sh \
+ t5520-pull.sh"
+
+ # Unzip is used only for the testcase code, not by any normal parts of Git.
+ has_version app-arch/unzip || \
+ einfo "Disabling tar-tree tests" && \
+ disabled="${disabled} \
+ t5000-tar-tree.sh"
+
+ if ! has userpriv "${FEATURES}"; then
+ ewarn "Skipping CVS tests because CVS does not work as root!"
+ ewarn "You should retest with FEATURES=userpriv!"
+ disabled="${disabled} \
+ ${tests_cvs}"
+ fi
+
+ use cvs && \
+ has_version dev-util/cvs && \
+ built_with_use dev-util/cvs server || \
+ einfo "Disabling CVS tests (needs dev-util/cvs[USE=server])" && \
+ disabled="${disabled} \
+ ${tests_cvs}"
+
+ use perl || \
+ einfo "Disabling tests that need Perl" && \
+ disabled="${disabled} \
+ ${tests_perl}"
+
+ # Reset all previously disabled tests
+ cd "${S}/t"
+ for i in *.sh.DISABLED ; do
+ [[ -f "${i}" ]] && mv -f "${i}" "${i%.DISABLED}"
+ done
+ einfo "Disabled tests:"
+ for i in ${disabled} ; do
+ [[ -f "${i}" ]] && mv -f "${i}" "${i}.DISABLED" && einfo "Disabled $i"
+ done
+ cd "${S}"
+ # Now run the tests
+ einfo "Start test run"
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ elog " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elisp-site-regen
+ elog "GNU Emacs has built-in Git support in versions greater 22.1."
+ elog "You can disable the emacs USE flag for dev-util/git"
+ elog "if you are using such a version."
+ fi
+ if use subversion && ! built_with_use dev-util/subversion perl ; then
+ ewarn "You must build dev-util/subversion with USE=perl"
+ ewarn "to get the full functionality of git-svn!"
+ fi
+ elog "These additional scripts need some dependencies:"
+ echo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-instaweb \
+ "|| ( www-servers/lighttpd www-servers/apache )"
+ echo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}