summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTim Harder <radhermit@gentoo.org>2011-10-16 06:02:51 +0000
committerTim Harder <radhermit@gentoo.org>2011-10-16 06:02:51 +0000
commit4737fcb1d4e9dae8ef658ed4a9b82aaa476360c7 (patch)
tree2e84554fe83ef7c529e59b64eb9cd3b453087862 /dev-util
parentamd64 stable wrt #386963 (diff)
downloadgentoo-2-4737fcb1d4e9dae8ef658ed4a9b82aaa476360c7.tar.gz
gentoo-2-4737fcb1d4e9dae8ef658ed4a9b82aaa476360c7.tar.bz2
gentoo-2-4737fcb1d4e9dae8ef658ed4a9b82aaa476360c7.zip
Update to EAPI 4 and other minor fixes (fixes bug #387261).
(Portage version: 2.2.0_alpha67/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/ctags/ChangeLog7
-rw-r--r--dev-util/ctags/ctags-5.8.ebuild23
2 files changed, 16 insertions, 14 deletions
diff --git a/dev-util/ctags/ChangeLog b/dev-util/ctags/ChangeLog
index 679cc15736fa..7448e1c1f5e3 100644
--- a/dev-util/ctags/ChangeLog
+++ b/dev-util/ctags/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/ctags
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ChangeLog,v 1.74 2010/10/19 05:23:53 leio Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ChangeLog,v 1.75 2011/10/16 06:02:51 radhermit Exp $
+
+ 16 Oct 2011; Tim Harder <radhermit@gentoo.org> ctags-5.8.ebuild:
+ Update to EAPI 4 and other minor fixes (fixes bug #387261).
19 Oct 2010; Mart Raudsepp <leio@gentoo.org> ctags-5.5.4-r2.ebuild:
Drop to ~mips
diff --git a/dev-util/ctags/ctags-5.8.ebuild b/dev-util/ctags/ctags-5.8.ebuild
index f8175aaf30d3..348019766d23 100644
--- a/dev-util/ctags/ctags-5.8.ebuild
+++ b/dev-util/ctags/ctags-5.8.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2009 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ctags-5.8.ebuild,v 1.1 2009/11/16 21:59:58 spatz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/ctags/ctags-5.8.ebuild,v 1.2 2011/10/16 06:02:51 radhermit Exp $
-EAPI="2"
+EAPI="4"
inherit eutils
@@ -27,8 +27,8 @@ src_prepare() {
epatch "${FILESDIR}/${P}-f95-pointers.patch"
# enabling Ada support
- if use ada; then
- cp "${WORKDIR}/${PN}-ada-mode-4.3.11/ada.c" "${S}"
+ if use ada ; then
+ cp "${WORKDIR}/${PN}-ada-mode-4.3.11/ada.c" "${S}" || die
epatch "${FILESDIR}/${P}-ada.patch"
fi
}
@@ -38,20 +38,19 @@ src_configure() {
--with-posix-regex \
--without-readlib \
--disable-etags \
- --enable-tmpdir=/tmp \
- || die "econf failed"
+ --enable-tmpdir=/tmp
}
src_install() {
- einstall || die "einstall failed"
+ emake prefix="${D}"/usr mandir="${D}"/usr/share/man install
# namepace collision with X/Emacs-provided /usr/bin/ctags -- we
# rename ctags to exuberant-ctags (Mandrake does this also).
- mv "${D}"/usr/bin/{ctags,exuberant-ctags}
- mv "${D}"/usr/share/man/man1/{ctags,exuberant-ctags}.1
+ mv "${D}"/usr/bin/{ctags,exuberant-ctags} || die
+ mv "${D}"/usr/share/man/man1/{ctags,exuberant-ctags}.1 || die
- dodoc FAQ NEWS README || die
- dohtml EXTENDING.html ctags.html || die
+ dodoc FAQ NEWS README
+ dohtml EXTENDING.html ctags.html
}
pkg_postinst() {