summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAlexis Ballier <aballier@gentoo.org>2010-02-01 10:30:23 +0000
committerAlexis Ballier <aballier@gentoo.org>2010-02-01 10:30:23 +0000
commit586a8b6b77e7e4396335142df5cd321f767ab693 (patch)
tree9e808b05ab5fca3383b4f00723d9bd9083092e84 /dev-util
parentRemove old ruby-mmap (diff)
downloadgentoo-2-586a8b6b77e7e4396335142df5cd321f767ab693.tar.gz
gentoo-2-586a8b6b77e7e4396335142df5cd321f767ab693.tar.bz2
gentoo-2-586a8b6b77e7e4396335142df5cd321f767ab693.zip
version bump
(Portage version: 2.2_rc62/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/coccinelle/ChangeLog8
-rw-r--r--dev-util/coccinelle/coccinelle-0.2.1.ebuild60
2 files changed, 67 insertions, 1 deletions
diff --git a/dev-util/coccinelle/ChangeLog b/dev-util/coccinelle/ChangeLog
index 17fa45ab5031..7d4df8544cfc 100644
--- a/dev-util/coccinelle/ChangeLog
+++ b/dev-util/coccinelle/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/coccinelle
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.1 2010/01/24 18:07:36 aballier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/ChangeLog,v 1.2 2010/02/01 10:30:23 aballier Exp $
+
+*coccinelle-0.2.1 (01 Feb 2010)
+
+ 01 Feb 2010; Alexis Ballier <aballier@gentoo.org>
+ +coccinelle-0.2.1.ebuild:
+ version bump
*coccinelle-0.2.0 (24 Jan 2010)
diff --git a/dev-util/coccinelle/coccinelle-0.2.1.ebuild b/dev-util/coccinelle/coccinelle-0.2.1.ebuild
new file mode 100644
index 000000000000..504709f7a4bb
--- /dev/null
+++ b/dev-util/coccinelle/coccinelle-0.2.1.ebuild
@@ -0,0 +1,60 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/coccinelle/coccinelle-0.2.1.ebuild,v 1.1 2010/02/01 10:30:23 aballier Exp $
+
+EAPI="2"
+
+inherit multilib
+
+DESCRIPTION="Program matching and transformation engine"
+HOMEPAGE="http://coccinelle.lip6.fr/"
+SRC_URI="http://coccinelle.lip6.fr/distrib/${P}.tgz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="doc +ocamlopt python"
+
+RDEPEND="python? ( dev-lang/python )
+ >=dev-lang/ocaml-3.10[ocamlopt?]"
+DEPEND="${RDEPEND}
+ doc? ( virtual/latex-base
+ || ( dev-texlive/texlive-latexextra app-text/ptex ) )"
+
+src_configure() {
+ # non-autoconf
+ ./configure \
+ --prefix=/usr \
+ $(use ocamlopt || echo "--no-opt") \
+ $(use_with python) \
+ || die
+ sed -i "s:^LIBDIR=.*:LIBDIR=/usr/$(get_libdir)/ocaml/stublibs/:" Makefile.config
+ sed -i "s:^SHAREDIR=.*:SHAREDIR=/usr/libexec/${PN}/:" Makefile.config
+ sed -i "s:^MANDIR=.*:MANDIR=/usr/share/man/:" Makefile.config
+}
+
+src_compile() {
+ emake depend || die
+ emake || die
+ if use doc ; then
+ emake docs || die
+ fi
+ if use ocamlopt ; then
+ emake opt || die
+ fi
+}
+
+src_test() {
+ ./spatch standard.h -parse_c -dir tests/ || die
+ ./spatch -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ if use ocamlopt ; then
+ ./spatch.opt -iso_file standard.iso -macro_file_builtins standard.h -testall || die
+ fi
+}
+
+src_install() {
+ emake DESTDIR="${D}" install || die
+ dodoc authors.txt bugs.txt changes.txt credits.txt readme.txt
+ use doc && dodoc docs/manual/*.pdf
+ export STRIP_MASK='*/coccinelle/spatch'
+}