summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSteve Arnold <nerdboy@gentoo.org>2009-06-06 15:54:16 +0000
committerSteve Arnold <nerdboy@gentoo.org>2009-06-06 15:54:16 +0000
commit5c048cad16d78bf45f38ac683b97982900d8ca4e (patch)
tree445a54add68d40753f46aeca8f7b983fc61e7285 /dev-util
parentInitial commit. (diff)
downloadgentoo-2-5c048cad16d78bf45f38ac683b97982900d8ca4e.tar.gz
gentoo-2-5c048cad16d78bf45f38ac683b97982900d8ca4e.tar.bz2
gentoo-2-5c048cad16d78bf45f38ac683b97982900d8ca4e.zip
Added new version, updated use=doc generation (closes bug #265941).
(Portage version: 2.2_rc33/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/rapidsvn/ChangeLog12
-rw-r--r--dev-util/rapidsvn/files/rapidsvn-0.9.8-sar.patch28
-rw-r--r--dev-util/rapidsvn/rapidsvn-0.9.8.ebuild110
3 files changed, 148 insertions, 2 deletions
diff --git a/dev-util/rapidsvn/ChangeLog b/dev-util/rapidsvn/ChangeLog
index b3818f10df4f..8abe8fb09a24 100644
--- a/dev-util/rapidsvn/ChangeLog
+++ b/dev-util/rapidsvn/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/rapidsvn
-# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/ChangeLog,v 1.64 2008/09/17 20:46:01 maekke Exp $
+# Copyright 2000-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/ChangeLog,v 1.65 2009/06/06 15:54:15 nerdboy Exp $
+
+*rapidsvn-0.9.8 (06 Jun 2009)
+
+ 06 Jun 2009; Steve Arnold <nerdboy@gentoo.org>
+ +files/rapidsvn-0.9.8-sar.patch, +rapidsvn-0.9.8.ebuild:
+ Added new version, updated use=doc generation (closes bug #265941). The
+ underlying subversion neon support is dorked up (at least for me) so this
+ was tested with webdav-serf against a couple of different local repos.
17 Sep 2008; Markus Meier <maekke@gentoo.org> rapidsvn-0.9.6-r1.ebuild:
amd64/x86 stable, bug #237095
diff --git a/dev-util/rapidsvn/files/rapidsvn-0.9.8-sar.patch b/dev-util/rapidsvn/files/rapidsvn-0.9.8-sar.patch
new file mode 100644
index 000000000000..6769382f8267
--- /dev/null
+++ b/dev-util/rapidsvn/files/rapidsvn-0.9.8-sar.patch
@@ -0,0 +1,28 @@
+--- src/svncpp/client_status.cpp.orig 2009-02-14 14:08:15.000000000 -0800
++++ src/svncpp/client_status.cpp 2009-05-26 18:12:04.137129866 -0700
+@@ -65,17 +65,21 @@
+ hi != NULL;
+ hi = apr_hash_next(hi))
+ {
+- char *path;
++ typedef union {
++ char *cpath;
++ void *vpath;
++ } upath;
++ upath path;
+ void *val;
+- apr_hash_this(hi, (const void **)&path, NULL, &val);
++ apr_hash_this(hi, (const void **)&path.vpath, NULL, &val);
+
+ svn_log_changed_path_t *log_item = reinterpret_cast<svn_log_changed_path_t *>(val);
+
+ entry.changedPaths.push_back(
+- LogChangePathEntry(path,
++ LogChangePathEntry(path.cpath,
+ log_item->action,
+ log_item->copyfrom_path,
+- log_item->copyfrom_rev));
++ log_item->copyfrom_rev) );
+ }
+ }
+
diff --git a/dev-util/rapidsvn/rapidsvn-0.9.8.ebuild b/dev-util/rapidsvn/rapidsvn-0.9.8.ebuild
new file mode 100644
index 000000000000..0cb8b4c51b09
--- /dev/null
+++ b/dev-util/rapidsvn/rapidsvn-0.9.8.ebuild
@@ -0,0 +1,110 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/rapidsvn/rapidsvn-0.9.8.ebuild,v 1.1 2009/06/06 15:54:15 nerdboy Exp $
+
+WANT_AUTOCONF="2.5"
+inherit versionator eutils libtool autotools wxwidgets flag-o-matic fdo-mime
+
+DESCRIPTION="Cross-platform GUI front-end for the Subversion revision system."
+HOMEPAGE="http://rapidsvn.tigris.org/"
+SRC_URI="http://www.rapidsvn.org/download/release/${PV}/${P}.tar.gz"
+LICENSE="GPL-2 LGPL-2.1 FDL-1.2"
+SLOT="0"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="doc"
+
+COMMON_DEP=">=dev-util/subversion-1.5.0
+ >=x11-libs/wxGTK-2.6
+ >=dev-libs/apr-1.2.10
+ >=dev-libs/apr-util-1.2.10"
+
+DEPEND="${COMMON_DEP}
+ doc? ( dev-libs/libxslt
+ app-text/docbook-sgml-utils
+ app-doc/doxygen
+ app-text/docbook-xsl-stylesheets )"
+
+RDEPEND="${COMMON_DEP}"
+
+RESTRICT=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Apparently we still need the --as-needed link patch...
+ #export EPATCH_OPTS="-F3 -l"
+ epatch "${FILESDIR}/${PN}-svncpp_link.patch"
+ epatch "${FILESDIR}/${P}-sar.patch"
+ eautoreconf
+}
+
+src_compile() {
+ einfo "Checking for subversion compiled with WebDAV support..."
+ if ! built_with_use --missing true -o dev-util/subversion webdav-serf || \
+ built_with_use --missing false dev-util/subversion nowebdav; then
+ ewarn "SVN (dev-util/subversion) must be compiled with WebDAV support."
+ ewarn "Please re-emerge subversion with the webdav-serf USE flag and"
+ ewarn "without the nowebdav USE flag."
+ die "SVN merged without WebDAV support"
+ else
+ einfo "Found WebDAV support; continuing..."
+ fi
+
+ # if you compiled subversion without (the) apache2 (flag) and with the
+ # berkdb flag, you will get an error that it can't find the lib db4
+ # Note: this should be fixed in rapidsvn 0.9.3 and later
+ local myconf
+ local apr_suffix=""
+
+ if has_version ">dev-libs/apr-util-1"; then
+ apr_suffix="-1"
+ fi
+
+ if use doc; then
+ myconf="--with-manpage=yes"
+ else
+ myconf="--without-xsltproc --with-manpage=no \
+ --without-doxygen --without-dot"
+ fi
+
+ local INST_WX=$(best_version x11-libs/wxGTK)
+ export WX_GTK_VER=$(get_version_component_range 1-2 \
+ ${INST_WX/x11-libs\/wxGTK})
+
+ need-wxwidgets ansi
+ myconf="${myconf} --with-wx-config=${WX_CONFIG}"
+
+ append-flags $( /usr/bin/apr${apr_suffix}-config --cppflags )
+
+ econf --with-svn-lib=/usr/$(get_libdir) \
+ --with-svn-include=/usr/include \
+ --with-apr-config="/usr/bin/apr${apr_suffix}-config" \
+ --with-apu-config="/usr/bin/apu${apr_suffix}-config" \
+ ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ einstall || die "einstall failed"
+
+ doicon src/res/rapidsvn.ico
+ make_desktop_entry rapidsvn "RapidSVN ${PV}" \
+ "/usr/share/pixmaps/rapidsvn.ico" \
+ "RevisionControl;Development"
+
+ dodoc HACKING.txt TRANSLATIONS
+
+ if use doc ; then
+ dodoc AUTHORS CHANGES NEWS README
+ dohtml "${S}"/doc/svncpp/html/*
+ fi
+}
+
+pkg_postinst() {
+ fdo-mime_desktop_database_update
+}
+
+pkg_postrm() {
+ fdo-mime_desktop_database_update
+}