summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMark Guertin <gerk@gentoo.org>2003-03-17 09:58:58 +0000
committerMark Guertin <gerk@gentoo.org>2003-03-17 09:58:58 +0000
commit6f75db9e3d6df4af541b3f9c593f562c412a7e5c (patch)
treeab9d2b3cde5262e54dbc9228161c0a788710bd3d /dev-util
parenttypo in ChangeLog (diff)
downloadgentoo-2-6f75db9e3d6df4af541b3f9c593f562c412a7e5c.tar.gz
gentoo-2-6f75db9e3d6df4af541b3f9c593f562c412a7e5c.tar.bz2
gentoo-2-6f75db9e3d6df4af541b3f9c593f562c412a7e5c.zip
rev bump for ppc support
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eclipse-SDK/ChangeLog6
-rw-r--r--dev-util/eclipse-SDK/eclipse-SDK-20030307_rc2.ebuild74
-rw-r--r--dev-util/eclipse-SDK/files/digest-eclipse-SDK-20030307_rc21
3 files changed, 80 insertions, 1 deletions
diff --git a/dev-util/eclipse-SDK/ChangeLog b/dev-util/eclipse-SDK/ChangeLog
index 792adb654222..d0c87366881b 100644
--- a/dev-util/eclipse-SDK/ChangeLog
+++ b/dev-util/eclipse-SDK/ChangeLog
@@ -1,7 +1,11 @@
# ChangeLog for dev-util/eclipse-SDK
# Copyright 2002-2003 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-SDK/ChangeLog,v 1.7 2003/02/12 06:40:53 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-SDK/ChangeLog,v 1.8 2003/03/17 09:58:58 gerk Exp $
+*eclipse-SDK-20030307_rc2 (17 Mar 2003)
+
+ 17 Mar 2003; Mark Guertin <gerk@gentoo.org> eclipse-SDK-20030307_rc2.ebuild:
+ Revision bump and initial PPC support
*eclipse-SDK-20030207 (07 Feb 2003)
diff --git a/dev-util/eclipse-SDK/eclipse-SDK-20030307_rc2.ebuild b/dev-util/eclipse-SDK/eclipse-SDK-20030307_rc2.ebuild
new file mode 100644
index 000000000000..cbe82af24503
--- /dev/null
+++ b/dev-util/eclipse-SDK/eclipse-SDK-20030307_rc2.ebuild
@@ -0,0 +1,74 @@
+# Copyright 1999-2003 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eclipse-SDK/eclipse-SDK-20030307_rc2.ebuild,v 1.1 2003/03/17 09:58:58 gerk Exp $
+
+DESCRIPTION="Eclipse Tools Platform"
+HOMEPAGE="http://www.eclipse.org/"
+SRC_URI="http://download2.eclipse.org/downloads/drops/S-RC2-200303071024/eclipse-SDK-RC2-linux-gtk.zip"
+IUSE=""
+
+SLOT="0"
+LICENSE="CPL-1.0"
+KEYWORDS="~x86 ~ppc ~sparc"
+
+DEPEND=">=virtual/jdk-1.3
+ =x11-libs/gtk+-2*
+ ppc? ( app-shells/tcsh )"
+
+RDEPEND=">=virtual/jdk-1.3
+ =x11-libs/gtk+-2*"
+
+S=${WORKDIR}/eclipse
+
+src_compile() {
+
+ if [ "`use ppc`" ]
+ then
+ # build the SWT library
+ library_dir=${S}/plugins/org.eclipse.platform.linux.gtk.source_2.1.0/src/org.eclipse.swt.gtk_2.1.0/ws/gtk/library
+ mkdir ${library_dir}
+ cd ${library_dir}
+ unzip -q ../swtsrc.zip
+ unzip -q ../swt-pisrc.zip
+ sed -e "s:/bluebird/teamswt/swt-builddir/ive:\$(JAVA_HOME):" \
+ -e "s:JAVA_JNI=\$(IVE_HOME)/bin/include:JAVA_JNI=\$(IVE_HOME)/include:" \
+ -e "s:\`pkg-config --libs gthread-2.0\`:-lgthread-2.0 -lglib-2.0:" \
+ make_gtk.mak > make_gtk.mak_new
+ cp make_gtk.mak_new make_gtk.mak
+
+ sh build.sh || die
+
+ # move the SWT library to the correct location and clean up
+ mkdir ${S}/plugins/org.eclipse.swt.gtk_2.1.0/os/linux/ppc
+ mv *.so ${S}/plugins/org.eclipse.swt.gtk_2.1.0/os/linux/ppc
+ rm -rf ${S}/plugins/org.eclipse.swt.gtk_2.1.0/os/linux/x86
+ cd ${S}
+ rm -rf ${library_dir}
+
+ # build the executable
+ bin_dir=${S}/plugins/org.eclipse.platform.source_2.1.0/src/org.eclipse.platform_2.1.0/bin
+ mkdir ${bin_dir}
+ cd ${bin_dir}
+ unzip -q ../launchersrc.zip
+ cd library/gtk
+ tcsh build.csh -arch ppc || die
+
+ # move the executable to the correct location and clean up
+ cp eclipse ${S}
+ cd ${S}
+ rm -rf ${bin_dir}
+ fi
+}
+
+src_install() {
+ dodir /opt/eclipse
+
+ cp -dpR features install.ini eclipse \
+ icon.xpm plugins startup.jar \
+ ${D}/opt/eclipse/
+
+ dohtml cpl-v10.html notice.html readme/*
+
+ dodir /etc/env.d
+ echo -e "LDPATH=/opt/eclipse\nPATH=/opt/eclipse\nROOTPATH=/opt/eclipse" > ${D}/etc/env.d/20eclipse
+}
diff --git a/dev-util/eclipse-SDK/files/digest-eclipse-SDK-20030307_rc2 b/dev-util/eclipse-SDK/files/digest-eclipse-SDK-20030307_rc2
new file mode 100644
index 000000000000..5391e62918c3
--- /dev/null
+++ b/dev-util/eclipse-SDK/files/digest-eclipse-SDK-20030307_rc2
@@ -0,0 +1 @@
+MD5 bb54069b0b0322f925d87d990f7b4a01 eclipse-SDK-RC2-linux-gtk.zip 68846419