summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastien Fabbro <bicatali@gentoo.org>2009-01-15 12:03:00 +0000
committerSebastien Fabbro <bicatali@gentoo.org>2009-01-15 12:03:00 +0000
commit85823257ed7f081f81842348b75bcc3b1a369b38 (patch)
tree758b4bd05fe06140938a76be9dbc182512712e7f /dev-util
parentRevision bump, with patch to fix monitor_desktops feature. Closes bug #253498. (diff)
downloadgentoo-2-85823257ed7f081f81842348b75bcc3b1a369b38.tar.gz
gentoo-2-85823257ed7f081f81842348b75bcc3b1a369b38.tar.bz2
gentoo-2-85823257ed7f081f81842348b75bcc3b1a369b38.zip
Version bump and updated description
(Portage version: 2.2_rc20/cvs/Linux 2.6.25-gentoo-r7 x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/scons/ChangeLog11
-rw-r--r--dev-util/scons/files/scons-1.2.0-links.patch24
-rw-r--r--dev-util/scons/files/scons-1.2.0-popen.patch58
-rw-r--r--dev-util/scons/metadata.xml17
-rw-r--r--dev-util/scons/scons-1.2.0.ebuild45
5 files changed, 148 insertions, 7 deletions
diff --git a/dev-util/scons/ChangeLog b/dev-util/scons/ChangeLog
index 699d7488ffdc..8ceff5ce23f5 100644
--- a/dev-util/scons/ChangeLog
+++ b/dev-util/scons/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-util/scons
-# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.65 2008/12/02 23:18:23 ranger Exp $
+# Copyright 1999-2009 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.66 2009/01/15 12:02:59 bicatali Exp $
+
+*scons-1.2.0 (15 Jan 2009)
+
+ 15 Jan 2009; Sébastien Fabbro <bicatali@gentoo.org>
+ +files/scons-1.2.0-links.patch, +files/scons-1.2.0-popen.patch,
+ metadata.xml, +scons-1.2.0.ebuild:
+ Version bump and updated description
02 Dec 2008; Brent Baude <ranger@gentoo.org> scons-1.0.0.ebuild:
stable ppc64, bug 242766
diff --git a/dev-util/scons/files/scons-1.2.0-links.patch b/dev-util/scons/files/scons-1.2.0-links.patch
new file mode 100644
index 000000000000..134c24c48448
--- /dev/null
+++ b/dev-util/scons/files/scons-1.2.0-links.patch
@@ -0,0 +1,24 @@
+--- engine/SCons/Script/Main.py.orig 2009-01-15 11:07:33.000000000 +0000
++++ engine/SCons/Script/Main.py 2009-01-15 11:09:12.000000000 +0000
+@@ -328,6 +328,10 @@
+ # then delete dir itself
+ if remove: os.rmdir(path)
+ display("Removed directory " + pathstr)
++ else:
++ if os.path.islink(path):
++ if remove: os.unlink(path)
++ display("Removed " + pathstr)
+ except (IOError, OSError), e:
+ print "scons: Could not remove '%s':" % pathstr, e.strerror
+
+--- engine/SCons/Tool/javac.py.orig 2009-01-15 11:05:46.000000000 +0000
++++ engine/SCons/Tool/javac.py 2009-01-15 11:06:41.000000000 +0000
+@@ -94,6 +94,8 @@
+ version = env.get('JAVAVERSION', '1.4')
+ full_tlist = []
+ for f in slist:
++ if not os.path.exists(f.rfile().get_abspath()):
++ continue
+ tlist = []
+ source_file_based = True
+ pkg_dir = None
diff --git a/dev-util/scons/files/scons-1.2.0-popen.patch b/dev-util/scons/files/scons-1.2.0-popen.patch
new file mode 100644
index 000000000000..23063cffd0c5
--- /dev/null
+++ b/dev-util/scons/files/scons-1.2.0-popen.patch
@@ -0,0 +1,58 @@
+--- engine/SCons/compat/__init__.py (revision 2695)
++++ engine/SCons/compat/__init__.py (working copy)
+@@ -167,11 +167,17 @@
+ del shlex
+ import_as('_scons_shlex', 'shlex')
+
+-try:
+- import subprocess
+-except ImportError:
+- # Pre-2.4 Python has no subprocess module.
+- import_as('_scons_subprocess', 'subprocess')
++#try:
++# import subprocess
++#except ImportError:
++# # Pre-2.4 Python has no subprocess module.
++# import_as('_scons_subprocess', 'subprocess')
++
++# Import subprocess unconditionally to avoid possible race conditions in
++# the official subprocess API. If there are API versions without known
++# problems, we can version-check and use the original subprocess module
++# in these cases.
++import_as('_scons_subprocess', 'subprocess')
+
+ import sys
+ try:
+
+
+--- engine/SCons/compat/_scons_subprocess.py (revision 2695)
++++ engine/SCons/compat/_scons_subprocess.py (working copy)
+@@ -581,13 +581,19 @@
+ class object:
+ pass
+
++import thread
++lock = thread.allocate_lock()
++
+ class Popen(object):
+ def __init__(self, args, bufsize=0, executable=None,
+ stdin=None, stdout=None, stderr=None,
+ preexec_fn=None, close_fds=False, shell=False,
+ cwd=None, env=None, universal_newlines=False,
+ startupinfo=None, creationflags=0):
+- """Create new Popen instance."""
++ """Create new Popen instance.
++ Popen is not thread-safe and is therefore protected with a lock.
++ """
++ lock.acquire()
+ _cleanup()
+
+ self._child_created = False
+@@ -655,6 +661,7 @@
+ self.stderr = os.fdopen(errread, 'rU', bufsize)
+ else:
+ self.stderr = os.fdopen(errread, 'rb', bufsize)
++ lock.release()
+
+
+ def _translate_newlines(self, data):
diff --git a/dev-util/scons/metadata.xml b/dev-util/scons/metadata.xml
index 17f2a23187bf..6af6b45aacaf 100644
--- a/dev-util/scons/metadata.xml
+++ b/dev-util/scons/metadata.xml
@@ -1,9 +1,16 @@
<?xml version="1.0" encoding="UTF-8"?>
<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
<pkgmetadata>
- <herd>python</herd>
- <maintainer>
- <email>python@gentoo.org</email>
- <name>Python Project Team</name>
- </maintainer>
+ <herd>python</herd>
+ <maintainer>
+ <email>python@gentoo.org</email>
+ <name>Python Project Team</name>
+ </maintainer>
+ <longdescription lang="en">
+ SCons is a make replacement providing a range of enhanced
+ features such as automated dependency generation and built in
+ compilation cache support. SCons rule sets are Python scripts so
+ as well as the features it provides itself SCons allows you to use
+ the full power of Python to control compilation.
+ </longdescription>
</pkgmetadata>
diff --git a/dev-util/scons/scons-1.2.0.ebuild b/dev-util/scons/scons-1.2.0.ebuild
new file mode 100644
index 000000000000..c91da048a7de
--- /dev/null
+++ b/dev-util/scons/scons-1.2.0.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2009 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-1.2.0.ebuild,v 1.1 2009/01/15 12:02:59 bicatali Exp $
+
+EAPI=2
+inherit eutils distutils
+
+DESCRIPTION="Extensible Python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz
+ doc? ( http://www.scons.org/doc/${PV}/PDF/${PN}-user.pdf -> ${P}-user.pdf
+ http://www.scons.org/doc/${PV}/HTML/${PN}-user.html -> ${P}-user.html )"
+
+HOMEPAGE="http://www.scons.org/"
+
+SLOT="0"
+LICENSE="MIT"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
+IUSE="doc"
+
+DOCS="RELEASE.txt CHANGES.txt"
+
+src_prepare() {
+ # from debian, fix links and removes
+ epatch "${FILESDIR}"/${P}-links.patch
+ epatch "${FILESDIR}"/${P}-popen.patch
+}
+
+src_install () {
+ distutils_src_install
+ # move man pages from /usr/man to /usr/share/man
+ dodir /usr/share
+ mv "${D}"/usr/man "${D}"/usr/share
+ if use doc; then
+ insinto /usr/share/doc/${PF}
+ doins "${DISTDIR}"/${P}-user.{pdf,html}
+ fi
+}
+
+pkg_postinst() {
+ python_mod_optimize /usr/$(get_libdir)/${P}
+}
+
+pkg_postrm() {
+ python_mod_cleanup /usr/$(get_libdir)/${P}
+}