summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarkus Ullmann <jokey@gentoo.org>2008-03-11 14:44:47 +0000
committerMarkus Ullmann <jokey@gentoo.org>2008-03-11 14:44:47 +0000
commit89f9de3630f62136280a1b89e35fa80f6a3b6f27 (patch)
tree976046aa206180eaf5023d9d65a3b0489c926a35 /dev-util
parentalpha/ia64/sparc/x86 stable (diff)
downloadgentoo-2-89f9de3630f62136280a1b89e35fa80f6a3b6f27.tar.gz
gentoo-2-89f9de3630f62136280a1b89e35fa80f6a3b6f27.tar.bz2
gentoo-2-89f9de3630f62136280a1b89e35fa80f6a3b6f27.zip
Version bump
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/eric/ChangeLog8
-rw-r--r--dev-util/eric/eric-4.1.1.ebuild80
-rw-r--r--dev-util/eric/files/4.1.1-paths.patch42
3 files changed, 129 insertions, 1 deletions
diff --git a/dev-util/eric/ChangeLog b/dev-util/eric/ChangeLog
index 3265dabaf065..fc8471fdcda7 100644
--- a/dev-util/eric/ChangeLog
+++ b/dev-util/eric/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/eric
# Copyright 2000-2008 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.56 2008/02/21 14:30:04 armin76 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/ChangeLog,v 1.57 2008/03/11 14:44:47 jokey Exp $
+
+*eric-4.1.1 (11 Mar 2008)
+
+ 11 Mar 2008; Markus Ullmann <jokey@gentoo.org> +files/4.1.1-paths.patch,
+ +eric-4.1.1.ebuild:
+ Version bump
21 Feb 2008; Raúl Porcel <armin76@gentoo.org> eric-4.0.4.ebuild:
sparc stable
diff --git a/dev-util/eric/eric-4.1.1.ebuild b/dev-util/eric/eric-4.1.1.ebuild
new file mode 100644
index 000000000000..be2b9b5e99b0
--- /dev/null
+++ b/dev-util/eric/eric-4.1.1.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/eric/eric-4.1.1.ebuild,v 1.1 2008/03/11 14:44:47 jokey Exp $
+
+NEED_PYTHON=2.4
+
+inherit python eutils
+
+MY_PN=${PN}4
+MY_P=${MY_PN}-${PV}
+DESCRIPTION="eric4 is a full featured Python IDE that is written in PyQt4 using the QScintilla editor widget"
+HOMEPAGE="http://www.die-offenbachs.de/detlev/eric4.html"
+SRC_URI="mirror://sourceforge/eric-ide/${MY_P}.tar.gz
+ linguas_cs? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-cs-${PV}.tar.gz )
+ linguas_de? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-de-${PV}.tar.gz )
+ linguas_fr? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-fr-${PV}.tar.gz )
+ linguas_ru? ( mirror://sourceforge/eric-ide/${MY_PN}-i18n-ru-${PV}.tar.gz )"
+
+SLOT="4"
+LICENSE="GPL-2"
+KEYWORDS="~amd64 ~ppc ~ppc64 ~sparc ~x86"
+IUSE="linguas_cs linguas_de linguas_fr linguas_ru"
+
+DEPEND=">=dev-python/PyQt4-4.1
+ >=dev-python/qscintilla-python-2.1
+ >=x11-libs/qt-4.2.0"
+RDEPEND="${DEPEND}"
+
+S=${WORKDIR}/${MY_P}
+
+LANGS="cs de fr ru"
+
+python_version
+
+pkg_setup() {
+ if ! built_with_use 'dev-python/qscintilla-python' 'qt4'; then
+ eerror "Please build qscintilla-python with qt4 useflag."
+ die "qscintilla-python built without qt4."
+ fi
+}
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}"/${PV}-paths.patch
+}
+
+src_install() {
+ # Change qt dir to be located in ${D}
+ dodir /usr/share/qt4/
+ ${python} install.py \
+ -z \
+ -b "/usr/bin" \
+ -i "${D}" \
+ -d "/usr/$(get_libdir)/python${PYVER}/site-packages" \
+ -c || die "python install.py failed"
+
+ make_desktop_entry "eric4 --nosplash" \
+ eric4 \
+ "/usr/$(get_libdir)/python${PYVER}/site-packages/eric4/icons/default/eric.png" \
+ "Development;IDE;Qt"
+}
+
+pkg_postinst() {
+ python_mod_optimize "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+ elog "If you want to use eric4 with mod_python, have a look at"
+ elog "\"${ROOT}usr/$(get_libdir)/python${PYVER}/site-packages/eric4/patch_modpython.py\"."
+ elog
+ elog "The following packages will give eric extended functionality."
+ elog
+ elog "dev-python/pylint"
+ elog "dev-python/pysvn (in sunrise overlay atm)"
+ elog
+ elog "This version has a new plugin interface with plugin-autofetch from"
+ elog "the App itself. You may want to check those as well"
+}
+
+pkg_posrm() {
+ python_mod_cleanup "${ROOT}"usr/$(get_libdir)/python${PYVER}/site-packages/eric4{,plugins}
+}
diff --git a/dev-util/eric/files/4.1.1-paths.patch b/dev-util/eric/files/4.1.1-paths.patch
new file mode 100644
index 000000000000..7a647b6b7a0b
--- /dev/null
+++ b/dev-util/eric/files/4.1.1-paths.patch
@@ -0,0 +1,42 @@
+--- ./install.py.orig 2008-03-01 12:46:17.000000000 +0100
++++ ./install.py 2008-03-11 15:34:36.000000000 +0100
+@@ -184,12 +184,10 @@
+ global cfg, distDir
+
+ pdir = os.path.join(cfg['mdir'], "eric4plugins")
+- if distDir:
+- pdir = distDir + pdir
+ fname = os.path.join(pdir, "__init__.py")
+ if not os.path.exists(fname):
+ if not os.path.exists(pdir):
+- os.mkdir(pdir, 0755)
++ os.makedirs(pdir, 0755)
+ f = open(fname, "wb")
+ f.write(\
+ '''# -*- coding: utf-8 -*-
+@@ -208,11 +206,14 @@
+
+ @return name of the directory containing the API files (string)
+ """
+- global cfg
++ global cfg, distDir
+
+ try:
+ from PyQt4 import pyqtconfig
+- qtDataDir = pyqtconfig._pkg_config["qt_data_dir"]
++ if distDir:
++ qtDataDir = distDir + pyqtconfig._pkg_config["qt_data_dir"]
++ else:
++ qtDataDir = pyqtconfig._pkg_config["qt_data_dir"]
+ except (AttributeError, ImportError):
+ print
+ print "Please enter the name of the Qt data directory."
+@@ -474,7 +475,7 @@
+ cfg['ericTemplatesDir'],
+ cfg['ericCodeTemplatesDir'], cfg['ericOthersDir'],
+ cfg['bindir'], cfg['mdir'],
+- getAPIsPath(), apis)
++ getAPIsPath()[len(distDir):], apis)
+ copyToFile(fn, config)
+
+ def doDependancyChecks():