summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarien Zwart <marienz@gentoo.org>2006-09-24 20:59:17 +0000
committerMarien Zwart <marienz@gentoo.org>2006-09-24 20:59:17 +0000
commit90e7ae13ddaa55552587841a8303af843f2bcf0a (patch)
treeb4085c29c734eb4389cb3bc9732d6f5a6bedfbf9 /dev-util
parentFix DEPEND/RDEPEND. (diff)
downloadgentoo-2-90e7ae13ddaa55552587841a8303af843f2bcf0a.tar.gz
gentoo-2-90e7ae13ddaa55552587841a8303af843f2bcf0a.tar.bz2
gentoo-2-90e7ae13ddaa55552587841a8303af843f2bcf0a.zip
Clean up old versions. Fix dependency bug spotted by Flameeyes. Bump to 0.10-r1 with a patch to mostly work with python 2.5.
(Portage version: 2.1.2_pre1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/bzr/ChangeLog11
-rw-r--r--dev-util/bzr/bzr-0.10-r1.ebuild78
-rw-r--r--dev-util/bzr/bzr-0.10.ebuild10
-rw-r--r--dev-util/bzr/bzr-0.9.ebuild10
-rw-r--r--dev-util/bzr/files/bzr-0.10-python-2.5-compat.patch51
-rw-r--r--dev-util/bzr/files/digest-bzr-0.10-r13
6 files changed, 154 insertions, 9 deletions
diff --git a/dev-util/bzr/ChangeLog b/dev-util/bzr/ChangeLog
index 477962136d5d..f757d6a096f2 100644
--- a/dev-util/bzr/ChangeLog
+++ b/dev-util/bzr/ChangeLog
@@ -1,6 +1,15 @@
# ChangeLog for dev-util/bzr
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.19 2006/09/04 15:47:01 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/ChangeLog,v 1.20 2006/09/24 20:59:17 marienz Exp $
+
+*bzr-0.10-r1 (24 Sep 2006)
+
+ 24 Sep 2006; Marien Zwart <marienz@gentoo.org>
+ +files/bzr-0.10-python-2.5-compat.patch, -bzr-0.6.2.ebuild,
+ -bzr-0.7.ebuild, -bzr-0.8.ebuild, -bzr-0.8.2.ebuild, -bzr-0.8.2-r1.ebuild,
+ bzr-0.9.ebuild, bzr-0.10.ebuild, +bzr-0.10-r1.ebuild:
+ Clean up old versions. Fix dependency bug spotted by Flameeyes. Bump to
+ 0.10-r1 with a patch to mostly work with python 2.5.
*bzr-0.10 (04 Sep 2006)
diff --git a/dev-util/bzr/bzr-0.10-r1.ebuild b/dev-util/bzr/bzr-0.10-r1.ebuild
new file mode 100644
index 000000000000..6e4ebe43b960
--- /dev/null
+++ b/dev-util/bzr/bzr-0.10-r1.ebuild
@@ -0,0 +1,78 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-0.10-r1.ebuild,v 1.1 2006/09/24 20:59:17 marienz Exp $
+
+inherit distutils bash-completion elisp-common eutils
+
+DESCRIPTION="next generation distributed version control"
+HOMEPAGE="http://bazaar-vcs.org/"
+SRC_URI="http://bazaar-vcs.org/releases/src/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
+IUSE="emacs test"
+
+python_rdep="dev-python/celementtree >=dev-python/paramiko-1.5"
+DEPEND=">=dev-lang/python-2.4
+ emacs? ( virtual/emacs )
+ test? ( $python_rdep )"
+RDEPEND=">=dev-lang/python-2.4
+ $python_rdep"
+
+PYTHON_MODNAME="bzrlib"
+
+DOCS="HACKING NEWS NEWS.developers"
+
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+
+ # Install the manpage in /usr/share/man instead of /usr/man
+ epatch "${FILESDIR}/${P}-fix-manpage-location.patch"
+
+ # Mostly work with python 2.5 (some tar export related things are
+ # still broken, but will be fixed in bzr 0.11).
+ epatch "${FILESDIR}/${P}-python-2.5-compat.patch"
+}
+
+src_compile() {
+ distutils_src_compile
+ if use emacs; then
+ elisp-compile contrib/emacs/bzr-mode.el || die "Emacs modules failed!"
+ fi
+}
+
+src_install() {
+ distutils_src_install
+ if use emacs; then
+ insinto "${SITELISP}"
+ doins contrib/emacs/bzr-mode.el*
+ elisp-site-file-install "${FILESDIR}/70bzr-gentoo.el"
+ fi
+ insinto /usr/share/zsh/site-functions
+ doins contrib/zsh/_bzr
+ dobashcompletion contrib/bash/bzr
+}
+
+pkg_postinst() {
+ distutils_pkg_postinst
+ use emacs && elisp-site-regen
+ bash-completion_pkg_postinst
+
+ einfo "If you just upgraded from a version of bzr older than 0.9"
+ einfo "you should rename your ~/.bazaar/branches.conf to locations.conf"
+ einfo "(see /usr/share/doc/${PF}/NEWS.gz)"
+}
+
+pkg_postrm() {
+ distutils_pkg_postrm
+ # regenerate site-gentoo if we are merged USE=emacs and unmerged
+ # USE=-emacs
+ has_version virtual/emacs && elisp-site-regen
+}
+
+src_test() {
+ "${python}" bzr --no-plugins selftest || die "bzr selftest failed"
+}
diff --git a/dev-util/bzr/bzr-0.10.ebuild b/dev-util/bzr/bzr-0.10.ebuild
index 54e5275cb2a9..6b8c96ccd076 100644
--- a/dev-util/bzr/bzr-0.10.ebuild
+++ b/dev-util/bzr/bzr-0.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-0.10.ebuild,v 1.1 2006/09/04 15:47:01 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-0.10.ebuild,v 1.2 2006/09/24 20:59:17 marienz Exp $
inherit distutils bash-completion elisp-common eutils
@@ -11,12 +11,14 @@ SRC_URI="http://bazaar-vcs.org/releases/src/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
-IUSE="emacs"
+IUSE="emacs test"
+python_rdep="dev-python/celementtree >=dev-python/paramiko-1.5"
DEPEND=">=dev-lang/python-2.4
- dev-python/celementtree
emacs? ( virtual/emacs )
- >=dev-python/paramiko-1.5"
+ test? ( $python_rdep )"
+RDEPEND=">=dev-lang/python-2.4
+ $python_rdep"
PYTHON_MODNAME="bzrlib"
diff --git a/dev-util/bzr/bzr-0.9.ebuild b/dev-util/bzr/bzr-0.9.ebuild
index 4fa8a67a3b9b..c45ca841dc9f 100644
--- a/dev-util/bzr/bzr-0.9.ebuild
+++ b/dev-util/bzr/bzr-0.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-0.9.ebuild,v 1.1 2006/08/24 18:46:31 marienz Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/bzr/bzr-0.9.ebuild,v 1.2 2006/09/24 20:59:17 marienz Exp $
inherit distutils bash-completion elisp-common eutils
@@ -11,12 +11,14 @@ SRC_URI="http://bazaar-vcs.org/pkg/${P}.tar.gz"
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="~amd64 ~ia64 ~ppc ~x86 ~x86-fbsd"
-IUSE="emacs"
+IUSE="emacs test"
+python_rdep="dev-python/celementtree >=dev-python/paramiko-1.5"
DEPEND=">=dev-lang/python-2.4
- dev-python/celementtree
emacs? ( virtual/emacs )
- >=dev-python/paramiko-1.5"
+ test? ( $python_rdep )"
+RDEPEND=">=dev-lang/python-2.4
+ $python_rdep"
PYTHON_MODNAME="bzrlib"
diff --git a/dev-util/bzr/files/bzr-0.10-python-2.5-compat.patch b/dev-util/bzr/files/bzr-0.10-python-2.5-compat.patch
new file mode 100644
index 000000000000..fdb2fc0c8b16
--- /dev/null
+++ b/dev-util/bzr/files/bzr-0.10-python-2.5-compat.patch
@@ -0,0 +1,51 @@
+=== modified file 'bzrlib/errors.py'
+--- bzrlib/errors.py 2006-08-22 21:31:23 +0000
++++ bzrlib/errors.py 2006-09-21 21:01:04 +0000
+@@ -44,7 +44,7 @@
+ >>> try:
+ ... raise NotBranchError(path='/foo/bar')
+ ... except:
+-... print sys.exc_type
++... print '%s.%s' % (sys.exc_type.__module__, sys.exc_type.__name__)
+ ... print sys.exc_value
+ ... path = getattr(sys.exc_value, 'path', None)
+ ... if path is not None:
+@@ -264,8 +264,7 @@
+
+ def __init__(self, msg, base, args):
+ PathError.__init__(self, base, msg)
+- self.args = [base]
+- self.args.extend(args)
++ self.args = [base] + list(args)
+
+
+ class UnsupportedProtocol(PathError):
+
+=== modified file 'bzrlib/plugins/launchpad/test_register.py'
+--- bzrlib/plugins/launchpad/test_register.py 2006-05-16 02:31:06 +0000
++++ bzrlib/plugins/launchpad/test_register.py 2006-09-21 21:44:39 +0000
+@@ -71,6 +71,9 @@
+
+ class InstrumentedXMLRPCTransport(xmlrpclib.Transport):
+
++ # Python 2.5's xmlrpclib looks for this.
++ _use_datetime = False
++
+ def __init__(self, testcase):
+ self.testcase = testcase
+
+
+=== modified file 'bzrlib/trace.py'
+--- bzrlib/trace.py 2006-08-22 21:39:33 +0000
++++ bzrlib/trace.py 2006-09-21 20:53:45 +0000
+@@ -288,7 +288,8 @@
+ """Report an exception that probably indicates a bug in bzr"""
+ import traceback
+ exc_type, exc_object, exc_tb = exc_info
+- print >>err_file, "bzr: ERROR: %s: %s" % (exc_type, exc_object)
++ print >>err_file, "bzr: ERROR: %s.%s: %s" % (
++ exc_type.__module__, exc_type.__name__, exc_object)
+ print >>err_file
+ traceback.print_exception(exc_type, exc_object, exc_tb, file=err_file)
+ print >>err_file
+
diff --git a/dev-util/bzr/files/digest-bzr-0.10-r1 b/dev-util/bzr/files/digest-bzr-0.10-r1
new file mode 100644
index 000000000000..7872ef24a2d2
--- /dev/null
+++ b/dev-util/bzr/files/digest-bzr-0.10-r1
@@ -0,0 +1,3 @@
+MD5 8a21693efe9b06bed04fa4e8a74b7e83 bzr-0.10.tar.gz 950911
+RMD160 046dd9479e516b6e9b526df5f9baa2a7ec185a5b bzr-0.10.tar.gz 950911
+SHA256 4a9b5b2d0b2c33c91dabeb0831b3da660189eb38ad9c28c929ea64b79fecc20f bzr-0.10.tar.gz 950911