summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorTom William Payne <twp@gentoo.org>2006-12-07 09:17:37 +0000
committerTom William Payne <twp@gentoo.org>2006-12-07 09:17:37 +0000
commit922f1df60cac31830183a61fb7dfcd12e230d62f (patch)
tree031a5b20b3b1f9e44e22452f8c99952fb7029fc9 /dev-util
parentLatest version of mediawiki with postgres support (diff)
downloadgentoo-2-922f1df60cac31830183a61fb7dfcd12e230d62f.tar.gz
gentoo-2-922f1df60cac31830183a61fb7dfcd12e230d62f.tar.bz2
gentoo-2-922f1df60cac31830183a61fb7dfcd12e230d62f.zip
Version bump. Bug # 157405.
(Portage version: 2.1.2_rc2-r5)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/scons/ChangeLog7
-rw-r--r--dev-util/scons/files/digest-scons-0.96.933
-rw-r--r--dev-util/scons/scons-0.96.93.ebuild42
3 files changed, 51 insertions, 1 deletions
diff --git a/dev-util/scons/ChangeLog b/dev-util/scons/ChangeLog
index c66054fa2f32..5c08ce5f9676 100644
--- a/dev-util/scons/ChangeLog
+++ b/dev-util/scons/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/scons
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.38 2006/11/09 21:54:48 twp Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/ChangeLog,v 1.39 2006/12/07 09:17:37 twp Exp $
+
+*scons-0.96.93 (07 Dec 2006)
+
+ 07 Dec 2006; <twp@gentoo.org> +scons-0.96.93.ebuild:
+ Version bump. Bug # 157405.
*scons-0.96.92-r3 (09 Nov 2006)
diff --git a/dev-util/scons/files/digest-scons-0.96.93 b/dev-util/scons/files/digest-scons-0.96.93
new file mode 100644
index 000000000000..a061311977fe
--- /dev/null
+++ b/dev-util/scons/files/digest-scons-0.96.93
@@ -0,0 +1,3 @@
+MD5 2f8c5fc81102ccbad6e482ec963b9505 scons-0.96.93.tar.gz 390627
+RMD160 691890defaf3a4318c5e22291b9b01565488bb57 scons-0.96.93.tar.gz 390627
+SHA256 2a7847f7c5946ab82d89c41aa7f5822c89dc349c607321d26740c9ce29c6fc27 scons-0.96.93.tar.gz 390627
diff --git a/dev-util/scons/scons-0.96.93.ebuild b/dev-util/scons/scons-0.96.93.ebuild
new file mode 100644
index 000000000000..37a92652a584
--- /dev/null
+++ b/dev-util/scons/scons-0.96.93.ebuild
@@ -0,0 +1,42 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/scons/scons-0.96.93.ebuild,v 1.1 2006/12/07 09:17:37 twp Exp $
+
+NEED_PYTHON="1.5.2"
+
+inherit python distutils multilib
+
+DESCRIPTION="Extensible Python-based build utility"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+RESTRICT="nomirror"
+HOMEPAGE="http://www.scons.org/"
+
+SLOT="0"
+LICENSE="as-is"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~mips ~ppc ~ppc-macos ~ppc64 ~sparc ~x86"
+IUSE=""
+
+DOCS="RELEASE.txt CHANGES.txt LICENSE.txt"
+
+src_install () {
+ distutils_src_install
+ # move man pages from /usr/man to /usr/share/man
+ dodir /usr/share
+ mv ${D}/usr/man ${D}/usr/share
+}
+
+pkg_postinst() {
+ python_mod_optimize ${ROOT}/usr/$(get_libdir)/${P}
+ # clean up stale junk left there by old faulty ebuilds
+ # see Bug 118022 and Bug 132448
+ if has_version "<dev-util/scons-0.96.92-r1" ; then
+ einfo "Cleaning up stale orphaned py[co] files..."
+ [[ -d "${ROOT}/usr/$(get_libdir)/scons/SCons" ]] \
+ && rm -rf "${ROOT}/usr/$(get_libdir)/scons/SCons"
+ einfo "Done."
+ fi
+}
+
+pkg_postrm() {
+ python_mod_cleanup ${ROOT}/usr/$(get_libdir)/${P}
+}