summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorFabio Erculiani <lxnay@gentoo.org>2011-08-13 14:03:16 +0000
committerFabio Erculiani <lxnay@gentoo.org>2011-08-13 14:03:16 +0000
commit9770c4fcd1199938e134e4b1d7f166f824097c14 (patch)
tree616ac321a99057b467a21f24ebd96e8dcd559729 /dev-util
parentStable for HPPA (bug #378797). (diff)
downloadgentoo-2-9770c4fcd1199938e134e4b1d7f166f824097c14.tar.gz
gentoo-2-9770c4fcd1199938e134e4b1d7f166f824097c14.tar.bz2
gentoo-2-9770c4fcd1199938e134e4b1d7f166f824097c14.zip
install non-arch dependent files in /usr/lib
(Portage version: 2.2.0_alpha37/cvs/Linux x86_64)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/molecule/ChangeLog5
-rw-r--r--dev-util/molecule/molecule-0.9.20.7.ebuild10
2 files changed, 9 insertions, 6 deletions
diff --git a/dev-util/molecule/ChangeLog b/dev-util/molecule/ChangeLog
index d5c35dd16985..3037a8e34fd0 100644
--- a/dev-util/molecule/ChangeLog
+++ b/dev-util/molecule/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-util/molecule
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.23 2011/07/21 12:03:16 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/ChangeLog,v 1.24 2011/08/13 14:03:16 lxnay Exp $
+
+ 13 Aug 2011; Fabio Erculiani <lxnay@gentoo.org> molecule-0.9.20.7.ebuild:
+ install non-arch dependent files in /usr/lib
*molecule-0.9.20.7 (21 Jul 2011)
diff --git a/dev-util/molecule/molecule-0.9.20.7.ebuild b/dev-util/molecule/molecule-0.9.20.7.ebuild
index 7f4d59461380..07470a86fb85 100644
--- a/dev-util/molecule/molecule-0.9.20.7.ebuild
+++ b/dev-util/molecule/molecule-0.9.20.7.ebuild
@@ -1,11 +1,11 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.20.7.ebuild,v 1.1 2011/07/21 12:03:16 lxnay Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/molecule/molecule-0.9.20.7.ebuild,v 1.2 2011/08/13 14:03:16 lxnay Exp $
EAPI="3"
PYTHON_DEPEND="*"
-inherit multilib python
+inherit python
DESCRIPTION="Release metatool used for creating Sabayon (and Gentoo) releases"
HOMEPAGE="http://www.sabayon.org"
@@ -24,15 +24,15 @@ RDEPEND="net-misc/rsync
virtual/cdrtools"
src_install() {
- emake DESTDIR="${D}" LIBDIR="/usr/$(get_libdir)" \
+ emake DESTDIR="${D}" LIBDIR="/usr/lib" \
PREFIX="/usr" SYSCONFDIR="/etc" install \
|| die "emake install failed"
}
pkg_postinst() {
- python_mod_optimize "/usr/$(get_libdir)/molecule"
+ python_mod_optimize "/usr/lib/molecule"
}
pkg_postrm() {
- python_mod_cleanup "/usr/$(get_libdir)/molecule"
+ python_mod_cleanup "/usr/lib/molecule"
}