summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMarius Mauch <genone@gentoo.org>2004-02-28 03:03:17 +0000
committerMarius Mauch <genone@gentoo.org>2004-02-28 03:03:17 +0000
commit9b5c8f199726fbd1ed3c9e2a8af31f206a4b34c1 (patch)
tree1a0f78376d3b2b8ab54c0e08e8ba53939c775ef8 /dev-util
parentinitial commit (bug #43059) (Manifest recommit) (diff)
downloadgentoo-2-9b5c8f199726fbd1ed3c9e2a8af31f206a4b34c1.tar.gz
gentoo-2-9b5c8f199726fbd1ed3c9e2a8af31f206a4b34c1.tar.bz2
gentoo-2-9b5c8f199726fbd1ed3c9e2a8af31f206a4b34c1.zip
played a bit with KDE and the Makefile, should work now
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/gambas/ChangeLog8
-rw-r--r--dev-util/gambas/files/Makefile.am-0.9013
-rw-r--r--dev-util/gambas/gambas-0.90.ebuild15
3 files changed, 21 insertions, 15 deletions
diff --git a/dev-util/gambas/ChangeLog b/dev-util/gambas/ChangeLog
index 646a37bb6087..f12fc6dd7b34 100644
--- a/dev-util/gambas/ChangeLog
+++ b/dev-util/gambas/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/gambas
# Copyright 2000-2004 Gentoo Technologies, Inc.; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.5 2004/02/26 23:29:17 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/ChangeLog,v 1.6 2004/02/28 03:03:16 genone Exp $
+
+ 28 Feb 2004; Marius Mauch <genone@gentoo.org> gambas-0.90.ebuild,
+ files/Makefile.am-0.90:
+ Always enable KDE support now as it doesn't work without, removing qt
+ USE flag as it's pointless. Further patching the Makefile as it now
+ segfaults on KDE info files.
*gambas-0.90 (27 Feb 2004)
diff --git a/dev-util/gambas/files/Makefile.am-0.90 b/dev-util/gambas/files/Makefile.am-0.90
index d1a1b53d2097..2dfd74bd572f 100644
--- a/dev-util/gambas/files/Makefile.am-0.90
+++ b/dev-util/gambas/files/Makefile.am-0.90
@@ -8,12 +8,13 @@ install-exec-local:
@(cd $(srcdir)/app; d=`pwd`; for p in *; do echo "Compiling $$p..."; cd $$d/$$p; \
gbc -ag; gba; rm -rf .gambas; $(INSTALL) $$p $(bindir); done)
- @echo
- @echo "Creating the library info files..."
- @$(INSTALL) -d $(libdir)/info
- @$(bindir)/gbi -a
- @rm -f $(libdir)/lib.gb.la
- @rm -f $(libdir)/lib.gb.so*
+ # This part is producing segfaults on kde stuff
+ #@echo
+ #@echo "Creating the library info files..."
+ #@$(INSTALL) -d $(libdir)/info
+ #@$(bindir)/gbi -a
+ #@rm -f $(libdir)/lib.gb.la
+ #@rm -f $(libdir)/lib.gb.so*
@echo
@echo "Installing the gambas help files..."
diff --git a/dev-util/gambas/gambas-0.90.ebuild b/dev-util/gambas/gambas-0.90.ebuild
index 318dfe39dbbc..2a2417536161 100644
--- a/dev-util/gambas/gambas-0.90.ebuild
+++ b/dev-util/gambas/gambas-0.90.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2004 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.90.ebuild,v 1.2 2004/02/27 02:19:52 genone Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/gambas/gambas-0.90.ebuild,v 1.3 2004/02/28 03:03:16 genone Exp $
inherit eutils
@@ -9,12 +9,12 @@ HOMEPAGE="http://gambas.sourceforge.net"
SRC_URI="http://gambas.sourceforge.net/${P}.tar.bz2"
LICENSE="GPL-2"
SLOT="0"
-KEYWORDS="-*"
-IUSE="kde postgres mysql sdl doc qt curl debug"
+KEYWORDS="~x86"
+IUSE="postgres mysql sdl doc curl debug"
DEPEND=">=sys-devel/automake-1.7.5
>=x11-base/xfree-4.3.0
>=x11-libs/qt-3.2
- kde? ( >=kde-base/kdelibs-3.2 )
+ >=kde-base/kdelibs-3.2
sdl? ( media-libs/libsdl )
mysql? ( dev-db/mysql )
postgres? ( dev-db/postgresql )
@@ -23,7 +23,7 @@ DEPEND=">=sys-devel/automake-1.7.5
src_unpack() {
unpack ${A}
cd "${S}"
- sed -i 's:^ *CFLAGS=.*-Os.*::' 's:^ *CXXFLAGS=.*-Os.*::' configure
+ sed -i 's:-Os::' configure
# replace braindead Makefile
rm Makefile*
cp "${FILESDIR}/Makefile.am-${PV}" ./Makefile.am
@@ -35,12 +35,12 @@ src_unpack() {
src_compile() {
local myconf
- myconf="${myconf} `use_enable kde`"
+ myconf="${myconf} --enable-kde --enable-qt"
myconf="${myconf} `use_enable mysql`"
myconf="${myconf} `use_enable postgres`"
myconf="${myconf} `use_enable sdl`"
myconf="${myconf} `use_enable curl`"
- myconf="${myconf} `use_enable qt`"
+
if use debug; then
myconf="${myconf} --disable-optimization --enable-debug"
else
@@ -56,7 +56,6 @@ src_install() {
export PATH="${D}/usr/bin:${PATH}"
einstall || die
- cd ${S}
dodoc README INSTALL NEWS AUTHORS ChangeLog COPYING TODO
# only install the API docs and examples with USE=doc