summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRobin H. Johnson <robbat2@gentoo.org>2007-11-22 12:58:41 +0000
committerRobin H. Johnson <robbat2@gentoo.org>2007-11-22 12:58:41 +0000
commita6a6831d04adfa73c2eca9a0ea9b03952e419ec4 (patch)
treee650824b71537aee09fc3c46182b098b3d5d9c4b /dev-util
parentamd64 stable wrt #199973 (diff)
downloadgentoo-2-a6a6831d04adfa73c2eca9a0ea9b03952e419ec4.tar.gz
gentoo-2-a6a6831d04adfa73c2eca9a0ea9b03952e419ec4.tar.bz2
gentoo-2-a6a6831d04adfa73c2eca9a0ea9b03952e419ec4.zip
Add missing cpio dependancy, redo the documentation install so that the text versions and (optionally) HTML versions are installed including the release notes. Also install some new bits from contrib: blameview, continuous-integration, remotes2config.
(Portage version: 2.1.3.19)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/git/ChangeLog10
-rw-r--r--dev-util/git/files/digest-git-1.5.3.6-r19
-rw-r--r--dev-util/git/git-1.5.3.6-r1.ebuild192
3 files changed, 210 insertions, 1 deletions
diff --git a/dev-util/git/ChangeLog b/dev-util/git/ChangeLog
index ff5635f6fe9e..e4aca8e2c7fd 100644
--- a/dev-util/git/ChangeLog
+++ b/dev-util/git/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/git
# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.232 2007/11/20 22:07:54 ferdy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/ChangeLog,v 1.233 2007/11/22 12:58:41 robbat2 Exp $
+
+*git-1.5.3.6-r1 (22 Nov 2007)
+
+ 22 Nov 2007; Robin H. Johnson <robbat2@gentoo.org> +git-1.5.3.6-r1.ebuild:
+ Add missing cpio dependancy, redo the documentation install so that the text
+ versions and (optionally) HTML versions are installed including the release
+ notes. Also install some new bits from contrib: blameview,
+ continuous-integration, remotes2config.
*git-1.5.3.6 (20 Nov 2007)
diff --git a/dev-util/git/files/digest-git-1.5.3.6-r1 b/dev-util/git/files/digest-git-1.5.3.6-r1
new file mode 100644
index 000000000000..85f99e352469
--- /dev/null
+++ b/dev-util/git/files/digest-git-1.5.3.6-r1
@@ -0,0 +1,9 @@
+MD5 9b0a6cea7b084f3fc78f264cd2fb49bd git-1.5.3.6.tar.bz2 1356739
+RMD160 dbda09ada993a9835f9f403d7fa5c54ed3598b46 git-1.5.3.6.tar.bz2 1356739
+SHA256 95a5f9d8a9174277b539296901561fff6dbbba20dbdd4cfe5595c22a5a4d2221 git-1.5.3.6.tar.bz2 1356739
+MD5 20fdbd3a2e1f9835c3c5cb6b78c08d0c git-htmldocs-1.5.3.6.tar.bz2 545021
+RMD160 4174428f3d37d3c32776137390bb46d3667a47a9 git-htmldocs-1.5.3.6.tar.bz2 545021
+SHA256 893b72beed877cca84de11f941807441685666016994bf83cbd28cf07b8144c9 git-htmldocs-1.5.3.6.tar.bz2 545021
+MD5 cc8556ff7e89db26dd1a024cfe8584e3 git-manpages-1.5.3.6.tar.bz2 147732
+RMD160 4080488cd65b82b2459b373c3d8eb6d3024b24e9 git-manpages-1.5.3.6.tar.bz2 147732
+SHA256 ec03a96deb343267d34801bb20f18d296c693da19280910cf3e68f5acc89de07 git-manpages-1.5.3.6.tar.bz2 147732
diff --git a/dev-util/git/git-1.5.3.6-r1.ebuild b/dev-util/git/git-1.5.3.6-r1.ebuild
new file mode 100644
index 000000000000..612153980668
--- /dev/null
+++ b/dev-util/git/git-1.5.3.6-r1.ebuild
@@ -0,0 +1,192 @@
+# Copyright 1999-2007 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/git/git-1.5.3.6-r1.ebuild,v 1.1 2007/11/22 12:58:41 robbat2 Exp $
+
+inherit toolchain-funcs eutils elisp-common perl-module bash-completion
+
+MY_PV="${PV/_rc/.rc}"
+MY_P="${PN}-${MY_PV}"
+
+DOC_VER=${MY_PV}
+
+DESCRIPTION="GIT - the stupid content tracker, the revision control system heavily used by the Linux kernel team"
+HOMEPAGE="http://git.or.cz/"
+SRC_URI="mirror://kernel/software/scm/git/${MY_P}.tar.bz2
+ mirror://kernel/software/scm/git/${PN}-manpages-${DOC_VER}.tar.bz2
+ doc? ( mirror://kernel/software/scm/git/${PN}-htmldocs-${DOC_VER}.tar.bz2 )"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~x86-fbsd"
+IUSE="curl doc emacs gtk iconv mozsha1 perl ppcsha1 tk webdav"
+
+DEPEND="
+ !app-misc/git
+ dev-libs/openssl
+ sys-libs/zlib
+ dev-lang/perl
+ app-arch/cpio
+ tk? ( dev-lang/tk )
+ curl? ( net-misc/curl )
+ webdav? ( dev-libs/expat )
+ emacs? ( virtual/emacs )"
+RDEPEND="${DEPEND}
+ perl? ( dev-perl/Error )
+ gtk? ( >=dev-python/pygtk-2.8 )"
+
+SITEFILE=72${PN}-gentoo.el
+S="${WORKDIR}/${MY_P}"
+
+# This is needed because for some obscure reasons future calls to make don't
+# pick up these exports if we export them in src_unpack()
+exportmakeopts() {
+ local myopts
+
+ if use mozsha1 ; then
+ myopts="${myopts} MOZILLA_SHA1=YesPlease"
+ elif use ppcsha1 ; then
+ myopts="${myopts} PPC_SHA1=YesPlease"
+ fi
+
+ if use curl ; then
+ use webdav || myopts="${myopts} NO_EXPAT=YesPlease"
+ else
+ myopts="${myopts} NO_CURL=YesPlease"
+ use webdav && ewarn "USE=webdav only matters with USE=curl. Ignoring."
+ fi
+
+ myopts="${myopts} WITH_SEND_EMAIL=YesPlease"
+
+ use iconv || myopts="${myopts} NO_ICONV=YesPlease"
+
+ export MY_MAKEOPTS=${myopts}
+}
+
+showpkgdeps() {
+ local pkg=$1
+ shift
+ elog " $(printf "%-17s:" ${pkg}) ${@}"
+}
+
+src_unpack() {
+ unpack ${MY_P}.tar.bz2
+ cd "${S}"
+ unpack ${PN}-manpages-${DOC_VER}.tar.bz2
+ use doc && cd "${S}"/Documentation && unpack ${PN}-htmldocs-${DOC_VER}.tar.bz2
+ cd "${S}"
+
+ epatch "${FILESDIR}"/${PN}-1.5.3-symlinks.patch
+
+ sed -i \
+ -e "s:^\(CFLAGS = \).*$:\1${CFLAGS} -Wall:" \
+ -e "s:^\(LDFLAGS = \).*$:\1${LDFLAGS}:" \
+ -e "s:^\(CC = \).*$:\1$(tc-getCC):" \
+ -e "s:^\(AR = \).*$:\1$(tc-getAR):" \
+ -e 's:ln :ln -s :g' \
+ Makefile || die "sed failed"
+
+ exportmakeopts
+}
+
+src_compile() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr || die "make failed"
+
+ if use emacs ; then
+ elisp-compile contrib/emacs/{,vc-}git.el || die "emacs modules failed"
+ fi
+}
+
+src_install() {
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr install || \
+ die "make install failed"
+
+ use tk || rm "${D}"/usr/bin/git{k,-gui}
+
+ doman man?/*
+
+ dodoc README Documentation/{SubmittingPatches,CodingGuidelines}
+ use doc && dodir /usr/share/doc/${PF}/html
+ for d in / /howto/ /technical/ ; do
+ einfo "Doing Documentation${d}"
+ docinto ${d}
+ dodoc Documentation${d}*.txt
+ use doc && dohtml -p ${d} Documentation${d}*.html
+ done
+ docinto /
+
+ dobashcompletion contrib/completion/git-completion.bash ${PN}
+
+ if use emacs ; then
+ elisp-install ${PN} contrib/emacs/{,vc-}git.el* || \
+ die "elisp-install failed"
+ elisp-site-file-install "${FILESDIR}"/${SITEFILE}
+ # don't add automatically to the load-path, so the sitefile
+ # can do a conditional loading
+ touch "${D}"/"${SITELISP}"/${PN}/.nosearch
+ fi
+
+ if use gtk ; then
+ dobin "${S}"/contrib/gitview/gitview
+ dodoc "${S}"/contrib/gitview/gitview.txt
+ newbin "${S}"/contrib/blameview/blameview.perl blameview
+ newdoc "${S}"/contrib/blameview/README README.blameview
+ fi
+
+ dodir /usr/share/${PN}/contrib
+ for i in continuous fast-import hg-to-git \
+ hooks remotes2config.sh vim stats \
+ workdir ; do
+ cp -rf \
+ "${S}"/contrib/${i} \
+ "${D}"/usr/share/${PN}/contrib \
+ || die "Failed contrib ${i}"
+ done
+
+ insinto /etc/xinetd.d
+ newins "${FILESDIR}"/git-daemon.xinetd git-daemon
+
+ newinitd "${FILESDIR}"/git-daemon.initd git-daemon
+ newconfd "${FILESDIR}"/git-daemon.confd git-daemon
+
+ fixlocalpod
+}
+
+src_test() {
+ cd "${S}"
+ has_version dev-util/subversion || \
+ MY_MAKEOPTS="${MY_MAKEOPTS} NO_SVN_TESTS=YesPlease"
+ has_version app-arch/unzip || \
+ rm "${S}"/t/t5000-tar-tree.sh
+ # Stupid CVS won't let some people commit as root
+ rm "${S}"/t/t9200-git-cvsexportcommit.sh
+ emake ${MY_MAKEOPTS} DESTDIR="${D}" prefix=/usr test || die "tests failed"
+}
+
+pkg_postinst() {
+ if use emacs ; then
+ elisp-site-regen
+ elog "GNU Emacs has built-in Git support in versions greater 22.1."
+ elog "You can disable the emacs USE flag for dev-util/git"
+ elog "if you are using such a version."
+ fi
+ elog "These additional scripts need some dependencies:"
+ echo
+ showpkgdeps git-archimport "dev-util/tla"
+ showpkgdeps git-cvsimport ">=dev-util/cvsps-2.1"
+ showpkgdeps git-svnimport "dev-util/subversion(USE=perl)"
+ showpkgdeps git-svn \
+ "dev-util/subversion(USE=perl)" \
+ "dev-perl/libwww-perl" \
+ "dev-perl/TermReadKey"
+ showpkgdeps git-quiltimport "dev-util/quilt"
+ showpkgdeps git-cvsserver "dev-perl/DBI" "dev-perl/DBD-SQLite"
+ showpkgdeps git-instaweb \
+ "|| ( www-servers/lighttpd www-servers/apache(SLOT=2) )"
+ showpkgdeps git-send-email "USE=perl"
+ showpkgdeps git-remote "USE=perl"
+ echo
+}
+
+pkg_postrm() {
+ use emacs && elisp-site-regen
+}