summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorIan Delaney <idella4@gentoo.org>2014-09-21 09:24:45 +0000
committerIan Delaney <idella4@gentoo.org>2014-09-21 09:24:45 +0000
commitba64962c5e2d95a2d41813f528185d13461acfd1 (patch)
tree7392a6281d3fd54949fd3cf47d80daa86f2c42fb /dev-util
parentAdd ~ppc, wrt bug #523344 (diff)
downloadgentoo-2-ba64962c5e2d95a2d41813f528185d13461acfd1.tar.gz
gentoo-2-ba64962c5e2d95a2d41813f528185d13461acfd1.tar.bz2
gentoo-2-ba64962c5e2d95a2d41813f528185d13461acfd1.zip
bump; ebuild based on graaf's verion from his overlay with additions to the doc builds, thx graaf. Remove old ebuilds and patch, see Bug 522472
(Portage version: 2.2.10/cvs/Linux x86_64, signed Manifest commit with key 0xB8072B0D)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/reviewboard/ChangeLog10
-rw-r--r--dev-util/reviewboard/files/1.7.28-docs.patch (renamed from dev-util/reviewboard/files/docs.patch)3
-rw-r--r--dev-util/reviewboard/reviewboard-1.7.28.ebuild (renamed from dev-util/reviewboard/reviewboard-1.7.7.1-r1.ebuild)31
-rw-r--r--dev-util/reviewboard/reviewboard-1.7.7.1.ebuild116
4 files changed, 25 insertions, 135 deletions
diff --git a/dev-util/reviewboard/ChangeLog b/dev-util/reviewboard/ChangeLog
index 288527e4a744..85951667b61f 100644
--- a/dev-util/reviewboard/ChangeLog
+++ b/dev-util/reviewboard/ChangeLog
@@ -1,6 +1,14 @@
# ChangeLog for dev-util/reviewboard
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/reviewboard/ChangeLog,v 1.10 2014/08/22 10:26:40 idella4 Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/reviewboard/ChangeLog,v 1.11 2014/09/21 09:24:45 idella4 Exp $
+
+*reviewboard-1.7.28 (21 Sep 2014)
+
+ 21 Sep 2014; Ian Delaney <idella4@gentoo.org> +files/1.7.28-docs.patch,
+ +reviewboard-1.7.28.ebuild, -files/docs.patch, -reviewboard-1.7.7.1-r1.ebuild,
+ -reviewboard-1.7.7.1.ebuild:
+ bump; ebuild based on graaf's verion from his overlay with additions to the
+ doc builds, thx graaf. Remove old ebuilds and patch, see Bug 522472
22 Aug 2014; Ian Delaney <idella4@gentoo.org> -reviewboard-1.7.12.ebuild:
remove old unviable version
diff --git a/dev-util/reviewboard/files/docs.patch b/dev-util/reviewboard/files/1.7.28-docs.patch
index 8292a86355ac..99741d2e40d0 100644
--- a/dev-util/reviewboard/files/docs.patch
+++ b/dev-util/reviewboard/files/1.7.28-docs.patch
@@ -49,5 +49,4 @@ ReviewBoard-1.7.7.1/docs/releasenotes/conf.py
-
-
-# Example configuration for intersphinx: refer to the Python standard library.
--intersphinx_mapping = {'http://www.reviewboard.org/docs/manual/dev': None}
-
+-intersphinx_mapping = {'https://www.reviewboard.org/docs/manual/dev': None}
diff --git a/dev-util/reviewboard/reviewboard-1.7.7.1-r1.ebuild b/dev-util/reviewboard/reviewboard-1.7.28.ebuild
index ee142bd9316e..aa75ae0b5e6b 100644
--- a/dev-util/reviewboard/reviewboard-1.7.7.1-r1.ebuild
+++ b/dev-util/reviewboard/reviewboard-1.7.28.ebuild
@@ -1,9 +1,9 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/reviewboard/reviewboard-1.7.7.1-r1.ebuild,v 1.3 2014/07/04 19:46:36 hasufell Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/reviewboard/reviewboard-1.7.28.ebuild,v 1.1 2014/09/21 09:24:45 idella4 Exp $
EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
+PYTHON_COMPAT=( python2_7 )
PYTHON_REQ_USE="sqlite"
inherit distutils-r1
@@ -19,19 +19,21 @@ LICENSE="MIT"
SLOT="0"
S=${WORKDIR}/${MY_PN}-${PV}
-RDEPEND=">=dev-python/django-1.4.3[${PYTHON_USEDEP},sqlite]
+RDEPEND=">=dev-python/django-1.4.14[${PYTHON_USEDEP},sqlite]
<dev-python/django-1.5[${PYTHON_USEDEP},sqlite]
- >=dev-python/django-evolution-0.6.7[${PYTHON_USEDEP}]
+ >=dev-python/django-evolution-0.6.9[${PYTHON_USEDEP}]
+ <dev-python/django-evolution-0.7[${PYTHON_USEDEP}]
>=dev-python/django-pipeline-1.2.24[${PYTHON_USEDEP}]
- >=dev-python/Djblets-0.7.7[${PYTHON_USEDEP}]
+ >=dev-python/Djblets-0.7.31[${PYTHON_USEDEP}]
+ <dev-python/Djblets-0.8[${PYTHON_USEDEP}]
>=dev-python/pygments-1.5[${PYTHON_USEDEP}]
dev-python/docutils[${PYTHON_USEDEP}]
>=dev-python/markdown-2.2.1[${PYTHON_USEDEP}]
- >=dev-python/paramiko-1.7.6[${PYTHON_USEDEP}]
+ >=dev-python/paramiko-1.9.0[${PYTHON_USEDEP}]
>=dev-python/mimeparse-0.1.3[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
+ dev-python/python-dateutil:python-2
dev-python/python-memcached[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
+ >=dev-python/pytz-2012h[${PYTHON_USEDEP}]
dev-python/recaptcha-client[${PYTHON_USEDEP}]"
DEPEND="${RDEPEND}
dev-python/setuptools[${PYTHON_USEDEP}]
@@ -42,16 +44,12 @@ REQUIRED_USE="doc? ( || ( codebase manual rnotes ) )"
# Tests mostly access the inet and when run mostly fail
RESTRICT=test
-PATCHES=( "${FILESDIR}"/docs.patch
- "${FILESDIR}"/CVE-2013-2209-sec.patch )
+PATCHES=( "${FILESDIR}"/${PV}-docs.patch )
python_prepare_all() {
- # Higher versions do not support python-2.5, while reviewboard upstream
- # still does. We do not support python-2.5 for this package as it will
- # prevent downgrades for some of our dependencies.
- sed -i setup.py \
- -e "s/python-dateutil==1.5/python-dateutil/" \
- -e "s/django-pipeline>=1.2.24,<1.3/django-pipeline>=1.2.24/" || die
+ # Running uglify is a problem right now, so skip this step. Rather
+ # have newer versions that compacted javascript.
+ sed -e "s/'pipeline.compressors.uglifyjs.UglifyJSCompressor'/None/" -i reviewboard/settings.py || die
distutils-r1_python_prepare_all
}
@@ -67,6 +65,7 @@ python_compile_all() {
einfo;einfo "$msg manual"
DJANGO_SETTINGS_MODULE="django.conf" emake -C docs/manual html
fi
+
if use codebase; then
pushd docs/codebase &> /dev/null
ln -sf ../../contrib/internal/conf/settings_local.py .
diff --git a/dev-util/reviewboard/reviewboard-1.7.7.1.ebuild b/dev-util/reviewboard/reviewboard-1.7.7.1.ebuild
deleted file mode 100644
index ea382c8d23ec..000000000000
--- a/dev-util/reviewboard/reviewboard-1.7.7.1.ebuild
+++ /dev/null
@@ -1,116 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/reviewboard/reviewboard-1.7.7.1.ebuild,v 1.1 2013/06/16 16:02:06 idella4 Exp $
-
-EAPI=5
-PYTHON_COMPAT=( python{2_6,2_7} )
-
-inherit distutils-r1
-
-MY_PN="ReviewBoard"
-DESCRIPTION="A web-based code review tool that offers developers an easy way to handle code reviews"
-HOMEPAGE="http://www.reviewboard.org/"
-SRC_URI="http://downloads.reviewboard.org/releases/${MY_PN}/1.7/${MY_PN}-${PV}.tar.gz"
-KEYWORDS="~amd64 ~x86"
-IUSE="codebase doc manual rnotes test"
-
-LICENSE="MIT"
-SLOT="0"
-S=${WORKDIR}/${MY_PN}-${PV}
-
-RDEPEND=">=dev-python/django-1.4.3[${PYTHON_USEDEP}]
- <dev-python/django-1.5[${PYTHON_USEDEP}]
- >=dev-python/django-evolution-0.6.7[${PYTHON_USEDEP}]
- >=dev-python/django-pipeline-1.2.24[${PYTHON_USEDEP}]
- >=dev-python/Djblets-0.7.7[${PYTHON_USEDEP}]
- >=dev-python/pygments-1.5[${PYTHON_USEDEP}]
- dev-python/docutils[${PYTHON_USEDEP}]
- >=dev-python/markdown-2.2.1[${PYTHON_USEDEP}]
- >=dev-python/paramiko-1.7.6[${PYTHON_USEDEP}]
- >=dev-python/mimeparse-0.1.3[${PYTHON_USEDEP}]
- dev-python/python-dateutil[${PYTHON_USEDEP}]
- dev-python/python-memcached[${PYTHON_USEDEP}]
- dev-python/pytz[${PYTHON_USEDEP}]
- dev-python/recaptcha-client[${PYTHON_USEDEP}]"
-DEPEND="${RDEPEND}
- dev-python/setuptools[${PYTHON_USEDEP}]
- test? ( dev-python/nose[${PYTHON_USEDEP}] )
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )"
-
-REQUIRED_USE="doc? ( || ( codebase manual rnotes ) )"
-# Tests mostly access the inet and when run mostly fail
-RESTRICT=test
-
-PATCHES=( "${FILESDIR}"/docs.patch )
-
-python_prepare_all() {
- # Higher versions do not support python-2.5, while reviewboard upstream
- # still does. We do not support python-2.5 for this package as it will
- # prevent downgrades for some of our dependencies.
- sed -i setup.py \
- -e "s/python-dateutil==1.5/python-dateutil/" \
- -e "s/django-pipeline>=1.2.24,<1.3/django-pipeline>=1.2.24/" || die
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- # See http://code.google.com/p/reviewboard/issues/ #3009
- # until build of manual can find and use ROOT_URLCONF, only possible build path for manual
- # requires sacrificing the resources section, all of which call on ROOT_URLCONF
- local msg="Generating docs for"
- if use doc; then
- if use manual; then
- rm -rf docs/manual/webapi//2.0/resources/ || die
- einfo;einfo "$msg manual"
- DJANGO_SETTINGS_MODULE="django.conf" emake -C docs/manual html
- fi
- if use codebase; then
- pushd docs/codebase &> /dev/null
- ln -sf ../../contrib/internal/conf/settings_local.py .
- popd &> /dev/null
- einfo;einfo "$msg codebase"
- emake -C docs/codebase html
- fi
-
- if use rnotes; then
- einfo;einfo "$msg release notes"
- emake -C docs/releasenotes html
- fi
- fi
-}
-
-python_test() {
- pushd ${PN} > /dev/null
- ln -sf contrib/internal/conf/settings_local.py .
- "${PYTHON}" manage.py test || die
-}
-
-python_install_all() {
- if use doc; then
- if use manual; then
- insinto /usr/share/doc/${PF}/manual
- doins -r docs/manual/_build/html/
- fi
- if use codebase; then
- insinto /usr/share/doc/${PF}/codebase
- doins -r docs/codebase/_build/html/
- fi
- if use rnotes; then
- insinto /usr/share/doc/${PF}/release_notes
- doins -r docs/releasenotes/_build/html/
- fi
- fi
- distutils-r1_python_install_all
-}
-
-pkg_postinst() {
- elog "You must install any VCS tool you wish ${PN} to support."
- elog "dev-util/cvs, dev-vcs/git, dev-vcs/mercurial or dev-util/subversion."
- elog
- elog "Enable the mysql, postgres or sqlite USEflag on dev-python/django"
- elog "to use the corresponding database backend."
- elog
- elog "For speed and responsiveness, consider installing net-misc/memcached"
- elog "and dev-python/python-memcached"
-}