summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2006-06-11 09:38:51 +0000
committerGeorge Shapovalov <george@gentoo.org>2006-06-11 09:38:51 +0000
commitc8fc0621c5d96764e9b7173ae64e1b770cd16ccb (patch)
tree7ff7619686fef7fbb8379dc8c76323938c05bf3e /dev-util
parentcleanup inherit - fix SRC_URI - depend on new style bglibs - remove unneeded ... (diff)
downloadgentoo-2-c8fc0621c5d96764e9b7173ae64e1b770cd16ccb.tar.gz
gentoo-2-c8fc0621c5d96764e9b7173ae64e1b770cd16ccb.tar.bz2
gentoo-2-c8fc0621c5d96764e9b7173ae64e1b770cd16ccb.zip
new version (#132495), the m4 issue is fixed, the --as-needed patch is still needed
(Portage version: 2.1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppunit/ChangeLog8
-rw-r--r--dev-util/cppunit/cppunit-1.11.6.ebuild45
-rw-r--r--dev-util/cppunit/files/digest-cppunit-1.11.63
3 files changed, 55 insertions, 1 deletions
diff --git a/dev-util/cppunit/ChangeLog b/dev-util/cppunit/ChangeLog
index 77f8e2c5dabb..67b1b417a5cf 100644
--- a/dev-util/cppunit/ChangeLog
+++ b/dev-util/cppunit/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-util/cppunit
# Copyright 2002-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.16 2006/04/21 17:00:33 flameeyes Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.17 2006/06/11 09:38:51 george Exp $
+
+*cppunit-1.11.6 (11 Jun 2006)
+
+ 11 Jun 2006; George Shapovalov <george@gentoo.org> +cppunit-1.11.6.ebuild:
+ new version (#132495), the m4 issue is fixed, the --as-needed patch is still
+ necessary
21 Apr 2006; Diego Pettenò <flameeyes@gentoo.org>
+files/cppunit-1.10.2-asneeded.patch, cppunit-1.10.2.ebuild:
diff --git a/dev-util/cppunit/cppunit-1.11.6.ebuild b/dev-util/cppunit/cppunit-1.11.6.ebuild
new file mode 100644
index 000000000000..e02a841d4ce0
--- /dev/null
+++ b/dev-util/cppunit/cppunit-1.11.6.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2006 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.11.6.ebuild,v 1.1 2006/06/11 09:38:51 george Exp $
+
+inherit eutils autotools
+
+DESCRIPTION="C++ port of the famous JUnit framework for unit testing"
+HOMEPAGE="http://cppunit.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL-2.1"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~ppc ~sparc ~x86"
+IUSE="doc"
+RESTRICT="test"
+
+DEPEND="doc? ( app-doc/doxygen
+ media-gfx/graphviz )"
+RDEPEND=""
+
+src_unpack() {
+ unpack ${A}
+ cd "${S}"
+ epatch "${FILESDIR}/${PN}-1.10.2-asneeded.patch"
+ AT_M4DIR="${S}/config" eautomake
+
+ elibtoolize
+}
+
+src_compile() {
+ econf \
+ $(use_enable doc doxygen) \
+ $(use_enable doc dot) \
+ || die "configure failed"
+ emake || die
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die
+ dodoc AUTHORS BUGS NEWS README THANKS TODO
+ # the package automatically puts its docs into /usr/share/cppunit
+ # move them to the standard location and clean up
+ mv ${D}/usr/share/cppunit/html ${D}/usr/share/doc/${PF}
+ rm -rf ${D}/usr/share/cppunit
+}
diff --git a/dev-util/cppunit/files/digest-cppunit-1.11.6 b/dev-util/cppunit/files/digest-cppunit-1.11.6
new file mode 100644
index 000000000000..44f20ef2302b
--- /dev/null
+++ b/dev-util/cppunit/files/digest-cppunit-1.11.6
@@ -0,0 +1,3 @@
+MD5 54734b1d054277e4fc0bac0df6e0aa4d cppunit-1.11.6.tar.gz 759854
+RMD160 70e909c42b20ce8fee446aeea16ab5ed02d59bc5 cppunit-1.11.6.tar.gz 759854
+SHA256 bad626a63101ef79c28536f9db9a1efdb543622afac0532e1bfb1c459e726da2 cppunit-1.11.6.tar.gz 759854