summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorDaniel Robbins <drobbins@gentoo.org>2002-07-08 04:05:36 +0000
committerDaniel Robbins <drobbins@gentoo.org>2002-07-08 04:05:36 +0000
commitd2157e2b28742c8cdc747094ed83da8cb14261cb (patch)
tree54a8ba8a5328cde86892415f86ba39ca8e2adf08 /dev-util
parentrepoman digest fixups (diff)
downloadgentoo-2-d2157e2b28742c8cdc747094ed83da8cb14261cb.tar.gz
gentoo-2-d2157e2b28742c8cdc747094ed83da8cb14261cb.tar.bz2
gentoo-2-d2157e2b28742c8cdc747094ed83da8cb14261cb.zip
repoman fixes
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/lincvs/lincvs-0.3.0-r1.ebuild62
1 files changed, 27 insertions, 35 deletions
diff --git a/dev-util/lincvs/lincvs-0.3.0-r1.ebuild b/dev-util/lincvs/lincvs-0.3.0-r1.ebuild
index 791c554608fb..6411157f1b44 100644
--- a/dev-util/lincvs/lincvs-0.3.0-r1.ebuild
+++ b/dev-util/lincvs/lincvs-0.3.0-r1.ebuild
@@ -1,53 +1,45 @@
-# Copyright 1999-2000 Gentoo Technologies, Inc.
+# Copyright 1999-2002 Gentoo Technologies, Inc.
# Distributed under the terms of the GNU General Public License, v2 or later
-# Author Achim Gottinger <achim@gentoo.org>
-# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/lincvs-0.3.0-r1.ebuild,v 1.2 2002/02/03 21:49:51 danarmak Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/lincvs/lincvs-0.3.0-r1.ebuild,v 1.3 2002/07/08 04:02:51 drobbins Exp $
S=${WORKDIR}/LinCVS-0.3
DESCRIPTION="A Graphical CVS Client"
SRC_URI="http://ppprs1.phy.tu-dresden.de/~trogisch/${PN}/download/${P}/${PN}-0.3-0-generic-src.tgz
http://ppprs1.phy.tu-dresden.de/~trogisch/${PN}/download/${P}/${PN}-0.3.patch-1.tgz"
HOMEPAGE="http://www.lincvs.de"
-
-DEPEND="kde? ( >=kde-base/kdelibs-2.1.1 )
- =x11-libs/qt-x11-2*"
-RDEPEND="$DEPEND
- dev-util/cvs"
+SLOT="0"
+DEPEND="kde? ( >=kde-base/kdelibs-2.1.1 ) =x11-libs/qt-2*"
+RDEPEND="$DEPEND dev-util/cvs"
+KEYWORDS="*"
+LICENSE="GPL-2"
src_unpack () {
-
- unpack ${A}
- patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
- cd ${S}/src
- patch diffview.cpp ${WORKDIR}/LinCVS-patch/diffview.patch
-
+ unpack ${A}
+ patch -p0 < ${FILESDIR}/${PF}-gentoo.diff
+ cd ${S}/src
+ patch diffview.cpp ${WORKDIR}/LinCVS-patch/diffview.patch
}
src_compile() {
-
- if [ "`use kde`" ] ; then
- sed "s:KDE2DIR:KDEDIR:g" Makefile.kde2 > Makefile
- fi
- cp Makefile Makefile.orig
- sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
-
- make
-
+ if [ "`use kde`" ] ; then
+ sed "s:KDE2DIR:KDEDIR:g" Makefile.kde2 > Makefile
+ fi
+ cp Makefile Makefile.orig
+ sed -e "s:-O2:${CFLAGS}:" Makefile.orig > Makefile
+ make
}
src_install () {
-
- into /usr
- dobin LinCVS tools/*.sh
- insinto /usr/share/icons/lincvs
- doins res/*.xpm
- dodoc AUTHORS COPYING ChangeLog
- #This is required by the app - uncmopressed txt's
- cd ${D}/usr/share/doc
- ln -s ${P}-${PR} ${PN}
- cd ${PN}
- cp ${S}/*.{txt,TXT} .
-
+ into /usr
+ dobin LinCVS tools/*.sh
+ insinto /usr/share/icons/lincvs
+ doins res/*.xpm
+ dodoc AUTHORS COPYING ChangeLog
+ #This is required by the app - uncmopressed txt's
+ cd ${D}/usr/share/doc
+ ln -s ${P}-${PR} ${PN}
+ cd ${PN}
+ cp ${S}/*.{txt,TXT} .
}