summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRémi Cardona <remi@gentoo.org>2008-04-02 11:26:55 +0000
committerRémi Cardona <remi@gentoo.org>2008-04-02 11:26:55 +0000
commitedcfc4fb1b6a067f2693e9517faf3cc01940bb4e (patch)
tree8d2abb325dd1c917b8d82269f9f94d2ce7d9dceb /dev-util
parentia64/sparc stable wrt #214971 (diff)
downloadgentoo-2-edcfc4fb1b6a067f2693e9517faf3cc01940bb4e.tar.gz
gentoo-2-edcfc4fb1b6a067f2693e9517faf3cc01940bb4e.tar.bz2
gentoo-2-edcfc4fb1b6a067f2693e9517faf3cc01940bb4e.zip
dev-util/pkgconfig: bump to 0.23
(Portage version: 2.1.4.4)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/pkgconfig/ChangeLog9
-rw-r--r--dev-util/pkgconfig/pkgconfig-0.23.ebuild40
2 files changed, 47 insertions, 2 deletions
diff --git a/dev-util/pkgconfig/ChangeLog b/dev-util/pkgconfig/ChangeLog
index e42d11eba173..6dbff5bb08b3 100644
--- a/dev-util/pkgconfig/ChangeLog
+++ b/dev-util/pkgconfig/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-util/pkgconfig
-# Copyright 1999-2007 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.71 2007/12/04 18:40:39 jer Exp $
+# Copyright 1999-2008 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/ChangeLog,v 1.72 2008/04/02 11:26:55 remi Exp $
+
+*pkgconfig-0.23 (02 Apr 2008)
+
+ 02 Apr 2008; Rémi Cardona <remi@gentoo.org> +pkgconfig-0.23.ebuild:
+ bump to 0.23, patch to fix make check has been included by upstream
04 Dec 2007; Jeroen Roovers <jer@gentoo.org> pkgconfig-0.22.ebuild:
Stable for HPPA (bug #201122).
diff --git a/dev-util/pkgconfig/pkgconfig-0.23.ebuild b/dev-util/pkgconfig/pkgconfig-0.23.ebuild
new file mode 100644
index 000000000000..ca50e3d4d4b9
--- /dev/null
+++ b/dev-util/pkgconfig/pkgconfig-0.23.ebuild
@@ -0,0 +1,40 @@
+# Copyright 1999-2008 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-util/pkgconfig/pkgconfig-0.23.ebuild,v 1.1 2008/04/02 11:26:55 remi Exp $
+
+inherit flag-o-matic eutils
+
+MY_PN="pkg-config"
+MY_P="${MY_PN}-${PV}"
+DESCRIPTION="Package config system that manages compile/link flags"
+HOMEPAGE="http://pkgconfig.freedesktop.org/wiki/"
+
+SRC_URI="http://pkgconfig.freedesktop.org/releases/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~sparc-fbsd ~x86 ~x86-fbsd"
+IUSE="hardened elibc_FreeBSD"
+
+DEPEND=""
+
+S=${WORKDIR}/${MY_P}
+
+src_compile() {
+ local myconf
+
+ use ppc64 && use hardened && replace-flags -O[2-3] -O1
+
+ # Force using all the requirements when linking, so that needed -pthread
+ # lines are inherited between libraries
+ use elibc_FreeBSD && myconf="${myconf} --enable-indirect-deps"
+
+ econf ${myconf} || die "econf failed"
+ emake || die "emake failed"
+}
+
+src_install() {
+ make DESTDIR="${D}" install || die "Installation failed"
+
+ dodoc AUTHORS ChangeLog NEWS README
+}