summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorGeorge Shapovalov <george@gentoo.org>2002-10-30 01:10:20 +0000
committerGeorge Shapovalov <george@gentoo.org>2002-10-30 01:10:20 +0000
commitf8679df7ba6c8a5fc709107b32fd448f469cb0ab (patch)
treecf0aaad3f4ef2cb417010561ec12060d91a249d2 /dev-util
parentnew package: a CAS as well as a C++ library providing algebraic capabilities. (diff)
downloadgentoo-2-f8679df7ba6c8a5fc709107b32fd448f469cb0ab.tar.gz
gentoo-2-f8679df7ba6c8a5fc709107b32fd448f469cb0ab.tar.bz2
gentoo-2-f8679df7ba6c8a5fc709107b32fd448f469cb0ab.zip
new package: cppunit library, a unit testing framework
generally used in XP programming projects.
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/cppunit/ChangeLog13
-rw-r--r--dev-util/cppunit/cppunit-1.8.0.ebuild76
-rw-r--r--dev-util/cppunit/files/digest-cppunit-1.8.01
3 files changed, 90 insertions, 0 deletions
diff --git a/dev-util/cppunit/ChangeLog b/dev-util/cppunit/ChangeLog
new file mode 100644
index 000000000000..2a8728eb9a79
--- /dev/null
+++ b/dev-util/cppunit/ChangeLog
@@ -0,0 +1,13 @@
+# ChangeLog for dev-util/cppunit
+# Copyright 2002 Gentoo Technologies, Inc.; Distributed under the GPL
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/ChangeLog,v 1.1 2002/10/30 01:10:20 george Exp $
+
+*cppunit-1.8.0 (29 Oct 2002)
+
+ 29 Oct 2002; George Shapovalov <george@gentoo.org> cppunit-1.8.0.ebuild :
+
+ initial release
+
+ cppunit: a unit testing framework, generally used in XP programming projects.
+
+ ebuild submitted by: Darke <darkepaw@users.sourceforge.net>
diff --git a/dev-util/cppunit/cppunit-1.8.0.ebuild b/dev-util/cppunit/cppunit-1.8.0.ebuild
new file mode 100644
index 000000000000..0408f6bff5ee
--- /dev/null
+++ b/dev-util/cppunit/cppunit-1.8.0.ebuild
@@ -0,0 +1,76 @@
+# Copyright 1999-2002 Gentoo Technologies, Inc.
+# Distributed under the terms of the GNU General Public License, v2 or later
+# $Header: /var/cvsroot/gentoo-x86/dev-util/cppunit/cppunit-1.8.0.ebuild,v 1.1 2002/10/30 01:10:20 george Exp $
+
+
+DESCRIPTION="CppUnit is the C++ port of the famous JUnit framework for unit testing."
+
+HOMEPAGE="http://cppunit.sourceforge.net/"
+SRC_URI="http://unc.dl.sourceforge.net/sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="LGPL"
+SLOT="0"
+KEYWORDS="~x86 ~ppc ~sparc ~sparc64"
+
+DEPEND="app-doc/doxygen
+ media-gfx/graphviz"
+
+src_compile () {
+ ./configure --prefix=/usr || die
+ emake || die
+ #emake check || die
+}
+
+src_install () {
+ # The libs
+ insinto /usr
+ dolib ${S}/src/cppunit/.libs/libcppunit-1.8.so.0.0.0 || die
+ #the symlinks in /usr/lib should be local
+ cd ${D}/usr/lib
+ ln -sf libcppunit-1.8.so.0.0.0 libcppunit-1.8.so.0 || die
+ ln -sf libcppunit-1.8.so.0.0.0 libcppunit.so || die
+ cd ${S}
+ dolib ${S}/src/cppunit/.libs/libcppunit.a || die
+
+ # Main headers
+ dodir /usr/include
+ dodir /usr/include/cppunit
+ find src -name "*.h" -exec cp '{}' ${D}/usr/include/cppunit ';'
+
+ # The user interface headers. There's also a MFC header, but it's
+ # not as if this is ever going to be used on a 'doze box. *grin*
+ dodir /usr/include/cppunit/ui
+ dodir /usr/include/cppunit/ui/qt
+ find ${S}/src -name "*.h" -exec cp '{}' ${D}/usr/include/cppunit/ui/qt ';'
+ dodir /usr/include/cppunit/ui/text
+ find ${S}/src -name "*.h" -exec cp '{}' ${D}/usr/include/cppunit/ui/text ';'
+
+ # And extension headers
+ dodir /usr/include/cppunit/extensions
+ find ${S}/src -name "*.h" -exec cp '{}' ${D}/usr/include/cppunit/extensions ';'
+
+ # And now for the documentation
+ docinto /usr
+ dodoc ChangeLog INSTALL COPYING
+
+ dodir /usr/share/doc/${P}
+ #cp -a ${S}/doc/html ${D}/usr/share/doc/${P}
+ dohtml doc/html
+
+ # There's a two-question text FAQ as well, but it's included in the
+ # html docs and IMO not worth repeating.
+
+ # Now examples, first a 'game' example:
+ dodir /usr/share/doc/${P}/examples/hierarchy
+ cp -a ${S}/examples/hierarchy/*.cpp ${D}/usr/share/doc/${P}/examples/hierarchy
+ cp -a ${S}/examples/hierarchy/*.h ${D}/usr/share/doc/${P}/examples/hierarchy
+ #cp -a ${S}/examples/hierarchy/hierarchy ${D}/usr/share/doc/${P}/examples/hierarchy
+
+ # Then the cppunittest 'example':
+ dodir /usr/share/doc/${P}/examples/cppunittest
+ cp -a ${S}/examples/cppunittest/*.cpp ${D}/usr/share/doc/${P}/examples/cppunittest
+ cp -a ${S}/examples/cppunittest/*.h ${D}/usr/share/doc/${P}/examples/cppunittest
+ #cp -a ${S}/examples/cppunittest/cppunittestmain ${D}/usr/share/doc/${P}/examples/cppunittest
+
+}
+
diff --git a/dev-util/cppunit/files/digest-cppunit-1.8.0 b/dev-util/cppunit/files/digest-cppunit-1.8.0
new file mode 100644
index 000000000000..d865061452e8
--- /dev/null
+++ b/dev-util/cppunit/files/digest-cppunit-1.8.0
@@ -0,0 +1 @@
+MD5 9f18d97ca99b4f095f5ff18139df59c3 cppunit-1.8.0.tar.gz 382730