summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorChris Parrott <cparrott@gentoo.org>2006-10-16 22:08:53 +0000
committerChris Parrott <cparrott@gentoo.org>2006-10-16 22:08:53 +0000
commitff433cdaa52c627699f22cfa60f4ed9553556534 (patch)
tree1ad053d84ac751b138ba46e07bc18f7307f96db3 /dev-util
parentStable on x86 wrt bug #145371. (diff)
downloadgentoo-2-ff433cdaa52c627699f22cfa60f4ed9553556534.tar.gz
gentoo-2-ff433cdaa52c627699f22cfa60f4ed9553556534.tar.bz2
gentoo-2-ff433cdaa52c627699f22cfa60f4ed9553556534.zip
removed virtual/mta from DEPEND and added warning about configuring mta
(Portage version: 2.1.2_pre3-r1)
Diffstat (limited to 'dev-util')
-rw-r--r--dev-util/darcs/ChangeLog6
-rw-r--r--dev-util/darcs/darcs-1.0.7.ebuild18
-rw-r--r--dev-util/darcs/darcs-1.0.8-r1.ebuild18
3 files changed, 35 insertions, 7 deletions
diff --git a/dev-util/darcs/ChangeLog b/dev-util/darcs/ChangeLog
index 72bdad53136f..67da3b682757 100644
--- a/dev-util/darcs/ChangeLog
+++ b/dev-util/darcs/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-util/darcs
# Copyright 2000-2006 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/ChangeLog,v 1.60 2006/10/07 10:08:46 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/ChangeLog,v 1.61 2006/10/16 22:08:53 cparrott Exp $
+
+ 16 Oct 2006; Chris Parrott <cparrott@gentoo.org> darcs-1.0.7.ebuild,
+ darcs-1.0.8-r1.ebuild:
+ remove virtual/mta from DEPEND and add warning about mta
07 Oct 2006; Andres Loeh <kosmikus@gentoo.org> darcs-1.0.8-r1.ebuild:
Undo ghc-6.6-specific changes to darcs ebuild, hopefully fixing bug #150326
diff --git a/dev-util/darcs/darcs-1.0.7.ebuild b/dev-util/darcs/darcs-1.0.7.ebuild
index d0ba2d7deee6..7b01f05b4ba1 100644
--- a/dev-util/darcs/darcs-1.0.7.ebuild
+++ b/dev-util/darcs/darcs-1.0.7.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.7.ebuild,v 1.1 2006/06/16 17:34:59 dcoutts Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.7.ebuild,v 1.2 2006/10/16 22:08:53 cparrott Exp $
-inherit base
+inherit base autotools
DESCRIPTION="David's Advanced Revision Control System is yet another replacement for CVS"
HOMEPAGE="http://abridgegame.org/darcs"
@@ -16,7 +16,6 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="doc"
DEPEND=">=net-misc/curl-7.10.2
- virtual/mta
>=virtual/ghc-6.2.2
doc? ( virtual/tetex
>=dev-tex/latex2html-2002.2.1_pre20041025-r1 )"
@@ -29,6 +28,9 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
base_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}/darcs-1.0.8-ghc66.patch"
+
# If we're going to use the CFLAGS with GHC's -optc flag then we'd better
# use it with -opta too or it'll break with some CFLAGS, eg -mcpu on sparc
sed -i 's:\($(addprefix -optc,$(CFLAGS))\):\1 $(addprefix -opta,$(CFLAGS)):' \
@@ -40,6 +42,9 @@ src_unpack() {
}
src_compile() {
+ # Since we've patched the build system:
+ eautoreconf
+
econf $(use_with doc docs) \
|| die "configure failed"
emake all || die "make failed"
@@ -56,3 +61,10 @@ src_install() {
dohtml "${S}/manual/"*
fi
}
+
+pkg_postinst() {
+ ewarn "NOTE: in order for the darcs send command to work properly,"
+ ewarn "you must properly configure your mail transport agent to relay"
+ ewarn "outgoing mail. For example, if you are using ssmtp, please edit"
+ ewarn "/etc/ssmtp/ssmtp.conf with appropriate values for your site."
+}
diff --git a/dev-util/darcs/darcs-1.0.8-r1.ebuild b/dev-util/darcs/darcs-1.0.8-r1.ebuild
index 3241bb5d230e..a60aac7130f8 100644
--- a/dev-util/darcs/darcs-1.0.8-r1.ebuild
+++ b/dev-util/darcs/darcs-1.0.8-r1.ebuild
@@ -1,8 +1,8 @@
# Copyright 1999-2006 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.8-r1.ebuild,v 1.2 2006/10/07 10:08:46 kosmikus Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-util/darcs/darcs-1.0.8-r1.ebuild,v 1.3 2006/10/16 22:08:53 cparrott Exp $
-inherit base
+inherit base autotools
DESCRIPTION="David's Advanced Revision Control System is yet another replacement for CVS"
HOMEPAGE="http://abridgegame.org/darcs"
@@ -16,7 +16,6 @@ KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~ppc64 ~sparc ~x86 ~x86-fbsd"
IUSE="doc"
DEPEND=">=net-misc/curl-7.10.2
- virtual/mta
>=virtual/ghc-6.2.2
doc? ( virtual/tetex
>=dev-tex/latex2html-2002.2.1_pre20041025-r1 )"
@@ -29,6 +28,9 @@ S=${WORKDIR}/${MY_P}
src_unpack() {
base_src_unpack
+ cd "${S}"
+ epatch "${FILESDIR}/${P}-ghc66.patch"
+
# If we're going to use the CFLAGS with GHC's -optc flag then we'd better
# use it with -opta too or it'll break with some CFLAGS, eg -mcpu on sparc
sed -i 's:\($(addprefix -optc,$(CFLAGS))\):\1 $(addprefix -opta,$(CFLAGS)):' \
@@ -40,6 +42,9 @@ src_unpack() {
}
src_compile() {
+ # Since we've patched the build system:
+ eautoreconf
+
econf $(use_with doc docs) \
|| die "configure failed"
emake all || die "make failed"
@@ -64,3 +69,10 @@ src_install() {
dohtml -r "${S}/manual/"*
fi
}
+
+pkg_postinst() {
+ ewarn "NOTE: in order for the darcs send command to work properly,"
+ ewarn "you must properly configure your mail transport agent to relay"
+ ewarn "outgoing mail. For example, if you are using ssmtp, please edit"
+ ewarn "/etc/ssmtp/ssmtp.conf with appropriate values for your site."
+}