summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-25 21:25:47 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-03-25 21:25:47 +0000
commit8fb2eeb671579f4d7f331b799d6f2170d6fd3b41 (patch)
treec5aec8d3b4cc9a85a29478d4e4dedae3f76c8d34 /dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild
parentStable on amd64 wrt bug #327725 (diff)
downloadgentoo-2-8fb2eeb671579f4d7f331b799d6f2170d6fd3b41.tar.gz
gentoo-2-8fb2eeb671579f4d7f331b799d6f2170d6fd3b41.tar.bz2
gentoo-2-8fb2eeb671579f4d7f331b799d6f2170d6fd3b41.zip
Set SUPPORT_PYTHON_ABIS (bug #329477).
(Portage version: 2.2.0_alpha28_p7/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild')
-rw-r--r--dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild20
1 files changed, 15 insertions, 5 deletions
diff --git a/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild b/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild
index 733cb813894b..b8a43204c7c0 100644
--- a/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild
+++ b/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild
@@ -1,10 +1,13 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild,v 1.3 2010/06/22 18:43:49 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/cvs2svn/cvs2svn-2.2.0.ebuild,v 1.4 2011/03/25 21:25:47 arfrever Exp $
EAPI="2"
+PYTHON_DEPEND="2"
PYTHON_USE_WITH_OR="berkdb gdbm"
PYTHON_USE_WITH_OPT="test"
+SUPPORT_PYTHON_ABIS="1"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit eutils distutils
@@ -19,16 +22,18 @@ SLOT="0"
KEYWORDS="~alpha ~amd64 ~ia64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
IUSE="bazaar git test"
-DEPEND="dev-lang/python
- >=dev-vcs/subversion-1.0.9"
+DEPEND=">=dev-vcs/subversion-1.0.9"
RDEPEND="${DEPEND}
bazaar? ( >=dev-vcs/bzr-1.13 )
git? ( >=dev-vcs/git-1.5.4.4 )
dev-vcs/rcs"
+PYTHON_MODNAME="cvs2svn_lib cvs2svn_rcsparse"
+
src_prepare() {
epatch "${FILESDIR}/2.2.0-deprecated-modules.patch"
distutils_src_prepare
+ python_convert_shebangs -r 2 .
}
src_install() {
@@ -41,10 +46,15 @@ src_install() {
src_test() {
# Need this because subversion is localized, but the tests aren't
export LC_ALL=C
- python -W ignore run-tests.py || die "tests failed"
+
+ testing() {
+ "$(PYTHON)" -W ignore run-tests.py
+ }
+ python_execute_function testing
}
pkg_postinst() {
+ distutils_pkg_postinst
elog "Additional scripts and examples have been installed to:"
elog " /usr/share/${PN}/"
}