summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorRafael Martins <rafaelmartins@gentoo.org>2010-11-02 06:34:58 +0000
committerRafael Martins <rafaelmartins@gentoo.org>2010-11-02 06:34:58 +0000
commit5819c2ecd63e5c06be53457ffb45d0e5e490aa28 (patch)
tree59e5eeaf1ec59f499b9d3871a57cf276a60ff629 /dev-vcs/fossil
parentStable for HPPA (bug #343473). (diff)
downloadgentoo-2-5819c2ecd63e5c06be53457ffb45d0e5e490aa28.tar.gz
gentoo-2-5819c2ecd63e5c06be53457ffb45d0e5e490aa28.tar.bz2
gentoo-2-5819c2ecd63e5c06be53457ffb45d0e5e490aa28.zip
Version bump.
(Portage version: 2.2.0_alpha3/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/ChangeLog8
-rw-r--r--dev-vcs/fossil/files/20101101142335-gentoo.patch28
-rw-r--r--dev-vcs/fossil/fossil-20101101142335.ebuild38
3 files changed, 73 insertions, 1 deletions
diff --git a/dev-vcs/fossil/ChangeLog b/dev-vcs/fossil/ChangeLog
index b58d333998dc..ab6a655eb8ea 100644
--- a/dev-vcs/fossil/ChangeLog
+++ b/dev-vcs/fossil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/fossil
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.5 2010/10/20 05:31:21 rafaelmartins Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.6 2010/11/02 06:34:58 rafaelmartins Exp $
+
+*fossil-20101101142335 (02 Nov 2010)
+
+ 02 Nov 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
+ +files/20101101142335-gentoo.patch, +fossil-20101101142335.ebuild:
+ Version bump.
20 Oct 2010; Rafael G. Martins <rafaelmartins@gentoo.org>
fossil-20100918155143.ebuild, fossil-20101005035549.ebuild:
diff --git a/dev-vcs/fossil/files/20101101142335-gentoo.patch b/dev-vcs/fossil/files/20101101142335-gentoo.patch
new file mode 100644
index 000000000000..9af6ac0371d8
--- /dev/null
+++ b/dev-vcs/fossil/files/20101101142335-gentoo.patch
@@ -0,0 +1,28 @@
+diff -uNr fossil-src-20101101142335.orig/Makefile fossil-src-20101101142335/Makefile
+--- fossil-src-20101101142335.orig/Makefile 2010-11-01 15:16:44.000000000 -0200
++++ fossil-src-20101101142335/Makefile 2010-11-02 04:14:27.645206756 -0200
+@@ -42,7 +42,7 @@
+ # so that we can build a static executable that will run in a
+ # chroot jail.
+ #
+-LIB = -lz $(LDFLAGS)
++LIB = -lz -lsqlite3
+
+ # If using HTTPS:
+ LIB += -lcrypto -lssl
+diff -uNr fossil-src-20101101142335.orig/src/main.mk fossil-src-20101101142335/src/main.mk
+--- fossil-src-20101101142335.orig/src/main.mk 2010-11-01 15:16:44.000000000 -0200
++++ fossil-src-20101101142335/src/main.mk 2010-11-02 04:19:50.511128354 -0200
+@@ -266,10 +266,10 @@
+ awk '{ printf "#define MANIFEST_VERSION \"[%.10s]\"\n", $$1}' $(SRCDIR)/../manifest.uuid >>VERSION.h
+ awk '$$1=="D"{printf "#define MANIFEST_DATE \"%s %s\"\n", substr($$2,1,10),substr($$2,12)}' $(SRCDIR)/../manifest >>VERSION.h
+
+-EXTRAOBJ = $(OBJDIR)/sqlite3.o $(OBJDIR)/shell.o $(OBJDIR)/th.o $(OBJDIR)/th_lang.o
++EXTRAOBJ = $(OBJDIR)/shell.o $(OBJDIR)/th.o $(OBJDIR)/th_lang.o
+
+ $(APPNAME): headers $(OBJ) $(EXTRAOBJ)
+- $(TCC) -o $(APPNAME) $(OBJ) $(EXTRAOBJ) $(LIB)
++ $(TCC) $(LDFLAGS) -o $(APPNAME) $(OBJ) $(EXTRAOBJ) $(LIB)
+
+ # This rule prevents make from using its default rules to try build
+ # an executable named "manifest" out of the file named "manifest.c"
diff --git a/dev-vcs/fossil/fossil-20101101142335.ebuild b/dev-vcs/fossil/fossil-20101101142335.ebuild
new file mode 100644
index 000000000000..d7dda6f8cdea
--- /dev/null
+++ b/dev-vcs/fossil/fossil-20101101142335.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20101101142335.ebuild,v 1.1 2010/11/02 06:34:58 rafaelmartins Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-src-${PV}"
+
+DESCRIPTION="simple, high-reliability, distributed software configuration management"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND=">=dev-db/sqlite-3.7.0
+ dev-libs/openssl
+ sys-libs/zlib"
+RDEPEND="${DEPEND}"
+
+S="${WORKDIR}/${MY_P}"
+
+src_prepare() {
+ epatch "${FILESDIR}/${PV}-gentoo.patch"
+ sed -i \
+ -e "/^TCC *=/s:=.*:=$(tc-getCC) -Wall \$(CFLAGS) \$(CPPFLAGS):" \
+ -e "/^BCC/s:gcc:$(tc-getBUILD_CC):" \
+ Makefile || die 'sed failed.'
+}
+
+src_install() {
+ dobin fossil || die 'dobin failed.'
+ dodoc ci_cvs.txt ci_fossil.txt cvs2fossil.txt || die 'dodoc failed.'
+}