summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2010-05-19 07:52:44 +0000
committerJustin Lecher <jlec@gentoo.org>2010-05-19 07:52:44 +0000
commita82094276fc043222e9b90bcf797a8b2be703aea (patch)
treef495567947e66b663812e5d4ac5f9310d3cc5939 /dev-vcs/fossil
parentApply fixes per bug #320475. Thx to Andrew Brouwers for testing. (diff)
downloadgentoo-2-a82094276fc043222e9b90bcf797a8b2be703aea.tar.gz
gentoo-2-a82094276fc043222e9b90bcf797a8b2be703aea.tar.bz2
gentoo-2-a82094276fc043222e9b90bcf797a8b2be703aea.zip
Version Bump #319503; unbundle sqlite; link as-needed conform
(Portage version: 2.2_rc67/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/fossil')
-rw-r--r--dev-vcs/fossil/ChangeLog8
-rw-r--r--dev-vcs/fossil/files/20100318142033-gentoo.patch29
-rw-r--r--dev-vcs/fossil/fossil-20100318142033.ebuild38
3 files changed, 74 insertions, 1 deletions
diff --git a/dev-vcs/fossil/ChangeLog b/dev-vcs/fossil/ChangeLog
index 1c6c6f006d1b..aa22726df4ba 100644
--- a/dev-vcs/fossil/ChangeLog
+++ b/dev-vcs/fossil/ChangeLog
@@ -1,6 +1,12 @@
# ChangeLog for dev-vcs/fossil
# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.1 2010/05/07 18:44:33 ulm Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/ChangeLog,v 1.2 2010/05/19 07:52:44 jlec Exp $
+
+*fossil-20100318142033 (19 May 2010)
+
+ 19 May 2010; Justin Lecher <jlec@gentoo.org>
+ +files/20100318142033-gentoo.patch, +fossil-20100318142033.ebuild:
+ Version Bump #319503; unbundle sqlite; link as-needed conform
07 May 2010; Ulrich Mueller <ulm@gentoo.org>
+fossil-20100124175507.ebuild, +metadata.xml:
diff --git a/dev-vcs/fossil/files/20100318142033-gentoo.patch b/dev-vcs/fossil/files/20100318142033-gentoo.patch
new file mode 100644
index 000000000000..751327cf56c7
--- /dev/null
+++ b/dev-vcs/fossil/files/20100318142033-gentoo.patch
@@ -0,0 +1,29 @@
+diff --git a/Makefile b/Makefile
+index 18d5ea5..962e295 100644
+--- a/Makefile
++++ b/Makefile
+@@ -40,7 +40,8 @@ TCC += -DFOSSIL_ENABLE_SSL
+ # so that we can build a static executable that will run in a
+ # chroot jail.
+ #
+-LIB = -lz $(LDFLAGS)
++
++LIB = -lz -lsqlite3
+ # If you're on OpenSolaris:
+ # LIB += lsocket
+ # Solaris 10 needs:
+diff --git a/src/main.mk b/src/main.mk
+index 470bedd..a8bbc38 100644
+--- a/src/main.mk
++++ b/src/main.mk
+@@ -266,8 +266,8 @@ VERSION.h: $(SRCDIR)/../manifest.uuid $(SRCDIR)/../manifest
+ awk '{ printf "#define MANIFEST_VERSION \"[%.10s]\"\n", $$1}' $(SRCDIR)/../manifest.uuid >>VERSION.h
+ awk '$$1=="D"{printf "#define MANIFEST_DATE \"%s %s\"\n", substr($$2,1,10),substr($$2,12)}' $(SRCDIR)/../manifest >>VERSION.h
+
+-$(APPNAME): headers $(OBJ) $(OBJDIR)/sqlite3.o $(OBJDIR)/th.o $(OBJDIR)/th_lang.o
+- $(TCC) -o $(APPNAME) $(OBJ) $(OBJDIR)/sqlite3.o $(OBJDIR)/th.o $(OBJDIR)/th_lang.o $(LIB)
++$(APPNAME): headers $(OBJ) $(OBJDIR)/th.o $(OBJDIR)/th_lang.o
++ $(TCC) $(LDFLAGS) -o $(APPNAME) $(OBJ) $(OBJDIR)/th.o $(OBJDIR)/th_lang.o $(LIB)
+
+ # This rule prevents make from using its default rules to try build
+ # an executable named "manifest" out of the file named "manifest.c"
diff --git a/dev-vcs/fossil/fossil-20100318142033.ebuild b/dev-vcs/fossil/fossil-20100318142033.ebuild
new file mode 100644
index 000000000000..1ae5e9ef8d9b
--- /dev/null
+++ b/dev-vcs/fossil/fossil-20100318142033.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2010 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/fossil/fossil-20100318142033.ebuild,v 1.1 2010/05/19 07:52:44 jlec Exp $
+
+EAPI="2"
+
+inherit eutils toolchain-funcs
+
+MY_P="${PN}-src-${PV}"
+
+DESCRIPTION="simple, high-reliability, distributed software configuration management"
+HOMEPAGE="http://www.fossil-scm.org/"
+SRC_URI="http://www.fossil-scm.org/download/${MY_P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE=""
+
+DEPEND="
+ dev-libs/openssl
+ sys-libs/zlib"
+RDEPEND=${DEPEND}
+
+S="${WORKDIR}"/${MY_P}
+
+src_prepare() {
+ epatch "${FILESDIR}"/${PV}-gentoo.patch
+ sed -i \
+ -e "/^TCC *=/s:=.*:=$(tc-getCC) -Wall \$(CFLAGS) \$(CPPFLAGS):" \
+ -e "/^BCC/s:gcc:$(tc-getBUILD_CC):" \
+ Makefile || die
+}
+
+src_install() {
+ dobin fossil || die
+ dodoc ci_cvs.txt ci_fossil.txt cvs2fossil.txt || die
+}