summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorJustin Lecher <jlec@gentoo.org>2014-02-21 14:51:54 +0000
committerJustin Lecher <jlec@gentoo.org>2014-02-21 14:51:54 +0000
commita86e1bbffa631b09695dfe6f0141aa4e09c73ce1 (patch)
tree44ac9de7cbe3a2d092d0caba2d2d174c26197f12 /dev-vcs/git-cola
parentVersion bump. (diff)
downloadgentoo-2-a86e1bbffa631b09695dfe6f0141aa4e09c73ce1.tar.gz
gentoo-2-a86e1bbffa631b09695dfe6f0141aa4e09c73ce1.tar.bz2
gentoo-2-a86e1bbffa631b09695dfe6f0141aa4e09c73ce1.zip
dev-vcs/git-cola: Fix html doc installation, #472048; drop old
(Portage version: 2.2.8-r1/cvs/Linux x86_64, signed Manifest commit with key B9D4F231BD1558AB!)
Diffstat (limited to 'dev-vcs/git-cola')
-rw-r--r--dev-vcs/git-cola/ChangeLog7
-rw-r--r--dev-vcs/git-cola/git-cola-1.8.3.ebuild90
-rw-r--r--dev-vcs/git-cola/git-cola-1.8.5.ebuild91
-rw-r--r--dev-vcs/git-cola/git-cola-1.9.1.ebuild102
-rw-r--r--dev-vcs/git-cola/git-cola-1.9.3-r1.ebuild104
-rw-r--r--dev-vcs/git-cola/git-cola-1.9.3.ebuild103
-rw-r--r--dev-vcs/git-cola/git-cola-1.9.4.ebuild6
7 files changed, 8 insertions, 495 deletions
diff --git a/dev-vcs/git-cola/ChangeLog b/dev-vcs/git-cola/ChangeLog
index 7f9c87cb2e93..355b9ab92295 100644
--- a/dev-vcs/git-cola/ChangeLog
+++ b/dev-vcs/git-cola/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/git-cola
# Copyright 1999-2014 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.21 2014/01/31 07:31:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/ChangeLog,v 1.22 2014/02/21 14:51:54 jlec Exp $
+
+ 21 Feb 2014; Justin Lecher <jlec@gentoo.org> -git-cola-1.8.3.ebuild,
+ -git-cola-1.8.5.ebuild, -git-cola-1.9.1.ebuild, -git-cola-1.9.3.ebuild,
+ -git-cola-1.9.3-r1.ebuild, git-cola-1.9.4.ebuild:
+ Fix html doc installation, #472048; drop old
*git-cola-1.9.4 (31 Jan 2014)
diff --git a/dev-vcs/git-cola/git-cola-1.8.3.ebuild b/dev-vcs/git-cola/git-cola-1.8.3.ebuild
deleted file mode 100644
index 084ba95fb11f..000000000000
--- a/dev-vcs/git-cola/git-cola-1.8.3.ebuild
+++ /dev/null
@@ -1,90 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.8.3.ebuild,v 1.1 2013/06/22 11:07:01 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-DISTUTILS_SINGLE_IMPL=true
-
-inherit distutils-r1
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="http://git-cola.github.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/jsonpickle[${PYTHON_USEDEP}]
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/PyQt4[${PYTHON_USEDEP}]
- dev-vcs/git"
-DEPEND="${RDEPEND}
- app-text/asciidoc
- app-text/xmlto
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- sys-devel/gettext
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-# tests currently broken due to unfinished translation framework
-RESTRICT="test"
-
-PATCHES=(
- "${FILESDIR}"/1.3.8-disable-tests.patch
- "${FILESDIR}"/1.8.1-system-ssh-askpass.patch
- )
-
-python_prepare_all() {
- # don't install docs into wrong location
- sed -i \
- -e '/doc/d' \
- setup.py || die "sed failed"
-
- sed -i \
- -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
- cola/resources.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- cd share/doc/${PN}/
- if use doc ; then
- emake all
- else
- sed \
- -e '/^install:/s:install-html::g' \
- -i Makefile || die
- fi
-}
-
-python_install_all() {
- cd share/doc/${PN}/
- emake \
- DESTDIR="${D}" \
- docdir="${EPREFIX}/usr/share/doc/${PF}" \
- prefix="${EPREFIX}/usr" \
- install
-
- if ! use doc ; then
- HTML_DOCS=( "${FILESDIR}"/index.html )
- fi
-
- distutils-r1_python_install_all
-}
-
-python_test() {
- PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
- --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
- || die "running nosetests failed"
-}
-
-pkg_postinst() {
- elog "Please make sure you have either a SSH key management installed and activated or"
- elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
- elog "Otherwise ${PN} may hang when pushing/pulling from remote git repositories via SSH. "
-}
diff --git a/dev-vcs/git-cola/git-cola-1.8.5.ebuild b/dev-vcs/git-cola/git-cola-1.8.5.ebuild
deleted file mode 100644
index 5b25565f29dc..000000000000
--- a/dev-vcs/git-cola/git-cola-1.8.5.ebuild
+++ /dev/null
@@ -1,91 +0,0 @@
-# Copyright 1999-2013 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.8.5.ebuild,v 1.2 2013/10/12 02:35:47 patrick Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-DISTUTILS_SINGLE_IMPL=true
-
-inherit distutils-r1
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="http://git-cola.github.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/jsonpickle[${PYTHON_USEDEP}]
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/PyQt4[${PYTHON_USEDEP}]
- dev-vcs/git"
-DEPEND="${RDEPEND}
- app-text/asciidoc
- app-text/xmlto
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- sys-devel/gettext
- test? ( dev-python/nose[${PYTHON_USEDEP}] )"
-
-PATCHES=(
- "${FILESDIR}"/1.3.8-disable-tests.patch
- "${FILESDIR}"/1.8.1-system-ssh-askpass.patch
- )
-
-python_prepare_all() {
- # unfinished translate framework
- rm test/test_cola_i18n.py || die
- # don't install docs into wrong location
- sed -i \
- -e '/doc/d' \
- setup.py || die "sed failed"
-
- sed -i \
- -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
- cola/resources.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- cd share/doc/${PN}/
- if use doc ; then
- emake all
- else
- sed \
- -e '/^install:/s:install-html::g' \
- -i Makefile || die
- fi
-}
-
-python_install_all() {
- cd share/doc/${PN}/ || die
- emake \
- DESTDIR="${D}" \
- docdir="${EPREFIX}/usr/share/doc/${PF}" \
- prefix="${EPREFIX}/usr" \
- install
-
- if use doc ; then
- HTML_DOCS=( share/doc/${PN}/_build/html/. )
- else
- HTML_DOCS=( "${FILESDIR}"/index.html )
- fi
-
- distutils-r1_python_install_all
-}
-
-python_test() {
- PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
- --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
- || die "running nosetests failed"
-}
-
-pkg_postinst() {
- elog "Please make sure you have either a SSH key management installed and activated or"
- elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
- elog "Otherwise ${PN} may hang when pushing/pulling from remote git repositories via SSH. "
-}
diff --git a/dev-vcs/git-cola/git-cola-1.9.1.ebuild b/dev-vcs/git-cola/git-cola-1.9.1.ebuild
deleted file mode 100644
index b6a42c0f8436..000000000000
--- a/dev-vcs/git-cola/git-cola-1.9.1.ebuild
+++ /dev/null
@@ -1,102 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.1.ebuild,v 1.2 2014/01/19 19:04:32 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-DISTUTILS_SINGLE_IMPL=true
-
-inherit distutils-r1
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="http://git-cola.github.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/jsonpickle[${PYTHON_USEDEP}]
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/PyQt4[${PYTHON_USEDEP}]
- dev-vcs/git"
-DEPEND="${RDEPEND}
- app-text/asciidoc
- app-text/xmlto
- sys-devel/gettext
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- sys-apps/net-tools
- )"
-
-PATCHES=(
- "${FILESDIR}"/${PV}-disable-tests.patch
- "${FILESDIR}"/${P}-system-ssh-askpass.patch
- )
-
-pkg_pretend() {
- if use test && [[ -z "$(hostname -d)" ]] ; then
- die "Test will fail if no domain is set"
- fi
-}
-python_prepare_all() {
- rm share/git-cola/bin/*askpass* || die
-
- # unfinished translate framework
- rm test/test_cola_i18n.py || die
-
- # don't install docs into wrong location
- sed -i \
- -e '/doc/d' \
- setup.py || die "sed failed"
-
- sed -i \
- -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
- cola/resources.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- cd share/doc/${PN}/
- if use doc ; then
- emake all
- else
- sed \
- -e '/^install:/s:install-html::g' \
- -i Makefile || die
- fi
-}
-
-python_install_all() {
- cd share/doc/${PN}/ || die
- emake \
- DESTDIR="${D}" \
- docdir="${EPREFIX}/usr/share/doc/${PF}" \
- prefix="${EPREFIX}/usr" \
- install
-
- if use doc ; then
- HTML_DOCS=( share/doc/${PN}/_build/html/. )
- else
- HTML_DOCS=( "${FILESDIR}"/index.html )
- fi
-
- distutils-r1_python_install_all
-}
-
-python_test() {
- PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
- --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
- || die "running nosetests failed"
-}
-
-pkg_postinst() {
- elog "Please make sure you have either a SSH key management installed and activated or"
- elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
- elog "Otherwise ${PN} may hang when pushing/pulling from remote git repositories via SSH. "
-}
diff --git a/dev-vcs/git-cola/git-cola-1.9.3-r1.ebuild b/dev-vcs/git-cola/git-cola-1.9.3-r1.ebuild
deleted file mode 100644
index 9b0c5fef08fa..000000000000
--- a/dev-vcs/git-cola/git-cola-1.9.3-r1.ebuild
+++ /dev/null
@@ -1,104 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.3-r1.ebuild,v 1.1 2014/01/29 11:55:12 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-DISTUTILS_SINGLE_IMPL=true
-
-inherit distutils-r1
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="http://git-cola.github.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/jsonpickle[${PYTHON_USEDEP}]
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/PyQt4[${PYTHON_USEDEP}]
- dev-vcs/git"
-DEPEND="${RDEPEND}
- app-text/asciidoc
- app-text/xmlto
- sys-devel/gettext
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- sys-apps/net-tools
- )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-disable-tests.patch
- "${FILESDIR}"/${PN}-1.9.1-system-ssh-askpass.patch
- )
-
-pkg_pretend() {
- if use test && [[ -z "$(hostname -d)" ]] ; then
- die "Test will fail if no domain is set"
- fi
-}
-
-python_prepare_all() {
- rm share/git-cola/bin/*askpass* || die
-
- # unfinished translate framework
- rm test/i18n_test.py || die
-
- # don't install docs into wrong location
- sed -i \
- -e '/doc/d' \
- setup.py || die "sed failed"
-
- sed -i \
- -e "s|'doc', 'git-cola'|'doc', '${PF}'|" \
- cola/resources.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- cd share/doc/${PN}/
- if use doc ; then
- emake all
- else
- sed \
- -e '/^install:/s:install-html::g' \
- -i Makefile || die
- fi
-}
-
-python_install_all() {
- cd share/doc/${PN}/ || die
- emake \
- DESTDIR="${D}" \
- docdir="${EPREFIX}/usr/share/doc/${PF}" \
- prefix="${EPREFIX}/usr" \
- install
-
- if use doc ; then
- HTML_DOCS=( share/doc/${PN}/_build/html/. )
- else
- HTML_DOCS=( "${FILESDIR}"/index.html )
- fi
-
- distutils-r1_python_install_all
- docompress /usr/share/doc/${PF}/git-cola.txt
-}
-
-python_test() {
- PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
- --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
- || die "running nosetests failed"
-}
-
-pkg_postinst() {
- elog "Please make sure you have either a SSH key management installed and activated or"
- elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
- elog "Otherwise ${PN} may hang when pushing/pulling from remote git repositories via SSH. "
-}
diff --git a/dev-vcs/git-cola/git-cola-1.9.3.ebuild b/dev-vcs/git-cola/git-cola-1.9.3.ebuild
deleted file mode 100644
index c707607c28b6..000000000000
--- a/dev-vcs/git-cola/git-cola-1.9.3.ebuild
+++ /dev/null
@@ -1,103 +0,0 @@
-# Copyright 1999-2014 Gentoo Foundation
-# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.3.ebuild,v 1.2 2014/01/19 19:04:32 jlec Exp $
-
-EAPI=5
-
-PYTHON_COMPAT=( python{2_6,2_7} )
-DISTUTILS_SINGLE_IMPL=true
-
-inherit distutils-r1
-
-DESCRIPTION="The highly caffeinated git GUI"
-HOMEPAGE="http://git-cola.github.com/"
-SRC_URI="https://github.com/${PN}/${PN}/archive/v${PV}.tar.gz -> ${P}.tar.gz"
-
-LICENSE="GPL-2"
-SLOT="0"
-KEYWORDS="~amd64 ~x86 ~amd64-linux ~x86-linux"
-IUSE="doc test"
-
-RDEPEND="
- dev-python/jsonpickle[${PYTHON_USEDEP}]
- dev-python/pyinotify[${PYTHON_USEDEP}]
- dev-python/PyQt4[${PYTHON_USEDEP}]
- dev-vcs/git"
-DEPEND="${RDEPEND}
- app-text/asciidoc
- app-text/xmlto
- sys-devel/gettext
- doc? ( dev-python/sphinx[${PYTHON_USEDEP}] )
- test? (
- dev-python/nose[${PYTHON_USEDEP}]
- sys-apps/net-tools
- )"
-
-PATCHES=(
- "${FILESDIR}"/${P}-disable-tests.patch
- "${FILESDIR}"/${PN}-1.9.1-system-ssh-askpass.patch
- )
-
-pkg_pretend() {
- if use test && [[ -z "$(hostname -d)" ]] ; then
- die "Test will fail if no domain is set"
- fi
-}
-
-python_prepare_all() {
- rm share/git-cola/bin/*askpass* || die
-
- # unfinished translate framework
- rm test/i18n_test.py || die
-
- # don't install docs into wrong location
- sed -i \
- -e '/doc/d' \
- setup.py || die "sed failed"
-
- sed -i \
- -e "s|'doc', 'git-cola'|'doc', '${PF}', 'html'|" \
- cola/resources.py || die "sed failed"
-
- distutils-r1_python_prepare_all
-}
-
-python_compile_all() {
- cd share/doc/${PN}/
- if use doc ; then
- emake all
- else
- sed \
- -e '/^install:/s:install-html::g' \
- -i Makefile || die
- fi
-}
-
-python_install_all() {
- cd share/doc/${PN}/ || die
- emake \
- DESTDIR="${D}" \
- docdir="${EPREFIX}/usr/share/doc/${PF}" \
- prefix="${EPREFIX}/usr" \
- install
-
- if use doc ; then
- HTML_DOCS=( share/doc/${PN}/_build/html/. )
- else
- HTML_DOCS=( "${FILESDIR}"/index.html )
- fi
-
- distutils-r1_python_install_all
-}
-
-python_test() {
- PYTHONPATH="${S}:${S}/build/lib:${PYTHONPATH}" LC_ALL="C" nosetests \
- --verbose --with-doctest --with-id --exclude=jsonpickle --exclude=json \
- || die "running nosetests failed"
-}
-
-pkg_postinst() {
- elog "Please make sure you have either a SSH key management installed and activated or"
- elog "installed a SSH askpass app like net-misc/x11-ssh-askpass."
- elog "Otherwise ${PN} may hang when pushing/pulling from remote git repositories via SSH. "
-}
diff --git a/dev-vcs/git-cola/git-cola-1.9.4.ebuild b/dev-vcs/git-cola/git-cola-1.9.4.ebuild
index 403a2302375f..6327dd129f1a 100644
--- a/dev-vcs/git-cola/git-cola-1.9.4.ebuild
+++ b/dev-vcs/git-cola/git-cola-1.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2014 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.4.ebuild,v 1.1 2014/01/31 07:31:20 jlec Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git-cola/git-cola-1.9.4.ebuild,v 1.2 2014/02/21 14:51:54 jlec Exp $
EAPI=5
@@ -81,9 +81,7 @@ python_install_all() {
prefix="${EPREFIX}/usr" \
install
- if use doc ; then
- HTML_DOCS=( share/doc/${PN}/_build/html/. )
- else
+ if ! use doc ; then
HTML_DOCS=( "${FILESDIR}"/index.html )
fi