summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2012-06-14 05:01:30 +0000
committerMike Frysinger <vapier@gentoo.org>2012-06-14 05:01:30 +0000
commitd2fa58ccf14832565606dd6281050ae6de32695f (patch)
tree6bfabf623f1e8e45766f8e61de5f9d1043f32d67 /dev-vcs/git
parentalso add new USE=nls support to git-1.7.10 ebuilds (diff)
downloadgentoo-2-d2fa58ccf14832565606dd6281050ae6de32695f.tar.gz
gentoo-2-d2fa58ccf14832565606dd6281050ae6de32695f.tar.bz2
gentoo-2-d2fa58ccf14832565606dd6281050ae6de32695f.zip
Put gpg dep behind a USE flag as this signing requirement only really matters to the client side when signing is in use.
(Portage version: 2.2.0_alpha110/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/git')
-rw-r--r--dev-vcs/git/ChangeLog9
-rw-r--r--dev-vcs/git/git-1.7.10.2.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.10.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.9.1.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.9.2.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.9.3.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.9.4.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.9.7.ebuild6
-rw-r--r--dev-vcs/git/git-1.7.9.ebuild6
-rw-r--r--dev-vcs/git/git-9999.ebuild6
-rw-r--r--dev-vcs/git/metadata.xml1
11 files changed, 36 insertions, 28 deletions
diff --git a/dev-vcs/git/ChangeLog b/dev-vcs/git/ChangeLog
index b6ca16b3efd3..38eb4a885d97 100644
--- a/dev-vcs/git/ChangeLog
+++ b/dev-vcs/git/ChangeLog
@@ -1,6 +1,13 @@
# ChangeLog for dev-vcs/git
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.135 2012/06/14 04:57:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/ChangeLog,v 1.136 2012/06/14 05:01:30 vapier Exp $
+
+ 14 Jun 2012; Mike Frysinger <vapier@gentoo.org> git-1.7.10.2.ebuild,
+ git-1.7.10.ebuild, git-1.7.9.1.ebuild, git-1.7.9.2.ebuild, git-1.7.9.3.ebuild,
+ git-1.7.9.4.ebuild, git-1.7.9.7.ebuild, git-1.7.9.ebuild, git-9999.ebuild,
+ metadata.xml:
+ Put gpg dep behind a USE flag as this signing requirement only really matters
+ to the client side when signing is in use.
14 Jun 2012; Mike Frysinger <vapier@gentoo.org> git-1.7.9.1.ebuild,
git-1.7.9.2.ebuild, git-1.7.9.3.ebuild, git-1.7.9.4.ebuild,
diff --git a/dev-vcs/git/git-1.7.10.2.ebuild b/dev-vcs/git/git-1.7.10.2.ebuild
index 083b31e7b475..9cc604d18ff6 100644
--- a/dev-vcs/git/git-1.7.10.2.ebuild
+++ b/dev-vcs/git/git-1.7.10.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.2.ebuild,v 1.3 2012/06/14 04:57:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.2.ebuild,v 1.4 2012/06/14 05:01:30 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -57,7 +57,7 @@ CDEPEND="
emacs? ( virtual/emacs )"
RDEPEND="${CDEPEND}
- app-crypt/gnupg
+ gpg? ( app-crypt/gnupg )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
diff --git a/dev-vcs/git/git-1.7.10.ebuild b/dev-vcs/git/git-1.7.10.ebuild
index 138fbf74bbe5..e3888be3c603 100644
--- a/dev-vcs/git/git-1.7.10.ebuild
+++ b/dev-vcs/git/git-1.7.10.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.ebuild,v 1.4 2012/06/14 04:57:27 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.10.ebuild,v 1.5 2012/06/14 05:01:30 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -57,7 +57,7 @@ CDEPEND="
emacs? ( virtual/emacs )"
RDEPEND="${CDEPEND}
- app-crypt/gnupg
+ gpg? ( app-crypt/gnupg )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
diff --git a/dev-vcs/git/git-1.7.9.1.ebuild b/dev-vcs/git/git-1.7.9.1.ebuild
index f0ba3ae289e8..bc9b81b9ee40 100644
--- a/dev-vcs/git/git-1.7.9.1.ebuild
+++ b/dev-vcs/git/git-1.7.9.1.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.1.ebuild,v 1.4 2012/06/14 04:53:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.1.ebuild,v 1.5 2012/06/14 05:01:30 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -57,7 +57,7 @@ CDEPEND="
emacs? ( virtual/emacs )"
RDEPEND="${CDEPEND}
- app-crypt/gnupg
+ gpg? ( app-crypt/gnupg )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
diff --git a/dev-vcs/git/git-1.7.9.2.ebuild b/dev-vcs/git/git-1.7.9.2.ebuild
index 1777e72430d9..885567f37872 100644
--- a/dev-vcs/git/git-1.7.9.2.ebuild
+++ b/dev-vcs/git/git-1.7.9.2.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.2.ebuild,v 1.4 2012/06/14 04:53:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.2.ebuild,v 1.5 2012/06/14 05:01:30 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -57,7 +57,7 @@ CDEPEND="
emacs? ( virtual/emacs )"
RDEPEND="${CDEPEND}
- app-crypt/gnupg
+ gpg? ( app-crypt/gnupg )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
diff --git a/dev-vcs/git/git-1.7.9.3.ebuild b/dev-vcs/git/git-1.7.9.3.ebuild
index 3510526b1d12..53e5fcf28ab5 100644
--- a/dev-vcs/git/git-1.7.9.3.ebuild
+++ b/dev-vcs/git/git-1.7.9.3.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.3.ebuild,v 1.4 2012/06/14 04:53:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.3.ebuild,v 1.5 2012/06/14 05:01:30 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -57,7 +57,7 @@ CDEPEND="
emacs? ( virtual/emacs )"
RDEPEND="${CDEPEND}
- app-crypt/gnupg
+ gpg? ( app-crypt/gnupg )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
diff --git a/dev-vcs/git/git-1.7.9.4.ebuild b/dev-vcs/git/git-1.7.9.4.ebuild
index b942d61c0f87..1bca4749c6dd 100644
--- a/dev-vcs/git/git-1.7.9.4.ebuild
+++ b/dev-vcs/git/git-1.7.9.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.4.ebuild,v 1.4 2012/06/14 04:53:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.4.ebuild,v 1.5 2012/06/14 05:01:30 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -57,7 +57,7 @@ CDEPEND="
emacs? ( virtual/emacs )"
RDEPEND="${CDEPEND}
- app-crypt/gnupg
+ gpg? ( app-crypt/gnupg )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
diff --git a/dev-vcs/git/git-1.7.9.7.ebuild b/dev-vcs/git/git-1.7.9.7.ebuild
index 80d2b41ce5cc..69d88b96e76b 100644
--- a/dev-vcs/git/git-1.7.9.7.ebuild
+++ b/dev-vcs/git/git-1.7.9.7.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.7.ebuild,v 1.3 2012/06/14 04:53:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.7.ebuild,v 1.4 2012/06/14 05:01:30 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -57,7 +57,7 @@ CDEPEND="
emacs? ( virtual/emacs )"
RDEPEND="${CDEPEND}
- app-crypt/gnupg
+ gpg? ( app-crypt/gnupg )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
diff --git a/dev-vcs/git/git-1.7.9.ebuild b/dev-vcs/git/git-1.7.9.ebuild
index 4e40dd254600..e53a31588356 100644
--- a/dev-vcs/git/git-1.7.9.ebuild
+++ b/dev-vcs/git/git-1.7.9.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.ebuild,v 1.4 2012/06/14 04:53:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-1.7.9.ebuild,v 1.5 2012/06/14 05:01:30 vapier Exp $
EAPI=4
@@ -41,7 +41,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -57,7 +57,7 @@ CDEPEND="
emacs? ( virtual/emacs )"
RDEPEND="${CDEPEND}
- app-crypt/gnupg
+ gpg? ( app-crypt/gnupg )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
diff --git a/dev-vcs/git/git-9999.ebuild b/dev-vcs/git/git-9999.ebuild
index b723e2a5aeb7..09a2756c3d0a 100644
--- a/dev-vcs/git/git-9999.ebuild
+++ b/dev-vcs/git/git-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.33 2012/06/14 04:53:12 vapier Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/git/git-9999.ebuild,v 1.34 2012/06/14 05:01:30 vapier Exp $
EAPI=4
@@ -40,7 +40,7 @@ fi
LICENSE="GPL-2"
SLOT="0"
-IUSE="+blksha1 +curl cgi doc emacs gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
+IUSE="+blksha1 +curl cgi doc emacs +gpg gtk +iconv +nls +pcre +perl +python ppcsha1 tk +threads +webdav xinetd cvs subversion test"
# Common to both DEPEND and RDEPEND
CDEPEND="
@@ -56,7 +56,7 @@ CDEPEND="
emacs? ( virtual/emacs )"
RDEPEND="${CDEPEND}
- app-crypt/gnupg
+ gpg? ( app-crypt/gnupg )
perl? ( dev-perl/Error
dev-perl/Net-SMTP-SSL
dev-perl/Authen-SASL
diff --git a/dev-vcs/git/metadata.xml b/dev-vcs/git/metadata.xml
index 85188db6261c..52b84f64d19d 100644
--- a/dev-vcs/git/metadata.xml
+++ b/dev-vcs/git/metadata.xml
@@ -21,6 +21,7 @@
</longdescription>
<use>
<flag name="cgi">Install gitweb too</flag>
+ <flag name="gpg">Pull in gnupg for signing -- without gnupg, attempts at signing will fail at runtime!</flag>
<flag name="mozsha1">Makes git use an optimized SHA1 routine from Mozilla that should be fast on non-x86 machines.</flag>
<flag name="blksha1">Use the new optimized SHA1 implementation.</flag>
<flag name="ppcsha1">Make use of a bundled routine that is optimized for the PPC arch.</flag>