summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorAgostino Sarubbo <ago@gentoo.org>2011-12-16 21:31:43 +0000
committerAgostino Sarubbo <ago@gentoo.org>2011-12-16 21:31:43 +0000
commit48555f5e966c03e5ed329b853b74ef3b99b2a8df (patch)
treefd49a690ecd92bec668f8e292adf48a4dd54c33b /dev-vcs/mercurial
parentRemoved deprecated versions (diff)
downloadgentoo-2-48555f5e966c03e5ed329b853b74ef3b99b2a8df.tar.gz
gentoo-2-48555f5e966c03e5ed329b853b74ef3b99b2a8df.tar.bz2
gentoo-2-48555f5e966c03e5ed329b853b74ef3b99b2a8df.zip
Added die also to 9999 ebuild, thanks Arfrever for the hint bug #393287
(Portage version: 2.1.10.40/cvs/Linux i686)
Diffstat (limited to 'dev-vcs/mercurial')
-rw-r--r--dev-vcs/mercurial/ChangeLog5
-rw-r--r--dev-vcs/mercurial/mercurial-9999.ebuild26
2 files changed, 17 insertions, 14 deletions
diff --git a/dev-vcs/mercurial/ChangeLog b/dev-vcs/mercurial/ChangeLog
index 2cbf05664d18..af2d7ca13b41 100644
--- a/dev-vcs/mercurial/ChangeLog
+++ b/dev-vcs/mercurial/ChangeLog
@@ -1,6 +1,9 @@
# ChangeLog for dev-vcs/mercurial
# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.61 2011/12/15 20:40:48 ago Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/ChangeLog,v 1.62 2011/12/16 21:31:43 ago Exp $
+
+ 16 Dec 2011; Agostino Sarubbo <ago@gentoo.org> mercurial-9999.ebuild:
+ Added die also to 9999 ebuild, thanks Arfrever for the hint bug #393287
15 Dec 2011; Agostino Sarubbo <ago@gentoo.org> mercurial-2.0.1.ebuild:
Added '|| die' where missing, wrt bug #393287
diff --git a/dev-vcs/mercurial/mercurial-9999.ebuild b/dev-vcs/mercurial/mercurial-9999.ebuild
index 1fcdbd9321b8..1b7edb2a85de 100644
--- a/dev-vcs/mercurial/mercurial-9999.ebuild
+++ b/dev-vcs/mercurial/mercurial-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.10 2011/09/09 16:50:10 mgorny Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/mercurial/mercurial-9999.ebuild,v 1.11 2011/12/16 21:31:43 ago Exp $
EAPI=3
PYTHON_DEPEND="2"
@@ -42,12 +42,12 @@ src_compile() {
distutils_src_compile
if use emacs; then
- cd "${S}"/contrib
+ cd "${S}"/contrib || die
elisp-compile mercurial.el || die "elisp-compile failed!"
fi
rm -rf contrib/{win32,macosx}
- make doc
+ make doc || die
}
src_install() {
@@ -57,27 +57,27 @@ src_install() {
if use zsh-completion ; then
insinto /usr/share/zsh/site-functions
- newins contrib/zsh_completion _hg
+ newins contrib/zsh_completion _hg || die
fi
rm -f doc/*.?.txt
- dodoc CONTRIBUTORS README doc/*.txt
- cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/
+ dodoc CONTRIBUTORS README doc/*.txt || die
+ cp hgweb*.cgi "${ED}"/usr/share/doc/${PF}/ || die
- dobin hgeditor
- dobin contrib/hgk
- dobin contrib/hg-ssh
+ dobin hgeditor || die
+ dobin contrib/hgk || die
+ dobin contrib/hg-ssh || die
rm -f contrib/hgk contrib/hg-ssh
rm -f contrib/bash_completion
- cp -r contrib "${ED}"/usr/share/doc/${PF}/
- doman doc/*.?
+ cp -r contrib "${ED}"/usr/share/doc/${PF}/ || die
+ doman doc/*.? || die
cat > "${T}/80mercurial" <<-EOF
HG="${EPREFIX}/usr/bin/hg"
EOF
- doenvd "${T}/80mercurial"
+ doenvd "${T}/80mercurial" || die
if use emacs; then
elisp-install ${PN} contrib/mercurial.el* || die "elisp-install failed!"
@@ -86,7 +86,7 @@ EOF
}
src_test() {
- cd "${S}/tests/"
+ cd "${S}/tests/" || die
rm -rf *svn* # Subversion tests fail with 1.5
rm -f test-archive # Fails due to verbose tar output changes
rm -f test-convert-baz* # GNU Arch baz