summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorSebastian Pipping <sping@gentoo.org>2011-04-06 17:07:14 +0000
committerSebastian Pipping <sping@gentoo.org>2011-04-06 17:07:14 +0000
commit97a375c029ff2b4a8b57063ac8cac5d52ecfca3d (patch)
tree02ee5221b994c1ae2aa16269a83fd7c8baff0469 /dev-vcs/svn2git/svn2git-9999.ebuild
parentUse Python 2 (bug #361499). (diff)
downloadgentoo-2-97a375c029ff2b4a8b57063ac8cac5d52ecfca3d.tar.gz
gentoo-2-97a375c029ff2b4a8b57063ac8cac5d52ecfca3d.tar.bz2
gentoo-2-97a375c029ff2b4a8b57063ac8cac5d52ecfca3d.zip
dev-vcs/svn2git: Bump to 1.0.3
(Portage version: 2.1.9.45/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/svn2git/svn2git-9999.ebuild')
-rw-r--r--dev-vcs/svn2git/svn2git-9999.ebuild13
1 files changed, 8 insertions, 5 deletions
diff --git a/dev-vcs/svn2git/svn2git-9999.ebuild b/dev-vcs/svn2git/svn2git-9999.ebuild
index a97dd08528f3..ee1909ba2f9c 100644
--- a/dev-vcs/svn2git/svn2git-9999.ebuild
+++ b/dev-vcs/svn2git/svn2git-9999.ebuild
@@ -1,13 +1,13 @@
# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-9999.ebuild,v 1.4 2011/01/11 08:43:47 sping Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/svn2git/svn2git-9999.ebuild,v 1.5 2011/04/06 17:07:13 sping Exp $
EAPI="2"
-inherit eutils qt4-r2
+inherit versionator eutils qt4-r2
[ "$PV" == "9999" ] && inherit git
-MY_PV="1.0.2-1-gebac099"
+MY_PV=$(get_version_component_range 1-3)
DESCRIPTION="Tool for one-time conversion from svn to git."
HOMEPAGE="http://gitorious.org/svn2git/svn2git"
@@ -15,7 +15,7 @@ if [ "$PV" == "9999" ]; then
EGIT_REPO_URI="git://gitorious.org/svn2git/svn2git.git"
KEYWORDS=""
else
- SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${MY_PV} -> ${P}.tar.gz"
+ SRC_URI="http://gitorious.org/${PN}/${PN}/archive-tarball/${MY_PV} -> ${MY_PV}.tar.gz"
KEYWORDS="~amd64 ~x86"
fi
@@ -34,7 +34,10 @@ S=${WORKDIR}/${PN}-${PN}
src_prepare() {
# Note: patching order matters
epatch "${FILESDIR}"/${PN}-1.0.2.1-include-path.patch
- [ "$PV" != "9999" ] && epatch "${FILESDIR}"/${PN}-1.0.2.1-version.patch
+ if [[ "$PV" != "9999" ]]; then
+ epatch "${FILESDIR}"/${PN}-1.0.3_p1-version.patch
+ epatch "${FILESDIR}"/${PN}-1.0.3-backup-refs.patch
+ fi
qt4-r2_src_prepare
}