summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorMike Gilbert <floppym@gentoo.org>2012-05-07 18:09:13 +0000
committerMike Gilbert <floppym@gentoo.org>2012-05-07 18:09:13 +0000
commit2510ffbdcc9fbb5903c22ef07b270127d0cf2ac8 (patch)
tree6808101912d1f006d01226f5f7fdc81d8261267f /dev-vcs/tortoisehg
parentVersion bump. (diff)
downloadgentoo-2-2510ffbdcc9fbb5903c22ef07b270127d0cf2ac8.tar.gz
gentoo-2-2510ffbdcc9fbb5903c22ef07b270127d0cf2ac8.tar.bz2
gentoo-2-2510ffbdcc9fbb5903c22ef07b270127d0cf2ac8.zip
Sync live ebuild.
(Portage version: 2.2.0_alpha101/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs/tortoisehg')
-rw-r--r--dev-vcs/tortoisehg/ChangeLog6
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-2.4.ebuild9
-rw-r--r--dev-vcs/tortoisehg/tortoisehg-9999.ebuild24
3 files changed, 31 insertions, 8 deletions
diff --git a/dev-vcs/tortoisehg/ChangeLog b/dev-vcs/tortoisehg/ChangeLog
index 9e771b99f309..e75df0c95d7f 100644
--- a/dev-vcs/tortoisehg/ChangeLog
+++ b/dev-vcs/tortoisehg/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/tortoisehg
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.17 2012/05/07 18:04:45 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/ChangeLog,v 1.18 2012/05/07 18:09:13 floppym Exp $
+
+ 07 May 2012; Mike Gilbert <floppym@gentoo.org> tortoisehg-2.4.ebuild,
+ tortoisehg-9999.ebuild:
+ Sync live ebuild.
*tortoisehg-2.4 (07 May 2012)
diff --git a/dev-vcs/tortoisehg/tortoisehg-2.4.ebuild b/dev-vcs/tortoisehg/tortoisehg-2.4.ebuild
index 5b243caa7b6e..daa3e06c729a 100644
--- a/dev-vcs/tortoisehg/tortoisehg-2.4.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-2.4.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.4.ebuild,v 1.1 2012/05/07 18:04:45 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-2.4.ebuild,v 1.2 2012/05/07 18:09:13 floppym Exp $
EAPI=4
@@ -13,11 +13,13 @@ inherit distutils eutils multilib
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-2.1 <dev-vcs/mercurial-2.3"
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
KEYWORDS=""
SRC_URI=""
+ HG_DEPEND="dev-vcs/mercurial"
fi
DESCRIPTION="Set of graphical tools for Mercurial"
@@ -27,12 +29,11 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc nautilus"
-RDEPEND="dev-python/iniparse
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse
dev-python/pygments
dev-python/PyQt4
dev-python/qscintilla-python
- >=dev-vcs/mercurial-2.1
- <dev-vcs/mercurial-2.3
nautilus? ( dev-python/nautilus-python )"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
diff --git a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
index c52687fcadff..b15fe40ee16d 100644
--- a/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
+++ b/dev-vcs/tortoisehg/tortoisehg-9999.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.7 2012/05/07 18:04:45 floppym Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/tortoisehg/tortoisehg-9999.ebuild,v 1.8 2012/05/07 18:09:13 floppym Exp $
EAPI=4
@@ -13,11 +13,13 @@ inherit distutils eutils multilib
if [[ ${PV} != *9999* ]]; then
KEYWORDS="~amd64 ~x86"
SRC_URI="mirror://bitbucket/${PN}/targz/downloads/${P}.tar.gz"
+ HG_DEPEND=">=dev-vcs/mercurial-2.1 <dev-vcs/mercurial-2.3"
else
inherit mercurial
EHG_REPO_URI="https://bitbucket.org/tortoisehg/thg"
KEYWORDS=""
SRC_URI=""
+ HG_DEPEND="dev-vcs/mercurial"
fi
DESCRIPTION="Set of graphical tools for Mercurial"
@@ -27,11 +29,11 @@ LICENSE="GPL-2"
SLOT="0"
IUSE="doc nautilus"
-RDEPEND="dev-python/iniparse
+RDEPEND="${HG_DEPEND}
+ dev-python/iniparse
dev-python/pygments
dev-python/PyQt4
dev-python/qscintilla-python
- dev-vcs/mercurial
nautilus? ( dev-python/nautilus-python )"
DEPEND="${RDEPEND}
doc? ( >=dev-python/sphinx-1.0.3 )"
@@ -40,6 +42,22 @@ src_prepare() {
# make the install respect multilib.
sed -i -e "s:lib/nautilus:$(get_libdir)/nautilus:" setup.py || die
+ if [[ ${LINGUAS+set} ]]; then
+ pushd i18n/tortoisehg > /dev/null || die
+ local x y keep
+ for x in *.po; do
+ keep=
+ for y in ${LINGUAS}; do
+ if [[ ${y} == ${x%.po}* ]]; then
+ keep=1
+ break
+ fi
+ done
+ [[ ${keep} ]] || rm "${x}" || die
+ done
+ popd > /dev/null || die
+ fi
+
distutils_src_prepare
}