summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorThomas Sachau <tommy@gentoo.org>2012-08-22 20:33:11 +0000
committerThomas Sachau <tommy@gentoo.org>2012-08-22 20:33:11 +0000
commit3027f31dea8a379f2f7521f3c9475437061e6551 (patch)
tree0749a60a7d2559c5f7ac69663c7a4c7d8bab3a5e /dev-vcs
parentStable for x86, wrt bug #429190 (diff)
downloadgentoo-2-3027f31dea8a379f2f7521f3c9475437061e6551.tar.gz
gentoo-2-3027f31dea8a379f2f7521f3c9475437061e6551.tar.bz2
gentoo-2-3027f31dea8a379f2f7521f3c9475437061e6551.zip
Add patch for kwallet, upstream applied it to trunk, but did not include it in the following release, should now really fix bug 421575
(Portage version: 2.2.0_alpha116-r1/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/subversion/ChangeLog7
-rw-r--r--dev-vcs/subversion/files/subversion-1.7.6-kwallet.patch44
-rw-r--r--dev-vcs/subversion/subversion-1.7.6.ebuild5
3 files changed, 53 insertions, 3 deletions
diff --git a/dev-vcs/subversion/ChangeLog b/dev-vcs/subversion/ChangeLog
index 41b9f09aa4fa..8e6e51b5ba49 100644
--- a/dev-vcs/subversion/ChangeLog
+++ b/dev-vcs/subversion/ChangeLog
@@ -1,6 +1,11 @@
# ChangeLog for dev-vcs/subversion
# Copyright 1999-2012 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.81 2012/08/21 20:53:41 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/ChangeLog,v 1.82 2012/08/22 20:33:10 tommy Exp $
+
+ 22 Aug 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
+ subversion-1.7.6.ebuild, +files/subversion-1.7.6-kwallet.patch:
+ Add patch for kwallet, upstream applied it to trunk, but did not include it
+ in the following release, should now really fix bug 421575
21 Aug 2012; Thomas Sachau (Tommy[D]) <tommy@gentoo.org>
subversion-1.7.6.ebuild:
diff --git a/dev-vcs/subversion/files/subversion-1.7.6-kwallet.patch b/dev-vcs/subversion/files/subversion-1.7.6-kwallet.patch
new file mode 100644
index 000000000000..e568b88a3f46
--- /dev/null
+++ b/dev-vcs/subversion/files/subversion-1.7.6-kwallet.patch
@@ -0,0 +1,44 @@
+--- subversion/trunk/subversion/libsvn_auth_kwallet/kwallet.cpp 2012/03/21 18:22:15 1303489
++++ subversion/trunk/subversion/libsvn_auth_kwallet/kwallet.cpp 2012/06/03 18:54:26 1345740
+@@ -60,6 +60,9 @@
+ /* KWallet simple provider, puts passwords in KWallet */
+ /*-----------------------------------------------------------------------*/
+
++static int q_argc = 1;
++static char q_argv0[] = "svn"; // Build non-const char * from string constant
++static char *q_argv[] = { q_argv0 };
+
+ static const char *
+ get_application_name(apr_hash_t *parameters,
+@@ -212,12 +215,11 @@
+ QCoreApplication *app;
+ if (! qApp)
+ {
+- int argc = 1;
+- app = new QCoreApplication(argc, (char *[1]) {(char *) "svn"});
++ int argc = q_argc;
++ app = new QCoreApplication(argc, q_argv);
+ }
+
+- KCmdLineArgs::init(1,
+- (char *[1]) {(char *) "svn"},
++ KCmdLineArgs::init(q_argc, q_argv,
+ get_application_name(parameters, pool),
+ "subversion",
+ ki18n(get_application_name(parameters, pool)),
+@@ -289,12 +291,11 @@
+ QCoreApplication *app;
+ if (! qApp)
+ {
+- int argc = 1;
+- app = new QCoreApplication(argc, (char *[1]) {(char *) "svn"});
++ int argc = q_argc;
++ app = new QCoreApplication(argc, q_argv);
+ }
+
+- KCmdLineArgs::init(1,
+- (char *[1]) {(char *) "svn"},
++ KCmdLineArgs::init(q_argc, q_argv,
+ get_application_name(parameters, pool),
+ "subversion",
+ ki18n(get_application_name(parameters, pool)),
diff --git a/dev-vcs/subversion/subversion-1.7.6.ebuild b/dev-vcs/subversion/subversion-1.7.6.ebuild
index b4a05fbb2631..9a4423762b33 100644
--- a/dev-vcs/subversion/subversion-1.7.6.ebuild
+++ b/dev-vcs/subversion/subversion-1.7.6.ebuild
@@ -1,6 +1,6 @@
# Copyright 1999-2012 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.7.6.ebuild,v 1.2 2012/08/21 20:53:41 tommy Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/subversion/subversion-1.7.6.ebuild,v 1.3 2012/08/22 20:33:10 tommy Exp $
EAPI="3"
SUPPORT_PYTHON_ABIS="1"
@@ -109,7 +109,8 @@ src_prepare() {
"${FILESDIR}"/${PN}-1.5.6-aix-dso.patch \
"${FILESDIR}"/${PN}-1.6.3-hpux-dso.patch \
"${FILESDIR}"/${PN}-fix-parallel-build-support-for-perl-bindings.patch \
- "${FILESDIR}"/${P}-revert-mod_dontdothat-move.patch
+ "${FILESDIR}"/${P}-revert-mod_dontdothat-move.patch \
+ "${FILESDIR}"/${P}-kwallet.patch
fperms +x build/transform_libtool_scripts.sh