summaryrefslogtreecommitdiff
diff options
context:
space:
mode:
authorArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-18 12:55:44 +0000
committerArfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>2011-01-18 12:55:44 +0000
commit3e7d0e920370e7f02961eece30288fd02e1a7fa8 (patch)
treeabd4a620fecfed8426c23cd111d94fb99625d3ee /dev-vcs
parentAdded patch to compile against libevent-2, bug #333091 (diff)
downloadgentoo-2-3e7d0e920370e7f02961eece30288fd02e1a7fa8.tar.gz
gentoo-2-3e7d0e920370e7f02961eece30288fd02e1a7fa8.tar.bz2
gentoo-2-3e7d0e920370e7f02961eece30288fd02e1a7fa8.zip
Restrict Jython ABIs. Use python_get_sitedir() in correct scope (bug #351961).
(Portage version: 2.2.0_alpha17/cvs/Linux x86_64)
Diffstat (limited to 'dev-vcs')
-rw-r--r--dev-vcs/qct/ChangeLog8
-rw-r--r--dev-vcs/qct/qct-1.7.ebuild32
2 files changed, 30 insertions, 10 deletions
diff --git a/dev-vcs/qct/ChangeLog b/dev-vcs/qct/ChangeLog
index 99538c6bbb01..c1a6ce208ec7 100644
--- a/dev-vcs/qct/ChangeLog
+++ b/dev-vcs/qct/ChangeLog
@@ -1,6 +1,10 @@
# ChangeLog for dev-vcs/qct
-# Copyright 1999-2010 Gentoo Foundation; Distributed under the GPL v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qct/ChangeLog,v 1.8 2010/07/08 12:38:15 arfrever Exp $
+# Copyright 1999-2011 Gentoo Foundation; Distributed under the GPL v2
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qct/ChangeLog,v 1.9 2011/01/18 12:55:44 arfrever Exp $
+
+ 18 Jan 2011; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
+ qct-1.7.ebuild:
+ Restrict Jython ABIs. Use python_get_sitedir() in correct scope (bug #351961).
08 Jul 2010; Arfrever Frehtes Taifersar Arahesis <arfrever@gentoo.org>
qct-1.7.ebuild:
diff --git a/dev-vcs/qct/qct-1.7.ebuild b/dev-vcs/qct/qct-1.7.ebuild
index ad0898229463..43aba7642054 100644
--- a/dev-vcs/qct/qct-1.7.ebuild
+++ b/dev-vcs/qct/qct-1.7.ebuild
@@ -1,11 +1,11 @@
-# Copyright 1999-2010 Gentoo Foundation
+# Copyright 1999-2011 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qct/qct-1.7.ebuild,v 1.8 2010/07/08 12:38:15 arfrever Exp $
+# $Header: /var/cvsroot/gentoo-x86/dev-vcs/qct/qct-1.7.ebuild,v 1.9 2011/01/18 12:55:44 arfrever Exp $
EAPI="3"
PYTHON_DEPEND="2"
SUPPORT_PYTHON_ABIS="1"
-RESTRICT_PYTHON_ABIS="3.*"
+RESTRICT_PYTHON_ABIS="3.* *-jython"
inherit distutils
@@ -30,7 +30,17 @@ RDEPEND="${DEPEND}"
S="${WORKDIR}/${PN}"
-PYTHON_MODNAME="qctlib"
+pkg_setup() {
+ python_pkg_setup
+
+ PYTHON_MODNAME="qctlib"
+ if use bazaar; then
+ PYTHON_MODNAME+=" bzrlib/plugins/qctBzrPlugin.py"
+ fi
+ if use mercurial; then
+ PYTHON_MODNAME+=" hgext/qct.py"
+ fi
+}
src_prepare() {
distutils_src_prepare
@@ -57,13 +67,19 @@ src_install() {
dohtml doc/qct.1.html || die
if use bazaar; then
- insinto "$(python_get_sitedir)/bzrlib/plugins" || die
- doins plugins/qctBzrPlugin.py || die
+ install_bazaar_plugins() {
+ insinto "$(python_get_sitedir)/bzrlib/plugins" || return 1
+ doins plugins/qctBzrPlugin.py || return 1
+ }
+ python_execute_function -q install_bazaar_plugins
fi
if use mercurial; then
- insinto "$(python_get_sitedir)/hgext" || die
- doins hgext/qct.py || die
+ install_mercurial_extension() {
+ insinto "$(python_get_sitedir)/hgext" || return 1
+ doins hgext/qct.py || return 1
+ }
+ python_execute_function -q install_mercurial_extension
insinto /etc/mercurial/hgrc.d || die
doins "${FILESDIR}/qct.rc" || die
fi